Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-57752

Liferay Tooltip does not work in search container

    Details

    • Story Points:
      1.25

      Description

      Tested <liferay-ui:icon-help message="Does this work in search container?"/> inside a search container of a view.jsp for a portlet and it displays the question bubble, but no message is displayed when you hover over the icon.

      However, when I tried it on another jsp that isn't inside a search container, the icon works just as expected. Every time I mouse over it, the message "Does this work in search container?" will show up.

      This is where the code is being used.

       <liferay-ui:search-container searchContainer="${searchContainer}" emptyResultsMessage="there-are-currently-no-criteria">
      			<liferay-ui:search-container-row className="com.liferay.gsportal.scorecard.model.Criteria" modelVar="criteria">
      				<forEach: var="score" items="${ scoreList }">
      					<c:set var="criteriaId" value="${ criteria.criteriaId }"/>
      					<c:set var="scoreCriteria" value="${ score.criteriaId }"/>
      					<liferay-ui:icon-help message="Does this work in search container?"/>  

        Attachments

          Activity

            People

            • Assignee:
              haoliang.wu Haoliang Wu (Inactive)
              Reporter:
              daniel.song Daniel Song (Inactive)
              Participants of an Issue:
              Recent user:
              Esther Sanz
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                3 years, 17 weeks ago

                Packages

                Version Package
                6.2.X EE
                7.0.X EE
                Master