Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-58733

Custom Structure is lost when editing an article in a workflow through "My Workflow Tasks"

    Details

      Description

      Reproduction steps:

      1. Create a new structure (and corresponding template).
      2. Turn on single approver workflow for articles
      4. Create a new article with your structure, fill in some content and choose "Submit for publication"
      5. Kaleo generate a workflow task. Access the task under "My Workflow Tasks"
      6. Click the newly created task and assign it to yourself
      7. When article has been assigned to your user, click on the "Edit" link while reviewing the article.

      Actual Result: The article loads in a popup but the structure has been "lost". The value for the structure is "Default" and the fields are gone.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              felix.zhang Felix Zhang
              Reporter:
              tamas.molnar Tamas Molnar
              Participants of an Issue:
              Recent user:
              Esther Sanz
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                5 years, 5 weeks, 6 days ago

                  Packages

                  Version Package
                  6.2.4 CE GA5
                  6.2.X EE