Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-59636

Referencing an image from another Site in a Web Content doesn't work with Staging

    Details

      Description

      Steps to reproduce:

      1. Setup two different 6.2 Liferay portals
      2. On the first portal, create a two Sites: A and B
      3. On Site A, create one image in the doc library
      4. On Site B, create a Web content which includes image from Site A
      5. On the second portal create 2 sites : A and B (take care to have different Site IDs than those on staging env. If Ids are the same, you will not notice the issue)
      6. Enabla Remote Staging between the two Site As and the two Site Bs
      7. Full Publish the site A
      8. Full Publish the site B

      Result:
      On Site B image is not displayed correctly because the URL has NOT been converted, its URL still contains the Staging Site A ID.

      This will be a unique fix for 6.2, since the feature introduced by LPS-48299 can't be backported.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                lu.liu Lu Liu
                Reporter:
                gergely.mathe Gergely Mathe (Inactive)
                Participants of an Issue:
                Recent user:
                Esther Sanz
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  3 years, 26 weeks, 6 days ago

                  Packages

                  Version Package
                  6.2.X EE