Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-59869

LayoutFriendlyURLs aren't generated for system layouts if en_US is not present in locales property

    Details

      Description

      Reproduction steps:

      1. Set for example locales=de_DE and company.default.locale=de_DE in portal-ext.properties
      2. Start portal with a clean DB

      Result: When you try to hit welcome page you will get a 404 (In master/7.0, the Welcome page is rendered, though, you're unable to log in.)

      Expected result: Portal works fine

      Possible cause: CompanyThreadLocal and LocaleThreadLocal aren't set properly during checkCompany and LocaleUtil tries to fall back to en_US which is hardcoded as default languageId.

      UPDATE
      No longer reproducible on Master. Fixed by LPS-62798

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                norbert.kocsis Norbert Kocsis
                Reporter:
                norbert.kocsis Norbert Kocsis
                Participants of an Issue:
                Recent user:
                Esther Sanz
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  4 years, 3 weeks, 5 days ago

                  Packages

                  Version Package
                  7.0.0 CE RC1