Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-6165

When we create a new instance in Admin portlet, the installed third party portlets are not available for adding for this new instance

    Details

    • Branch Version/s:
      6.0.x, 5.2.x, 5.1.x
    • Backported to Branch:
      Committed

      Description

      Steps to reproduce

      1. Start Liferay server and login (as omni admin).
      2. Install any third party portlet (eg weather portlet from Sun MicroSystems) using Plugin Installer or Update manager
      3. Add a new instance using Admin portlet and add entry in the hosts file for this new instance unless DHCP server recognizes this already
      4. Open the new instance and login as admin.
      5. Notice that the installed portlet (eg. Weather portlet) is not in the list of available portlets for Add Applications menu. Just the Liferay portlets are available.
      6. Bounce the server and login again.
      7. This time the new portlet is in the list of available portlets in addition to the Liferay portlets.

      Expectation

      We expect that the installed portlets will be abailable for newly created instances as well.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              daeyoung.song Daeyoung Song (Inactive)
              Reporter:
              erict@ecollege.com Eric Thibeault (Inactive)
              Participants of an Issue:
              Recent user:
              Esther Sanz
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                11 years, 5 weeks, 4 days ago

                  Packages

                  Version Package
                  --Sprint - SP
                  6.1.0 CE RC1