Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-61829

Quick Reply feature in Message Boards doesn't work when Captcha is enabled in message boards because Captcha fails to appear

    Details

      Description

      Steps to reproduce:

      1. Add "captcha.check.portlet.message_boards.edit_message=true" to portal properties and start the server.
      2. Add a Message Boards portlet to a page.
      3. Post a new thread to the message board (Note that you should have to complete a Captcha challenge to successfully post your message).
      4. Select the "Quick Reply" option on the first post in the thread.

      Expected result: There is a Captcha beneath the space that allows the user to type their message.
      Actual result: There is no Captcha, so the user cannot verify that they are human. If the user clicks the "Publish" button, they will receive the error "Your request failed to complete.", and their message will not be published.

      Reproduced in:
      master (1063fb108ee9be3d4952a34a0dae2bcdc3a62f76)
      ee-6.2.x (e256baacf8c7c1888947f7e9e3b7687b559126bd)

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              harry.chai Harry Chai
              Reporter:
              michael.bowerman Michael Bowerman (Inactive)
              Participants of an Issue:
              Recent user:
              Esther Sanz
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                4 years, 47 weeks, 3 days ago

                  Packages

                  Version Package
                  Master