Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-62147

With structure and template, apostrophe characters in the abstract cause incorrect escaping of results.

    Details

      Description

      Steps to Reproduce

      1. Start a clean instance of liferay with hotfix-14774 installed
      2. Create a structure with a Text filed.
      3. Create a template for that structure and add a text element (just click the "text" option in the left menu).
      4. Create a web content using that structure and fill out "test" in both fields.
      5. Click the Abstract option in the right menu and fill in "test's" and save.
      6. On the home page, add a search portlet and type ":" in the search bar and search.

      Expected Result: the result would display "test's"
      Actual Result: the result displays "test&#039"

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ian.song Ian Song (Inactive)
                Reporter:
                eric.chi Eric Chi
                Participants of an Issue:
                Recent user:
                Esther Sanz
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  3 years, 35 weeks, 3 days ago

                  Packages

                  Version Package
                  6.2.X EE