Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-62293

Image rendered by a velocity template does not display in Web Content Display

    Details

    • Fix Priority:
      3

      Description

      Steps to reproduce:

      1. Navigate to Web Content admin
      2. Add a structure with an image field
      3. Open the dropdown for the added structure
      4. Select "Manage Templates"
      5. Add a template for the image structure
        • Under Details > Language, select "Velocity (.vm)"
        • Use the GUI to add the image field into the template
        • Save the template
      6. Add a web content article using the image structure
      7. Upload an image
      8. Publish the article
      9. Add Web Content Display to a page
      10. Select the image article
      11. Save
      12. View the article in WCD

      Expected result: Image displays in WCD
      Actual result: Image does not display in WCD.

      Note: The FreeMarker (.ftl) equivalent of the image template successfully renders the image in the web content display portlet.

      Reproduced on:
      Tomcat 7.0.62 + MySQL 5.6
      Portal Master GIT ID: 0ab06de9f166714afd0bc0273fdc770abd829bb5.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                anthony.chu Anthony Chu
                Reporter:
                anthony.chu Anthony Chu
                Participants of an Issue:
                Recent user:
                Esther Sanz
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  3 years, 39 weeks, 2 days ago

                  Packages

                  Version Package
                  7.0.0 Beta 4