Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-62788

Service builder throws error when plugin model implements hasSetModifiedDate

    Details

      Description

      1. Add
         	@Override
        	public boolean hasSetModifiedDate() {
        		return true;
        	}
        

        to any plugin's *Impl.java

      2. Run ant build-service

      Observe:

          [javac] ../liferay/trunk/liferay-plugins/webs/sync-web/docroot/WEB-INF/service/com/liferay/sync/model/SyncDeviceClp.java:48: error: SyncDeviceClp is not abstract and does not override abstract method hasSetModifiedDate() in SyncDevice
          [javac] public class SyncDeviceClp extends BaseModelImpl<SyncDevice>
          [javac]        ^
          [javac] Note: Some input files use unchecked or unsafe operations.
          [javac] Note: Recompile with -Xlint:unchecked for details.
          [javac] 1 error
      

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  3 years, 25 weeks, 2 days ago

                  Packages

                  Version Package
                  7.0.0 Beta 6