Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-63460

Form values aren't getting submitted through ajax in version 6.2.x

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Won't Fix
    • Affects Version/s: 6.2.3 CE GA4, 6.2.4 CE GA5
    • Fix Version/s: None
    • Component/s: Accessibility, Web Form
    • Labels:
      None

      Description

      We are migrating our code from Liferay 6.1.1 CE GA2 to Liferay 6.2.3 CE GA4 or 6.2.4 CE GA5

      Flow :

      On load of our application page, we have a jquery script which gets executed.
      Once page gets loaded, we populate the mandatory values in the form and tries to submit the form through ajax.
      Observed that values aren't getting bind to the model object when request reach to Controller.
      As we have done validations at controller level, validator checks the values for the mandatory values and find its null/Empty and throws back to the same page of the application with error messages.

      Though we have added the attributes <requires-namespaced-parameters>false</requires-namespaced-parameters> and <ajaxable>true</ajaxable>.

      Attached the liferay.portlet.xml file and sample.jsp of the application.

      Please assist with this issue.

      Thanks in advance.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                2 years, 35 weeks, 4 days ago