Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-64513

Search filters are not remembered when there is no result

    Details

      Description

      1. Create a new site (in addition to the default site, let's call it 'testsite')
      2. Create one web content in both sites
        1. Default site: web content title: "life is good"
        2. New site: web content title: "sun is awesome"
      3. On the default site, deploy a search portlet
      4. Select This Site from the search portlet and search for awesome
      5. The result page shows no results (which is expected), but it doesn't show the site facet of the default site, which was the scope of the search

      Problem: For the user the search result page implicates that there is no search result for the term "awesome" in the whole portal. However, this is only true for the site-specific search within the default site. The site facet is not shown, but should.
      Expected: The user sees that there are no search results for his/her search, and the site facet of the search scope is shown.

        Attachments

        1. fix.png
          fix.png
          43 kB
        2. reproduce.png
          reproduce.png
          27 kB

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  2 years, 15 weeks ago

                  Packages

                  Version Package
                  6.2.X EE
                  7.0.1 CE GA2