Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-65046

Search result snippet for Web Content doesn't show search terms for long content

    Details

      Description

      DESCRIPTION
      The search result snippet is not shifting its place in the resulting article in order to highlight the matching word

      STEPS TO REPRODUCE
      1. Navigate to home site
      2. Create 1 web content article with only the word "test" in the content.
      3. Create 1 more web content article with a lot of text (250-300 characters), but with "test" as the last word.
      4. Add web content search portlet to the home page and in the configuration, uncheck " Only show results for web content listed in a Web Content Display portlet. "
      5. Use web content search to search for "test"
      6. See results which do not show the highlighted search terms within the snippet.

      EXPECTED RESULTS
      "test" is shown in search snippet

      ACTUAL RESULTS
      search snippet does not show "test"

        Attachments

        1. fix.png
          fix.png
          25 kB
        2. reproduce.png
          reproduce.png
          41 kB

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  3 years, 29 weeks, 3 days ago

                  Packages

                  Version Package
                  6.2.X EE