Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-65208

Service Configurator does not add default resource permissions on deploy

    Details

      Description

      Service Configurator does not add default resource permissions on deploy.

      Steps to reproduce:

      1) Build portal using "ant all"
      2) Remove *journal*.jar from osgi/modules in portal home
      3) Start the portal
      4) Assert that there is no Liferay -> Content -> Web Content feature available
      5) Deploy all journal modules on running portal
      6) Go to Liferay -> Content -> Web Content

      Expected result: administrator can see Web Content interface

      Actual result: permissions error appears in console, normal behaviour only after portal restart

      It works in the same way with any kind of modules.

        Attachments

        1. dummy-app.zip
          72 kB
        2. fix.png
          fix.png
          150 kB

          Issue Links

            Activity

              People

              Assignee:
              melody.wu Melody Wu
              Reporter:
              pavel.savinov Pavel Savinov
              Participants of an Issue:
              Recent user:
              Esther Sanz
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                4 years, 24 weeks, 3 days ago

                  Packages

                  Version Package
                  7.0.1 CE GA2