Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-65626

WebSphere - 'TypeError: Liferay.Portal is undefined' thrown when hovering over Control Menu links

    Details

    • Fix Priority:
      5
    • OS:
      Windows 10
    • Application Servers:
      IBM Websphere 8.5.x

      Description

      Steps to reproduce:

      1. (Uninstall any old instance of Websphere through IBM Installation Manager, and delete the IBM folders)
      2. From Administrator console, build Liferay on Websphere with the following commands:
        • ant clean
        • ant compile
        • ant -f build-dist.xml build-dist-websphere

      or

      1. Build Liferay on Websphere:
        • ant -f build-dist.xml unzip-websphere
        • ant all
      2. startup @ [websphere_home]\profiles\liferay\bin, with: startserver.bat server1
      3. Sign in with workaround described in LPS-65625
      4. Hover over links in the Control Menu (e.g., Product Menu toggle, "+" icon, or the Simulator icon)

      Expected result:
      No JavaScript errors will be thrown in the browser.

      Actual result:
      TypeError: Liferay.Portal is undefined is thrown in succession when hovering over the links. And they are unresponsive to clicking. See attached gif.

        Attachments

          Activity

            People

            • Assignee:
              brian.wulbern Brian Wulbern
              Reporter:
              brian.wulbern Brian Wulbern
              Participants of an Issue:
              Recent user:
              Esther Sanz
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                3 years, 23 weeks, 3 days ago

                Packages

                Version Package
                7.0.1 CE GA2