Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-65903

Validation error and weird behavior on form display

    Details

      Description

      Hi team:
      in today's master I added a form with an email input and the validation works in an unusual way.
      The moment I write a letter I get a validation error (first weird thing - shouldn't it be validated on submission or on going to another input?) which says "Unknown error", while it should say something like "This is not a valid email" or something like that.

      (see attached image)

        Attachments

        1. pass.png
          pass.png
          27 kB
        2. reproduce.png
          reproduce.png
          19 kB
        3. validation.png
          validation.png
          34 kB

          Activity

            People

            Assignee:
            steven.gao Steven Gao (Inactive)
            Reporter:
            juan.fernandez Juan Fernández (Inactive)
            Participants of an Issue:
            Recent user:
            Csaba Turcsan
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              5 years, 15 weeks, 6 days ago

                Packages

                Version Package
                7.0.0 DXP FP59
                7.0.0 DXP SP9
                7.0.X
                7.1.X
                Master