Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-66009

Language does not display correctly after first save

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 7.0.1 CE GA2
    • Fix Version/s: 7.0.1 CE GA2
    • Component/s: My Account
    • Labels:
      None

      Description

      Steps to reproduce:

      1. Go to Account Settings
      2. Change language to Spanish
      3. Save
      4. On the pop up bar that appears, click on Mostrar la página en español (España).

      Expected Result
      The page is displayed in Spanish.

      Actual Result
      The Control Panel or menu icon is no longer visible with a message "Por favor, seleccione una aplicacion del menu izquierdo" on the page. The User has to click back to see the proper UI again. In order for the page to show in the correct language, the User has to save the language settings again. After the second save, the page displays the correct language (Spanish). Refer to attached gif.

      Reproduce on:
      Tomcat 8.0 + PostgreSQL 9.4
      Portal ee-7.0.x Git ID 30fce3be118c690e8aea0543b2b762d3367356a8

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                3 years, 21 weeks, 2 days ago

                Packages

                Version Package
                7.0.1 CE GA2