Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-66383

Select field no longer displays "selected" tag in markup

    Details

      Description

      This issue probably won't affect the user and we aren't sure it's a bug. It does seem inconsistent, because right after saving the tag appears, but then disappears if the user navigates away and returns. This also breaks our functional tests that rely on the selected tag.

      Steps:

      1. Add a Web Content Display
      2. Configure > Scope
      3. Assert the scope doesn't have the tag
        selected=" "

        that it used to have.

      4. Please see before and after screenshots

        Attachments

        1. 7.0 pass.png
          7.0 pass.png
          12 kB
        2. master pass.png
          master pass.png
          22 kB
        3. selectAfter.png
          selectAfter.png
          107 kB
        4. selectBefore.png
          selectBefore.png
          83 kB

          Issue Links

            Activity

              People

              Assignee:
              steven.gao Steven Gao (Inactive)
              Reporter:
              evan.nagayama Evan Nagayama (Inactive)
              Participants of an Issue:
              Recent user:
              Marta Elicegui
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                3 years, 20 weeks, 3 days ago

                  Packages

                  Version Package
                  7.0.0 DXP FP23
                  7.0.X EE
                  7.0.4 CE GA5
                  Master