Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-66464

Adding Tags with special characters doesn't tell the User why or which characters aren't allowed

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 7.0.0 CE RC1, 7.0.1 CE GA2
    • Fix Version/s: 7.0.1 CE GA2
    • Component/s: WCM, WCM > Tags
    • Labels:
      None

      Description

      Steps to reproduce:

      1. Navigate to Tags admin
      2. Add a Tag with a special character, like `~@#%&*+=|[]'";:/?, or } or {

      Expected result:
      The error message will tell the User which special characters are allowed, like -!$().^_.

      Actual result:
      The two messages just say: "Your request failed to complete." and "Please enter a valid name." See attached screenshot.

        Attachments

          Activity

            People

            • Assignee:
              brian.wulbern Brian Wulbern
              Reporter:
              brian.wulbern Brian Wulbern
              Participants of an Issue:
              Recent user:
              Esther Sanz
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                3 years, 19 weeks, 2 days ago

                Packages

                Version Package
                7.0.1 CE GA2