Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-66830

Plugins SDK not working for themes in GA1 and GA2

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Won't Fix
    • Affects Version/s: 7.0.0 CE GA1, 7.0.1 CE GA2
    • Fix Version/s: None
    • Labels:
      None
    • Fix Priority:
      4

      Description

      Steps to reproduce in 7.0 GA1

      1. Unzip a fresh 7.0 GA1 Plugins SDK
      2. Configure build.name.properties file
      3. Navigate to the `themes` directory of the Plugins SDK and run the create script to create the theme i.e. `./create yo "Yo"` on a Mac.
      4. cd into new theme directory i.e. `yo-theme` and run `ant war`.

      Task fails with the following error:
      Sass to CSS Builder generated exceptions.(see attached `7.0-ga1-plugins-sdk-sass-build-errors.txt` file)

      Steps to reproduce in 7.0 GA2:

      1. Unzip a fresh 7.0 GA2 Plugins SDK
      2. Configure build.name.properties file
      3. Navigate to the `themes` directory of the Plugins SDK and run the create script to create the theme i.e. `./create yo "Yo"` on a Mac.

      Build fails saying that it was "impossible to resolve dependencies."(see attached `7.0-ga2-plugins-sdk-unresolved-dependencies.txt` file.)

      I've attached my build.mike.properties as well. The configuration is the same, with the exception that one points to ga1 and the other to ga2.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  3 years, 36 weeks ago

                  Packages

                  Version Package