Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-67084

Search on stale index breaks Search Portlet UI when category was deleted and remote search server departs

    Details

      Description

      1- Configure Liferay to connect to a REMOTE search server (7.0/DXP: Elasticsearch or Solr, 6.2: Solr)
      2- Create a category
      3- Create a web content and use this category
      4- Disconnect the search server (simulate an outage)
      5- Delete the category
      6- Re-connect the search server
      (7- 6.2: Add Search Portlet to a page)
      8- Search for "test"
      (9- Click on the name of the category on the left facet panel)

      Result: page (UI) is broken. See the screenshots attached
      Expected Result UI remains "coherent" and does not get broken

      See the comments below for more information about the setup and other.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  2 years, 51 weeks, 3 days ago

                  Packages

                  Version Package
                  6.2.X EE
                  7.0.0 DXP FP1
                  7.0.2 CE GA3
                  7.0.0 DXP SP1
                  7.0.3 CE GA4
                  7.1.X
                  Master