Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-67924

Integration tests fail to run on Windows

    Details

    • Type: Regression Bug
    • Status: Closed
    • Resolution: Duplicate
    • Affects Version/s: Master
    • Fix Version/s: None
    • Component/s: Testing, Testing > Portal
    • Labels:
      None

      Description

      setup-test-classpath assumes that tests are run on *NIX environment (all equality tests use forward slashes), causing integration tests to fail on Windows with a log assertion error with the message, "Class com.liferay.portal.kernel.exception.PortalException is not loaded from a standard location (/WEB-INF/classes)"

      In order to reproduce the issue, run the following from a Windows machine:

      ant test-class -Dtest.class=USAPhoneNumberFormatImplTest

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              minhchau.dang Minhchau Dang
              Reporter:
              minhchau.dang Minhchau Dang
              Participants of an Issue:
              Recent user:
              Michael Saechang
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                5 years, 14 weeks, 5 days ago

                  Packages

                  Version Package