Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-68301

Unable to subscribe to a blog when category is required

Details

    Description

      When it's mandatory to categorize blogs with any category of a given vocabulary, it's not possible to subscribe to that blog.

      Steps to reproduce:
      1- Create a new vocabulary on Global scope, and set it as required for blog entries.
      2.- Create a category belonging to the previous vocabulary.
      3. On a site, create a new page
      4. On that page, instantiate the Blog portlet.
      5. On portlet configuration, set the page as the scope.
      6. Try to subscribe to the blog.

      Current behavior: it's not possible to subscribe to the blog, we see the "edit entry" screen with a message telling us we must set a category of the vocabulary created on step 1.
      Expected behavior: we can subscribe us to the blog.

      Attachments

        1. fix.png
          fix.png
          17 kB
        2. reproduce.png
          reproduce.png
          45 kB

        Issue Links

          Activity

            People

              raven.song Raven Song
              eduardo.perez Eduardo Perez (Inactive)
              Kiyoshi Lee Kiyoshi Lee
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                5 years, 26 weeks, 1 day ago

                Packages

                  Version Package
                  6.2.X EE
                  7.0.0 DXP FP21
                  7.0.0 DXP SP4
                  7.0.X EE
                  7.1.X
                  Master