Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-68613

User search and count for assigning site members is not consistent

    Details

      Description

      When trying to search users when assigning members for a site, the select query searches in database and the count query in the index, which results (because of the wildcards used) in inconsistent results.

      Steps to Reproduce:

      1. In an empty bundle create six users with first name and screen name user1, user2,... up to six (the email will be user1@liferay.com, user2@liferay.com,...).
      2. Create and additional user with first name and screen name zuser, and email zuser@liferay.com
      3. Go to Admin > Site Administration > Users > Site Memberships > Add Members > User
      4. Search users using literal u

      Expected Results:
      7 users should be found, and the message should be "Showing 7 results".

      Current Results:
      7 users are found, but the message is "Showing 6 results".

        Attachments

        1. 68613_2.png
          68613_2.png
          77 kB
        2. 68613.png
          68613.png
          75 kB

          Issue Links

            Activity

              People

              Assignee:
              sylvia.luan Sylvia Luan
              Reporter:
              mariano.alvaro Mariano Álvaro
              Participants of an Issue:
              Recent user:
              Marta Elicegui
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                4 years, 25 weeks, 5 days ago

                  Packages

                  Version Package
                  6.2.X EE