Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-68808

Can't select current site on WCD search field when actual user is not a member of it

    Details

      Description

      1. Log in as admin user
      2. Create a Site and add a page
      3. Add a Web Content Display portlet on the page
      4. Click Select Web Content
      5. Open the dropdown on the Search field
      6. Check the "My Sites" field, assert that the current site is present and is pre-selected by default
      7. Exit the dialog, go to Admin > Site Administration > Users
      8. Remove the admin user (that you are logged in with) from site members
      9. Go back to the page and the portlet, Click Select Web Content, Open the dropdown again

      Result: The current site is no longer available for selection in "My Sites" field

      The issue is not present on master and 7.0, but since the UI was completely refactored there, there is no chance to find and backport anything specific.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              gergely.mathe Gergely Mathe (Inactive)
              Reporter:
              gergely.mathe Gergely Mathe (Inactive)
              Participants of an Issue:
              Recent user:
              Marta Elicegui
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                5 years, 1 week, 6 days ago

                  Packages

                  Version Package
                  6.2.X EE