Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-69285

Incorrect site used when clicking "x-users" link from info panel in Users administration

Details

    Description

      With a single site selected, clicking the "x-users" link from the info panel in the "Sites" menu in the Control Panel will load an incorrect list of Site members (a separate list, that appears empty at first). This is because it uses the Control Panel groupId rather than the correct Site's groupId, because the groupId is missing from the display context.

      Steps to reproduce:
      1) Create a site
      2) Add a user to the site
      3) Open left nav menu > Control Panel > Sites
      4) Mark the checkbox next to the created site
      5) Select the "i" for Info near the top-right of the screen
      6) Information panel will expand, click on "X Users" down towards bottom.

      Expected Result: Selecting "X Users" would take you a list of all members of the Site
      Actual Results: Selecting "X Users" takes you to a list of members for the Control Panel site, which does not make sense in this context

      Reproduced in master: 8c907570f774fa7ed34ef9b9d988470e549e2146
      Reproduced in ee-7.0.x: e5993a0ac5252525f04fe2c5b94c40e2d1bc7e43

      Attachments

        Activity

          People

            raven.song Raven Song
            alec.shay Alec Shay
            Kiyoshi Lee Kiyoshi Lee
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:
              5 years, 51 weeks, 6 days ago

              Packages

                Version Package
                7.0.0 DXP FP9
                7.0.0 DXP SP2
                7.0.3 CE GA4
                7.1.X
                Master