Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-69946

"Server LDAP" and "Authentication LDAP", system settings won't appear on the search results after being changed and exported

    Details

      Description

      Steps to reproduce

      1. Go to Control Panel -> Configuration -> System Configuration
      2. Search for "LDAP"
      3. Click on link "LDAP Servers"
      4. Make some changes to the values and then save
      5. Export "LDAP Servers" configuration
      6. Now click on the entry named "LDAP Authentication"
      7. Tick the fields "Enabled" and "Password Policy Enabled" then save
      8. Export "LDAP Servers" configuration
      9. Restart server
      10. Perform the login. (The Authentication with LDAP, not will working, use the default login and password, like: test / test)
      11. Repeat steps 1, 2

      Expected behavior

      The links "Server LDAP" and "Authentication LDAP", should appear on the screen.

      Current behavior

      The links "Server LDAP" and "Authentication LDAP", don't appear on the screen.

      Despite not being available among the search results, it is accessible directly via URL or by going to "Foundation" tab.

      Reproduced on master @72b0e979d2823d3b75ab185bab282122e1053fdb

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  2 years, 1 week, 5 days ago

                  Packages

                  Version Package
                  7.0.0 DXP FP20
                  7.0.3 CE GA4
                  7.0.0 DXP SP4
                  7.0.X EE
                  7.1.X
                  Master