Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-70390

non ascii characters are displayed and stored wrong if SPA is turned off

    Details

      Description

      When adding user to Liferay and user name contains non ascii charachers those are stored wrong.

      To reproduce the issue:

      Use empty bundle:

      make sure that at portal-ext.properties

      javascript.single.page.application.enabled=false
      

      Login to user with as admin and create users with following values.

      Screenname: skandi
      email: skandi@liferay.com
      Firstname : Skändi
      Lastname : Ääkkönen

      and "Save".

      Expected result the non ascii characters would be displayed correctly, which is not working.

      This is working with fixpack 7

      Verified also with master branch git-id: 6272e18949263e85b7f8d46f05f1749635bb65b2

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  2 years, 36 weeks, 2 days ago

                  Packages

                  Version Package
                  7.0.0 DXP FP14
                  7.0.0 DXP SP3
                  7.0.3 CE GA4
                  7.0.X EE
                  7.1.X
                  Master