Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-71075

A tilde (~) symbol is added to the content when opening a Wiki in edit mode even without switching to source mode

    Details

      Description

      1) Start DXP, login as admin, deploy a Wiki on the Welcome page
      2) Edit the Front Page
      3) Switch to source and paste:

      [[http://www.google.com]] and [[http://www.facebook.com|/Facebook]]
      

      4.a) Switch to rich text editor, then back to source, then back to rich text editor, OR
      4.b) Publish, then edit the Front Page

      Actual result: You'll notice the text becomes http://www.google.com and ~/Facebook in rich text editor and one more tilde is added each time switching between source/text editor or editing the page

      Expected: Text in the text editor should remain: http://www.google.com and /Facebook

      Reproduced on DXP latest fix pack

      Branch:
      Reproduced on 7.0.x @ 870078ae5dc30d4d916bf89f5e7a95f98e80d6ac

      Master:
      Reproduced on master @ 01e9a631f6620eecb1faf0f1714e96f501d041f2

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  2 years, 34 weeks, 6 days ago

                  Packages

                  Version Package
                  7.0.0 DXP FP35
                  7.0.0 DXP SP7
                  7.0.5 CE GA6
                  7.0.X
                  7.1.0 M1
                  7.1.X
                  Master