Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-71321

Site Administrators are unable to view site roles

Details

    Description

      Description:
      Basic Site Administrators are unable to view the Roles list in their site control panel. When attempting to assign roles to a user, or view the Site Roles list before assigning users to a role, they see a blue box with "No roles found".

      Steps to Reproduce:
      1. Install hotfix-24274-6210 in a clean 6.2 bundle.
      2. Create two users assigned to the default Liferay site.
      3. Create a dummy site role.
      4. Make one of the users a Site Administrator.
      5. Log in as the Site Administrator.
      6. Navigate to Admin > Users.
      7. Click the Action button next to a the other created user.
      8. Click 'Assign Site Roles.'

      Expected:
      The dummy site role should be listed.
      Actual:
      "No roles were found." is displayed.

      Related:
      When LPS-52664 was backported from Master to 6.2.x, some of the logic was left out which caused this bug to persist.

      Additional Testing:

      6.2.x: 3739510bc58420fedf0fdad7ee8003bbe91a0fc1
      Issue reproduced in branch.
      Master: 1643645112fbb11cff30e2f5dea9d1d6c1bfc795
      Issue is fixed in master.

      Attachments

        1. fix.png
          fix.png
          33 kB
        2. reproduce.png
          reproduce.png
          29 kB

        Issue Links

          Activity

            People

              melody.wu Melody Wu
              joshua.stclair Joshua St. Clair (Inactive)
              Marta Elicegui Marta Elicegui
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                5 years, 36 weeks, 3 days ago

                Packages

                  Version Package
                  6.2.X EE