Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-71967

Cursor is not placed where clicked when using CKEditor with MS Edge

    Details

    • What problem did the customer find?:
      Attempting to place the cursor at the end of a Message Boards post when editing the post using Microsoft Edge will incorrectly place the cursor at the beginning of the field.
    • What do you think is the root cause? (if known):
      The root cause is an issue with CKEditor.
    • Proposed solution (if any):
      We now have CKEditor support. The CKEditor team would be the best ones to resolve the issue: https://grow.liferay.com/people/CKEditor+Support

      Description

      Description:
      Attempting to place the cursor at the end of a a CKEditor field while using MS Edge will place it at the beginning of the field instead.

      Steps to Reproduce
      1. Access Liferay using Microsoft Edge.
      2. Sign in as test/test.
      3. Navigate to Site Admin > Content > Message Boards.
      4. Create a new thread with some sample text.
      5. Edit the new thread.
      6. Attempt to place the cursor at the end of the body/message by clicking at the end of the text.

      Expected:
      Cursor will be placed at the end of the text on first click.
      Actual:
      The first click places the cursor at the beginning of the field.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  2 years, 5 days ago

                  Packages

                  Version Package
                  7.0.0 DXP FP32
                  7.0.5 CE GA6
                  7.0.X
                  7.1.X
                  Master