Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-72551

HTTP status is wrong when refresh same page

    Details

    • Fix Priority:
      2

      Description

      Steps to reproduce:

      1. Startup and login
      2. Create a new page test1 without any portlets
      3. Create a new page test2
      4. Add the sign-in portlet to the test2 page
      5. Sign out and verify that you are not logged in
      6. Open firebug or the developer tools and go to the Network tab.
      7. Open the /test1 page
      8. Check the http status code for /test1 HTTP GET request. It should be 200.
      9. Refresh same page with F5. Now you should see that request returns HTTP 304 status (not modified).
      10. Open the /test2 page
      11. Check the http status code for /test2 HTTP GET request. It should be 200.
      12. Refresh same page with F5. Now you should see that request returns HTTP 304 status (not modified).

       

      Actual Result:
      It still returns HTTP 200 status.

      Expected Result:
      It should return HTTP 304 status.

      Note: Any portlet that uses the <aui:form tag is generating this behavior.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              jose.balsas Chema Balsas
              Reporter:
              felix.zhang Felix Zhang
              Participants of an Issue:
              Recent user:
              Michael Saechang
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                2 years, 43 weeks, 2 days ago

                  Packages

                  Version Package