Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-72879

Hyperlink is removed from content when creating a new Web Content article

    Details

    • Fix Priority:
      2

      Description

      Description
      When creating a Web Content article with a hyperlink in the content and publishing the article fails, the hyperlink is not properly restored.
      The initial publishing can fail when setting the portal property:

      journal.article.types=General,Article,Video,Podcast
      

      This is a 62x unique fix, as categories tab is no longer available.

      Steps to Reproduce

      1. Include the following portal property:
        journal.article.types=General,Article,Video,Podcast
        
      1. Start Liferay 6.2
      2. Create a new basic web content
      3. Enter some text in the content field and hyperlink the text to this URL:
        http://www.google.com
      1. Publish the Web Content
      2. Notice the request failed and is requiring a category to be selected
      3. Select a category
      4. Publish the Web Content
      5. Edit the saved Web Content

      Expected Behavior: The content with the hyperlink is published
      Actual Behavior: The content with the hyperlink is removed

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              support-lep@liferay.com SE Support
              Reporter:
              eric.yan Eric Yan
              Participants of an Issue:
              Recent user:
              Felix Zhang
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Days since last comment:
                3 years, 48 weeks, 4 days ago

                  Packages

                  Version Package