Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-74028

Upgrading a database with Mobile Device Actions throws a log error

    Details

      Description

      Steps to Reproduce:

      1. Start 6.2.10 bundle
      2. Deploy 51degreesĀ from liferay-plugins-ee/ee-6.2.x
      3. Navigate to Site > Configuration > Mobile Device Families
      4. Add Mobile Device Family
      5. Navigate to Site Pages
      6. Select Mobile Device Rules
      7. Click 'Select Mobile Device Family' button
      8. Click Choose next to create family
      9. Open Actions dropdown
      10. Select Manage Actions
      11. Add Action
      12. Upgrade database to ee-7.0.x

      Expected result:
      Database upgrades without errors.

      Actual result:
      Error is thrown when upgrading:

      22:02:04,691 ERROR [localhost-startStop-1][ThrowableAwareRunnable:44] Unable to process runnable: There are no actions associated with the resource com.liferay.mobile.device.rules.kernel.MDRRuleGroupInstance
      com.liferay.portal.kernel.exception.NoSuchResourceActionException: There are no actions associated with the resource com.liferay.mobile.device.rules.kernel.MDRRuleGroupInstance
      

      The database upgrades, and portal will start with the upgraded database. The same error is thrown during startup.

      Reproduced on:
      Tomcat 8.0.32 + MySQL 5.6.
      Portal ee-7.0.x Git ID: b0a3e4c983158c66c441bd9685190f157bb78dc4

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kiana.suetani Kiana Suetani
                Reporter:
                kiana.suetani Kiana Suetani
                Participants of an Issue:
                Recent user:
                Csaba Turcsan
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  2 years, 14 weeks ago

                  Packages

                  Version Package
                  7.0.0 DXP FP28
                  7.0.X EE
                  7.0.4 CE GA5
                  Master