Details

      Description

      Compiling ee-7.0.x/master/7.0.x at head would sometimes throw the following errors:

           [exec] :apps:foundation:frontend-theme:frontend-theme-user-profile:zipResourcesImporterArchives UP-TO-DATE
           [exec] :apps:foundation:frontend-theme:frontend-theme-user-profile:gulpBuild[10:12:00] Finished 'build:compile-lib-sass' after 1.56 s
           [exec] [10:12:00] Finished 'build:compile-css' after 1.56 s
           [exec] [10:12:00] Starting 'build:fix-url-functions'...
           [exec] [10:12:00] Finished 'build:compile-lib-sass' after 1.58 s
           [exec] [10:12:00] Finished 'build:compile-css' after 1.58 s
           [exec] [10:12:00] Starting 'build:fix-url-functions'...
           [exec] [10:12:00] Finished 'build:fix-url-functions' after 99 ms
           [exec] [10:12:00] Starting 'build:move-compiled-css'...
           [exec] [10:12:00] Finished 'build:fix-url-functions' after 86 ms
           [exec] [10:12:00] Starting 'build:move-compiled-css'...
           [exec] [10:12:02] Finished 'build:base' after 8.03 s
           [exec] [10:12:02] Starting 'build:src'...
           [exec] [10:12:02] Finished 'build:src' after 80 ms
           [exec] [10:12:02] Starting 'build:web-inf'...
           [exec] [10:12:02] Finished 'build:web-inf' after 2.58 ms
           [exec] [10:12:02] Starting 'build:liferay-look-and-feel'...
           [exec] [10:12:03] Using gulpfile L:\EE\70p\modules\apps\foundation\frontend-theme\frontend-theme-user-profile\gulpfile.js
           [exec] [10:12:03] Starting 'build'...
           [exec] [10:12:03] Starting 'build:clean'...
           [exec] [10:12:03] Finished 'build:clean' after 17 ms
           [exec] [10:12:03] Starting 'build:base'...
           [exec] [10:12:03] Finished 'build:liferay-look-and-feel' after 47 ms
           [exec] [10:12:03] Starting 'build:hook'...
           [exec] [10:12:03] liferay-frontend-theme-unstyled using custom path: L:/EE/70p/modules/apps/foundation/frontend-theme/frontend-theme-unstyled/src/main/resources/META-INF/resources/_unstyled
           [exec] [10:12:03] liferay-frontend-theme-styled using custom path: L:/EE/70p/modules/apps/foundation/frontend-theme/frontend-theme-styled/src/main/resources/META-INF/resources/_styled
           [exec] [10:12:03] Finished 'build:hook' after 17 ms
           [exec] [10:12:03] Starting 'build:themelets'...
           [exec] [10:12:03] Starting 'build:themelet-src'...
           [exec] [10:12:03] Finished 'build:themelet-src' after 1.26 ms
           [exec] [10:12:03] Starting 'build:themelet-css-inject'...
           [exec] [10:12:03] Starting 'build:themelet-js-inject'...
           [exec] [10:12:03] gulp-inject Nothing to inject into _custom.scss.
           [exec] [10:12:03] gulp-inject Nothing to inject into portal_normal.ftl.
           [exec] [10:12:03] Finished 'build:themelet-css-inject' after 41 ms
           [exec] [10:12:03] Finished 'build:themelet-js-inject' after 17 ms
           [exec] [10:12:03] Finished 'build:themelets' after 44 ms
           [exec] [10:12:03] Starting 'build:rename-css-dir'...
           [exec] [10:12:03] Finished 'build:rename-css-dir' after 1.27 ms
           [exec] [10:12:03] Starting 'build:prep-css'...
           [exec] [10:12:03] Finished 'build:prep-css' after 8.03 ╬╝s
           [exec] [10:12:03] Starting 'build:compile-css'...
           [exec] [10:12:03] Starting 'build:compile-lib-sass'...
           [exec] [10:12:03] liferay-frontend-common-css using custom path: L:/EE/70p/modules/apps/foundation/frontend-theme/frontend-theme-user-dashboard/build_gradle/frontend-css-common
           [exec] [10:12:03] liferay-frontend-common-css using custom path: L:/EE/70p/modules/apps/foundation/frontend-theme/frontend-theme-user-dashboard/build_gradle/frontend-css-common
           [exec] [10:12:03] Finished 'build:move-compiled-css' after 2.61 s
           [exec] [10:12:03] Starting 'build:remove-old-css-dir'...
           [exec] [10:12:03] Finished 'build:move-compiled-css' after 2.67 s
           [exec] [10:12:03] Starting 'build:remove-old-css-dir'...
           [exec] [10:12:03] Finished 'build:remove-old-css-dir' after 274 ms
           [exec] [10:12:03] Starting 'build:fix-at-directives'...
           [exec] [10:12:03] Finished 'build:remove-old-css-dir' after 278 ms
           [exec] [10:12:03] Starting 'build:fix-at-directives'...
           [exec] [10:12:03] Finished 'build:fix-at-directives' after 73 ms
           [exec] [10:12:03] Starting 'build:r2'...
           [exec] [10:12:03] Finished 'build:fix-at-directives' after 66 ms
           [exec] [10:12:03] Starting 'build:r2'...
           [exec]
           [exec] :apps:foundation:frontend-image-editor:frontend-image-editor-capability-saturation:configJSModules FAILED
           [exec] L:\EE\70p\modules\apps\foundation\frontend-image-editor\frontend-image-editor-capability-saturation\node_modules\configstore\index.js:70
           [exec]                             throw err;
           [exec]                             ^
           [exec]
           [exec] Error: EPERM: operation not permitted, rename 'C:\Users\liferay\.config\configstore\update-notifier-liferay-module-config-generator.json.657235685' -> 'C:\Users\liferay\.config\configstore\update-notifier-liferay-module-config-generator.json'
           [exec]     at Error (native)
           [exec]     at Object.fs.renameSync (fs.js:809:18)
           [exec]     at Function.writeFileSync [as sync] (L:\EE\70p\modules\apps\foundation\frontend-image-editor\frontend-image-editor-capability-saturation\node_modules\write-file-atomic\index.js:124:8)
           [exec]     at Object.set (L:\EE\70p\modules\apps\foundation\frontend-image-editor\frontend-image-editor-capability-saturation\node_modules\configstore\index.js:63:21)
           [exec]     at Object.Configstore (L:\EE\70p\modules\apps\foundation\frontend-image-editor\frontend-image-editor-capability-saturation\node_modules\configstore\index.js:28:11)
           [exec]     at new UpdateNotifier (L:\EE\70p\modules\apps\foundation\frontend-image-editor\frontend-image-editor-capability-saturation\node_modules\update-notifier\index.js:34:17)
           [exec]     at module.exports (L:\EE\70p\modules\apps\foundation\frontend-image-editor\frontend-image-editor-capability-saturation\node_modules\update-notifier\index.js:108:23)
           [exec]     at Object.<anonymous> (L:\EE\70p\modules\apps\foundation\frontend-image-editor\frontend-image-editor-capability-saturation\node_modules\liferay-module-config-generator\bin\index.js:9:1)
           [exec]     at Module._compile (module.js:556:32)
           [exec]     at Object.Module._extensions..js (module.js:565:10)
           [exec]     at Module.load (module.js:473:32)
           [exec]     at tryModuleLoad (module.js:432:12)
           [exec]     at Function.Module._load (module.js:424:3)
           [exec]     at Module.runMain (module.js:590:10)
           [exec]     at run (bootstrap_node.js:394:7)
           [exec]     at startup (bootstrap_node.js:149:9)
           [exec] [10:12:04] Finished 'build:r2' after 381 ms
           [exec] [10:12:04] Starting 'build:war'...
           [exec] [10:12:04] Starting 'plugin:version'...
           [exec] [10:12:04] Finished 'plugin:version' after 10 ms
           [exec] [10:12:04] Starting 'plugin:war'...
           [exec] [10:12:04] Finished 'build:r2' after 438 ms
           [exec] [10:12:04] Starting 'build:war'...
           [exec] [10:12:04] Starting 'plugin:version'...
           [exec] [10:12:04] Finished 'plugin:version' after 8.84 ms
           [exec] [10:12:04] Starting 'plugin:war'...
           [exec] [10:12:04] Finished 'build:compile-lib-sass' after 1.72 s
           [exec] [10:12:04] Finished 'build:compile-css' after 1.73 s
           [exec] [10:12:04] Starting 'build:fix-url-functions'...
           [exec] [10:12:04] Finished 'build:fix-url-functions' after 76 ms
           [exec] [10:12:04] Starting 'build:move-compiled-css'...
           [exec] [10:12:05] Finished 'plugin:war' after 1.82 s
           [exec] [10:12:05] Finished 'build:war' after 1.83 s
           [exec] [10:12:05] Finished 'build' after 15 s
           [exec] [10:12:05] Finished 'plugin:war' after 1.8 s
           [exec] [10:12:05] Finished 'build:war' after 1.81 s
           [exec] [10:12:05] Finished 'build' after 15 s
           [exec] [10:12:07] Finished 'build:move-compiled-css' after 2.2 s
           [exec] [10:12:07] Starting 'build:remove-old-css-dir'...
           [exec] [10:12:07] Finished 'build:remove-old-css-dir' after 139 ms
           [exec] [10:12:07] Starting 'build:fix-at-directives'...
           [exec] [10:12:07] Finished 'build:fix-at-directives' after 34 ms
           [exec] [10:12:07] Starting 'build:r2'...
           [exec] [10:12:07] Finished 'build:r2' after 219 ms
           [exec] [10:12:07] Starting 'build:war'...
           [exec] [10:12:07] Starting 'plugin:version'...
           [exec] [10:12:07] Finished 'plugin:version' after 5.4 ms
           [exec] [10:12:07] Starting 'plugin:war'...
           [exec] [10:12:08] Finished 'build:base' after 5.43 s
           [exec] [10:12:08] Starting 'build:src'...
           [exec] [10:12:08] Finished 'build:src' after 60 ms
           [exec] [10:12:08] Starting 'build:web-inf'...
           [exec] [10:12:08] Finished 'build:web-inf' after 1.86 ms
           [exec] [10:12:08] Starting 'build:liferay-look-and-feel'...
           [exec] [10:12:08] Finished 'build:liferay-look-and-feel' after 36 ms
           [exec] [10:12:08] Starting 'build:hook'...
           [exec] [10:12:08] Finished 'build:hook' after 13 ms
           [exec] [10:12:08] Starting 'build:themelets'...
           [exec] [10:12:08] Starting 'build:themelet-src'...
           [exec] [10:12:08] Finished 'build:themelet-src' after 869 ╬╝s
           [exec] [10:12:08] Starting 'build:themelet-css-inject'...
           [exec] [10:12:08] Starting 'build:themelet-js-inject'...
           [exec] [10:12:08] gulp-inject Nothing to inject into _custom.scss.
           [exec] [10:12:08] gulp-inject Nothing to inject into portal_normal.ftl.
           [exec] [10:12:08] Finished 'build:themelet-css-inject' after 32 ms
           [exec] [10:12:08] Finished 'build:themelet-js-inject' after 13 ms
           [exec] [10:12:08] Finished 'build:themelets' after 34 ms
           [exec] [10:12:08] Starting 'build:rename-css-dir'...
           [exec] [10:12:08] Finished 'build:rename-css-dir' after 1.15 ms
           [exec] [10:12:08] Starting 'build:prep-css'...
           [exec] [10:12:08] Finished 'build:prep-css' after 9.82 ╬╝s
           [exec] [10:12:08] Starting 'build:compile-css'...
           [exec] [10:12:08] Starting 'build:compile-lib-sass'...
           [exec] [10:12:08] Finished 'plugin:war' after 1.13 s
           [exec] [10:12:08] Finished 'build:war' after 1.14 s
           [exec] [10:12:08] Finished 'build' after 14 s
           [exec] [10:12:08] liferay-frontend-common-css using custom path: L:/EE/70p/modules/apps/foundation/frontend-theme/frontend-theme-user-profile/build_gradle/frontend-css-common
           [exec] [10:12:08] liferay-frontend-common-css using custom path: L:/EE/70p/modules/apps/foundation/frontend-theme/frontend-theme-user-profile/build_gradle/frontend-css-common
           [exec] [10:12:09] Finished 'build:compile-lib-sass' after 977 ms
           [exec] [10:12:09] Finished 'build:compile-css' after 977 ms
           [exec] [10:12:09] Starting 'build:fix-url-functions'...
           [exec] [10:12:09] Finished 'build:fix-url-functions' after 49 ms
           [exec] [10:12:09] Starting 'build:move-compiled-css'...
           [exec] [10:12:11] Finished 'build:move-compiled-css' after 1.59 s
           [exec] [10:12:11] Starting 'build:remove-old-css-dir'...
           [exec] [10:12:11] Finished 'build:remove-old-css-dir' after 135 ms
           [exec] [10:12:11] Starting 'build:fix-at-directives'...
           [exec] [10:12:11] Finished 'build:fix-at-directives' after 27 ms
           [exec] [10:12:11] Starting 'build:r2'...
           [exec] [10:12:11] Finished 'build:r2' after 263 ms
           [exec] [10:12:11] Starting 'build:war'...
           [exec] [10:12:11] Starting 'plugin:version'...
           [exec] [10:12:11] Finished 'plugin:version' after 4.88 ms
           [exec] [10:12:11] Starting 'plugin:war'...
           [exec] [10:12:12] Finished 'plugin:war' after 1.13 s
           [exec] [10:12:12] Finished 'build:war' after 1.13 s
           [exec] [10:12:12] Finished 'build' after 9.79 s
           [exec] frontend-taglib@2.2.6 L:\EE\70p\modules\apps\foundation\frontend-taglib\frontend-taglib
           [exec] +-- abbrev@1.1.0
           [exec] +-- ansi-regex@2.1.1
           [exec] +-- ansi-styles@2.2.1
           [exec] +-- archy@1.0.0
           [exec] +-- arr-diff@2.0.0
           [exec] +-- arr-flatten@1.0.1
           [exec] +-- array-differ@1.0.0
           [exec] +-- array-uniq@1.0.3
           [exec] +-- array-unique@0.2.1
           [exec] +-- ast-types@0.8.15
           [exec] +-- balanced-match@0.4.2
           [exec] +-- beeper@1.1.1
           [exec] +-- bluebird@3.4.7
           [exec] +-- bootstrap@3.3.7
           [exec] +-- boxen@0.3.1
           [exec] | `-- object-assign@4.1.1
           [exec] +-- brace-expansion@1.1.6
           [exec] +-- braces@1.8.5
           [exec] +-- buffer-shims@1.0.0
           [exec] +-- capture-stack-trace@1.0.0
           [exec] +-- chalk@1.1.3
           [exec] +-- clone@1.0.2
           [exec] +-- clone-stats@0.0.1
           [exec] +-- code-point-at@1.1.0
           [exec] +-- commander@2.9.0
           [exec] +-- concat-map@0.0.1
           [exec] +-- config-chain@1.1.11
           [exec] +-- configstore@2.1.0
           [exec] | `-- object-assign@4.1.1
           [exec] +-- core-util-is@1.0.2
           [exec] +-- create-error-class@3.0.2
           [exec] +-- dateformat@2.0.0
           [exec] +-- deep-extend@0.4.1
           [exec] +-- defaults@1.0.3
           [exec] +-- deprecated@0.0.1
           [exec] +-- detect-file@0.1.0
           [exec] +-- dot-prop@3.0.0
           [exec] +-- duplexer2@0.0.2
           [exec] +-- editorconfig@0.13.2
           [exec] | `-- lru-cache@3.2.0
           [exec] +-- end-of-stream@0.1.5
           [exec] | `-- once@1.3.3
           [exec] +-- error-ex@1.3.0
           [exec] +-- escape-string-regexp@1.0.5
           [exec] +-- esprima@2.7.3
           [exec] +-- estraverse@4.2.0
           [exec] +-- expand-brackets@0.1.5
           [exec] +-- expand-range@1.8.2
           [exec] +-- expand-tilde@1.2.2
           [exec] +-- extend@3.0.0
           [exec] +-- extglob@0.3.2
           [exec] +-- fancy-log@1.3.0
           [exec] +-- filename-regex@2.0.0
           [exec] +-- fill-range@2.2.3
           [exec] +-- filled-array@1.1.0
           [exec] +-- find-index@0.1.1
           [exec] +-- findup-sync@0.4.3
           [exec] +-- fined@1.0.2
           [exec] +-- first-chunk-stream@1.0.0
           [exec] +-- flagged-respawn@0.3.2
           [exec] +-- for-in@0.1.6
           [exec] +-- for-own@0.1.4
           [exec] +-- foreachasync@3.0.0
           [exec] +-- fs-exists-sync@0.1.0
           [exec] +-- fs-extra@0.26.7
           [exec] +-- fs.realpath@1.0.0
           [exec] +-- gaze@0.5.2
           [exec] +-- glob@7.1.1
           [exec] +-- glob-base@0.3.0
           [exec] +-- glob-parent@2.0.0
           [exec] +-- glob-stream@3.1.18
           [exec] | +-- glob@4.5.3
           [exec] | +-- minimatch@2.0.10
           [exec] | +-- readable-stream@1.0.34
           [exec] | `-- through2@0.6.5
           [exec] +-- glob-watcher@0.0.6
           [exec] +-- glob2base@0.0.12
           [exec] +-- global-modules@0.2.3
           [exec] +-- global-prefix@0.1.5
           [exec] +-- globule@0.1.0
           [exec] | +-- glob@3.1.21
           [exec] | +-- graceful-fs@1.2.3
           [exec] | +-- inherits@1.0.2
           [exec] | `-- minimatch@0.2.14
           [exec] +-- glogg@1.0.0
           [exec] +-- got@5.7.1
           [exec] | +-- duplexer2@0.1.4
           [exec] | +-- isarray@1.0.0
           [exec] | +-- object-assign@4.1.1
           [exec] | `-- readable-stream@2.2.2
           [exec] +-- graceful-fs@4.1.11
           [exec] +-- graceful-readlink@1.0.1
           [exec] +-- gulp@3.9.1
           [exec] +-- gulp-util@3.0.8
           [exec] +-- gulplog@1.0.0
           [exec] +-- has-ansi@2.0.0
           [exec] +-- has-gulplog@0.1.0
           [exec] +-- homedir-polyfill@1.0.1
           [exec] +-- html2incdom@0.1.8
           [exec] +-- imurmurhash@0.1.4
           [exec] +-- inflight@1.0.6
           [exec] +-- inherits@2.0.3
           [exec] +-- ini@1.3.4
           [exec] +-- interpret@1.0.1
           [exec] +-- is-absolute@0.2.6
           [exec] +-- is-arrayish@0.2.1
           [exec] +-- is-buffer@1.1.4
           [exec] +-- is-dotfile@1.0.2
           [exec] +-- is-equal-shallow@0.1.3
           [exec] +-- is-extendable@0.1.1
           [exec] +-- is-extglob@1.0.0
           [exec] +-- is-finite@1.0.2
           [exec] +-- is-fullwidth-code-point@1.0.0
           [exec] +-- is-glob@2.0.1
           [exec] +-- is-npm@1.0.0
           [exec] +-- is-number@2.1.0
           [exec] +-- is-obj@1.0.1
           [exec] +-- is-posix-bracket@0.1.1
           [exec] +-- is-primitive@2.0.0
           [exec] +-- is-redirect@1.0.0
           [exec] +-- is-relative@0.2.1
           [exec] +-- is-retry-allowed@1.1.0
           [exec] +-- is-stream@1.1.0
           [exec] +-- is-unc-path@0.1.2
           [exec] +-- is-utf8@0.2.1
           [exec] +-- is-windows@0.2.0
           [exec] +-- isarray@0.0.1
           [exec] +-- isexe@1.1.2
           [exec] +-- isobject@2.1.0
           [exec] | `-- isarray@1.0.0
           [exec] +-- js-beautify@1.6.9
           [exec] +-- jsonfile@2.4.0
           [exec] +-- jsstana@0.1.6
           [exec] +-- kind-of@3.1.0
           [exec] +-- klaw@1.3.1
           [exec] +-- latest-version@2.0.0
           [exec] +-- levenshtein@1.0.5
           [exec] +-- liferay-module-config-generator@1.1.10
           [exec] +-- liftoff@2.3.0
           [exec] +-- lodash@1.0.2
           [exec] +-- lodash._basecopy@3.0.1
           [exec] +-- lodash._basetostring@3.0.1
           [exec] +-- lodash._basevalues@3.0.0
           [exec] +-- lodash._getnative@3.9.1
           [exec] +-- lodash._isiterateecall@3.0.9
           [exec] +-- lodash._reescape@3.0.0
           [exec] +-- lodash._reevaluate@3.0.0
           [exec] +-- lodash._reinterpolate@3.0.0
           [exec] +-- lodash._root@3.0.1
           [exec] +-- lodash.assignwith@4.2.0
           [exec] +-- lodash.escape@3.2.0
           [exec] +-- lodash.isarguments@3.1.0
           [exec] +-- lodash.isarray@3.0.4
           [exec] +-- lodash.isempty@4.4.0
           [exec] +-- lodash.isplainobject@4.0.6
           [exec] +-- lodash.isstring@4.0.1
           [exec] +-- lodash.keys@3.1.2
           [exec] +-- lodash.mapvalues@4.6.0
           [exec] +-- lodash.pick@4.4.0
           [exec] +-- lodash.restparam@3.6.1
           [exec] +-- lodash.template@3.6.2
           [exec] +-- lodash.templatesettings@3.1.1
           [exec] +-- lowercase-keys@1.0.0
           [exec] +-- lru-cache@2.7.3
           [exec] +-- map-cache@0.2.2
           [exec] +-- metal@2.6.0
           [exec] +-- metal-cli@2.1.2
           [exec] | +-- acorn@4.0.3
           [exec] | +-- amdefine@1.0.0
           [exec] | +-- ansi-regex@2.0.0
           [exec] | +-- ansi-styles@2.2.1
           [exec] | +-- arr-diff@2.0.0
           [exec] | +-- arr-flatten@1.0.1
           [exec] | +-- array-differ@1.0.0
           [exec] | +-- array-find-index@1.0.2
           [exec] | +-- array-uniq@1.0.3
           [exec] | +-- array-unique@0.2.1
           [exec] | +-- atob@1.1.3
           [exec] | +-- babel-code-frame@6.16.0
           [exec] | +-- babel-core@6.17.0
           [exec] | | +-- lodash@4.16.4
           [exec] | | `-- minimatch@3.0.3
           [exec] | +-- babel-deps@2.1.0
           [exec] | +-- babel-generator@6.17.0
           [exec] | | +-- jsesc@1.3.0
           [exec] | | `-- lodash@4.16.4
           [exec] | +-- babel-globals@2.0.1
           [exec] | +-- babel-helper-call-delegate@6.8.0
           [exec] | +-- babel-helper-define-map@6.9.0
           [exec] | | `-- lodash@4.16.4
           [exec] | +-- babel-helper-function-name@6.8.0
           [exec] | +-- babel-helper-get-function-arity@6.8.0
           [exec] | +-- babel-helper-hoist-variables@6.8.0
           [exec] | +-- babel-helper-optimise-call-expression@6.8.0
           [exec] | +-- babel-helper-regex@6.9.0
           [exec] | | `-- lodash@4.16.4
           [exec] | +-- babel-helper-replace-supers@6.16.0
           [exec] | +-- babel-helpers@6.16.0
           [exec] | +-- babel-messages@6.8.0
           [exec] | +-- babel-plugin-check-es2015-constants@6.8.0
           [exec] | +-- babel-plugin-external-helpers-2@6.3.13
           [exec] | | +-- babel-runtime@5.8.38
           [exec] | | `-- core-js@1.2.7
           [exec] | +-- babel-plugin-globals@2.0.1
           [exec] | +-- babel-plugin-transform-es2015-arrow-functions@6.8.0
           [exec] | +-- babel-plugin-transform-es2015-block-scoped-functions@6.8.0
           [exec] | +-- babel-plugin-transform-es2015-block-scoping@6.15.0
           [exec] | | `-- lodash@4.16.4
           [exec] | +-- babel-plugin-transform-es2015-classes@6.14.0
           [exec] | +-- babel-plugin-transform-es2015-computed-properties@6.8.0
           [exec] | +-- babel-plugin-transform-es2015-destructuring@6.16.0
           [exec] | +-- babel-plugin-transform-es2015-duplicate-keys@6.8.0
           [exec] | +-- babel-plugin-transform-es2015-for-of@6.8.0
           [exec] | +-- babel-plugin-transform-es2015-function-name@6.9.0
           [exec] | +-- babel-plugin-transform-es2015-literals@6.8.0
           [exec] | +-- babel-plugin-transform-es2015-modules-amd@6.8.0
           [exec] | +-- babel-plugin-transform-es2015-modules-commonjs@6.16.0
           [exec] | +-- babel-plugin-transform-es2015-modules-systemjs@6.14.0
           [exec] | +-- babel-plugin-transform-es2015-modules-umd@6.12.0
           [exec] | +-- babel-plugin-transform-es2015-object-super@6.8.0
           [exec] | +-- babel-plugin-transform-es2015-parameters@6.17.0
           [exec] | +-- babel-plugin-transform-es2015-shorthand-properties@6.8.0
           [exec] | +-- babel-plugin-transform-es2015-spread@6.8.0
           [exec] | +-- babel-plugin-transform-es2015-sticky-regex@6.8.0
           [exec] | +-- babel-plugin-transform-es2015-template-literals@6.8.0
           [exec] | +-- babel-plugin-transform-es2015-typeof-symbol@6.8.0
           [exec] | +-- babel-plugin-transform-es2015-unicode-regex@6.11.0
           [exec] | +-- babel-plugin-transform-regenerator@6.16.1
           [exec] | +-- babel-plugin-transform-strict-mode@6.11.3
           [exec] | +-- babel-preset-es2015@6.16.0
           [exec] | +-- babel-preset-metal-resolve-source@1.0.1
           [exec] | +-- babel-register@6.16.3
           [exec] | | `-- lodash@4.16.4
           [exec] | +-- babel-runtime@6.11.6
           [exec] | +-- babel-template@6.16.0
           [exec] | | `-- lodash@4.16.4
           [exec] | +-- babel-traverse@6.16.0
           [exec] | | `-- lodash@4.16.4
           [exec] | +-- babel-types@6.16.0
           [exec] | | `-- lodash@4.16.4
           [exec] | +-- babylon@6.11.6
           [exec] | +-- balanced-match@0.4.2
           [exec] | +-- beeper@1.1.0
           [exec] | +-- binaryextensions@1.0.1
           [exec] | +-- bower@1.7.9
           [exec] | +-- brace-expansion@1.1.6
           [exec] | +-- braces@1.8.5
           [exec] | +-- buffer-shims@1.0.0
           [exec] | +-- builtin-modules@1.1.1
           [exec] | +-- camelcase@2.1.1
           [exec] | +-- camelcase-keys@2.1.0
           [exec] | +-- chalk@1.1.3
           [exec] | +-- cliui@3.2.0
           [exec] | +-- clone@1.0.2
           [exec] | +-- clone-stats@0.0.1
           [exec] | +-- code-point-at@1.0.1
           [exec] | +-- concat-map@0.0.1
           [exec] | +-- concat-with-sourcemaps@1.0.4
           [exec] | +-- convert-source-map@1.3.0
           [exec] | +-- core-js@2.4.1
           [exec] | +-- core-util-is@1.0.2
           [exec] | +-- css@2.2.1
           [exec] | | +-- inherits@2.0.3
           [exec] | | `-- source-map@0.1.43
           [exec] | +-- currently-unhandled@0.4.1
           [exec] | +-- dateformat@1.0.12
           [exec] | +-- debug@2.2.0
           [exec] | +-- debug-fabulous@0.0.4
           [exec] | | `-- object-assign@4.1.0
           [exec] | +-- decamelize@1.2.0
           [exec] | +-- detect-indent@3.0.1
           [exec] | +-- detect-newline@2.1.0
           [exec] | +-- duplexer@0.1.1
           [exec] | +-- duplexer2@0.0.2
           [exec] | +-- duplexify@3.4.5
           [exec] | | +-- inherits@2.0.3
           [exec] | | +-- isarray@1.0.0
           [exec] | | `-- readable-stream@2.1.5
           [exec] | +-- end-of-stream@1.0.0
           [exec] | +-- error-ex@1.3.0
           [exec] | +-- escape-string-regexp@1.0.5
           [exec] | +-- esutils@2.0.2
           [exec] | +-- expand-brackets@0.1.5
           [exec] | +-- expand-range@1.8.2
           [exec] | +-- extend@3.0.0
           [exec] | +-- extend-shallow@2.0.1
           [exec] | +-- extglob@0.3.2
           [exec] | | `-- is-extglob@1.0.0
           [exec] | +-- fancy-log@1.2.0
           [exec] | +-- filename-regex@2.0.0
           [exec] | +-- fill-range@2.2.3
           [exec] | +-- find-up@1.1.2
           [exec] | | `-- path-exists@2.1.0
           [exec] | +-- first-chunk-stream@1.0.0
           [exec] | +-- for-in@0.1.6
           [exec] | +-- for-own@0.1.4
           [exec] | +-- fork-stream@0.0.4
           [exec] | +-- gaze@0.5.2
           [exec] | +-- get-stdin@4.0.1
           [exec] | +-- glob@3.1.21
           [exec] | +-- glob-base@0.3.0
           [exec] | | +-- glob-parent@2.0.0
           [exec] | | +-- is-extglob@1.0.0
           [exec] | | `-- is-glob@2.0.1
           [exec] | +-- glob-expand@0.1.0
           [exec] | | +-- glob@4.4.2
           [exec] | | +-- inherits@2.0.3
           [exec] | | +-- lodash@1.2.1
           [exec] | | `-- minimatch@2.0.10
           [exec] | +-- glob-parent@3.0.0
           [exec] | +-- glob-stream@5.3.5
           [exec] | | +-- glob@5.0.15
           [exec] | | +-- inherits@2.0.3
           [exec] | | +-- minimatch@3.0.3
           [exec] | | +-- readable-stream@1.0.34
           [exec] | | `-- through2@0.6.5
           [exec] | +-- glob-watcher@2.0.0
           [exec] | +-- globals@8.18.0
           [exec] | +-- globule@0.1.0
           [exec] | +-- glogg@1.0.0
           [exec] | +-- graceful-fs@1.2.3
           [exec] | +-- gulp-babel-deps@2.0.1
           [exec] | +-- gulp-babel-globals@2.0.0
           [exec] | +-- gulp-if@2.0.1
           [exec] | +-- gulp-ignore@2.0.1
           [exec] | +-- gulp-match@1.0.2
           [exec] | | `-- minimatch@3.0.3
           [exec] | +-- gulp-replace@0.5.4
           [exec] | | +-- inherits@2.0.3
           [exec] | | +-- isarray@1.0.0
           [exec] | | `-- readable-stream@2.1.5
           [exec] | +-- gulp-sourcemaps@1.7.3
           [exec] | | +-- graceful-fs@4.1.9
           [exec] | | `-- vinyl@1.2.0
           [exec] | +-- gulp-util@3.0.7
           [exec] | +-- gulp-wrapper@1.0.0
           [exec] | | +-- inherits@2.0.3
           [exec] | | +-- readable-stream@1.0.34
           [exec] | | `-- through2@0.6.5
           [exec] | +-- gulplog@1.0.0
           [exec] | +-- has-ansi@2.0.0
           [exec] | +-- has-gulplog@0.1.0
           [exec] | +-- home-or-tmp@1.0.0
           [exec] | +-- hosted-git-info@2.1.5
           [exec] | +-- indent-string@2.1.0
           [exec] | | `-- repeating@2.0.1
           [exec] | +-- inflight@1.0.6
           [exec] | +-- inherits@1.0.2
           [exec] | +-- invariant@2.2.1
           [exec] | +-- invert-kv@1.0.0
           [exec] | +-- is-arrayish@0.2.1
           [exec] | +-- is-buffer@1.1.4
           [exec] | +-- is-builtin-module@1.0.0
           [exec] | +-- is-dotfile@1.0.2
           [exec] | +-- is-equal-shallow@0.1.3
           [exec] | +-- is-extendable@0.1.1
           [exec] | +-- is-extglob@2.1.0
           [exec] | +-- is-finite@1.0.2
           [exec] | +-- is-fullwidth-code-point@1.0.0
           [exec] | +-- is-glob@3.1.0
           [exec] | +-- is-number@2.1.0
           [exec] | +-- is-posix-bracket@0.1.1
           [exec] | +-- is-primitive@2.0.0
           [exec] | +-- is-stream@1.1.0
           [exec] | +-- is-utf8@0.2.1
           [exec] | +-- is-valid-glob@0.3.0
           [exec] | +-- isarray@0.0.1
           [exec] | +-- isobject@2.1.0
           [exec] | | `-- isarray@1.0.0
           [exec] | +-- istextorbinary@1.0.2
           [exec] | +-- js-tokens@2.0.0
           [exec] | +-- jsesc@0.5.0
           [exec] | +-- json-stable-stringify@1.0.1
           [exec] | +-- json5@0.4.0
           [exec] | +-- jsonify@0.0.0
           [exec] | +-- kind-of@3.0.4
           [exec] | +-- lazy-debug-legacy@0.0.1
           [exec] | +-- lazystream@1.0.0
           [exec] | | +-- inherits@2.0.3
           [exec] | | +-- isarray@1.0.0
           [exec] | | `-- readable-stream@2.1.5
           [exec] | +-- lcid@1.0.0
           [exec] | +-- load-json-file@1.1.0
           [exec] | | `-- graceful-fs@4.1.9
           [exec] | +-- lodash@1.0.2
           [exec] | +-- lodash._basecopy@3.0.1
           [exec] | +-- lodash._basetostring@3.0.1
           [exec] | +-- lodash._basevalues@3.0.0
           [exec] | +-- lodash._getnative@3.9.1
           [exec] | +-- lodash._isiterateecall@3.0.9
           [exec] | +-- lodash._reescape@3.0.0
           [exec] | +-- lodash._reevaluate@3.0.0
           [exec] | +-- lodash._reinterpolate@3.0.0
           [exec] | +-- lodash._root@3.0.1
           [exec] | +-- lodash.escape@3.2.0
           [exec] | +-- lodash.isarguments@3.1.0
           [exec] | +-- lodash.isarray@3.0.4
           [exec] | +-- lodash.isequal@4.4.0
           [exec] | +-- lodash.keys@3.1.2
           [exec] | +-- lodash.restparam@3.6.1
           [exec] | +-- lodash.template@3.6.2
           [exec] | +-- lodash.templatesettings@3.1.1
           [exec] | +-- loose-envify@1.2.0
           [exec] | | `-- js-tokens@1.0.3
           [exec] | +-- loud-rejection@1.6.0
           [exec] | +-- lru-cache@2.7.3
           [exec] | +-- map-obj@1.0.1
           [exec] | +-- meow@3.7.0
           [exec] | | `-- object-assign@4.1.0
           [exec] | +-- merge@1.2.0
           [exec] | +-- merge-stream@1.0.0
           [exec] | | +-- inherits@2.0.3
           [exec] | | +-- isarray@1.0.0
           [exec] | | `-- readable-stream@2.1.5
           [exec] | +-- metal-jquery-adapter@1.0.0
           [exec] | +-- metal-tools-build-amd@3.0.1
           [exec] | +-- metal-tools-build-globals@2.0.1
           [exec] | +-- metal-tools-build-jquery@2.0.1
           [exec] | +-- metal-tools-soy@3.0.2
           [exec] | +-- micromatch@2.3.11
           [exec] | | +-- is-extglob@1.0.0
           [exec] | | `-- is-glob@2.0.1
           [exec] | +-- minimatch@0.2.14
           [exec] | +-- minimist@1.2.0
           [exec] | +-- mkdirp@0.5.1
           [exec] | | `-- minimist@0.0.8
           [exec] | +-- mout@0.11.1
           [exec] | +-- ms@0.7.1
           [exec] | +-- mtil@0.1.3
           [exec] | +-- multipipe@0.1.2
           [exec] | +-- normalize-package-data@2.3.5
           [exec] | +-- normalize-path@2.0.1
           [exec] | +-- number-is-nan@1.0.1
           [exec] | +-- object-assign@3.0.0
           [exec] | +-- object.omit@2.0.0
           [exec] | +-- once@1.3.3
           [exec] | +-- ordered-read-streams@0.3.0
           [exec] | | +-- inherits@2.0.3
           [exec] | | +-- isarray@1.0.0
           [exec] | | `-- readable-stream@2.1.5
           [exec] | +-- os-locale@1.4.0
           [exec] | +-- os-tmpdir@1.0.2
           [exec] | +-- parse-glob@3.0.4
           [exec] | | +-- is-extglob@1.0.0
           [exec] | | `-- is-glob@2.0.1
           [exec] | +-- parse-json@2.2.0
           [exec] | +-- path-exists@1.0.0
           [exec] | +-- path-is-absolute@1.0.1
           [exec] | +-- path-type@1.1.0
           [exec] | | `-- graceful-fs@4.1.9
           [exec] | +-- pify@2.3.0
           [exec] | +-- pinkie@2.0.4
           [exec] | +-- pinkie-promise@2.0.1
           [exec] | +-- preserve@0.2.0
           [exec] | +-- private@0.1.6
           [exec] | +-- process-nextick-args@1.0.7
           [exec] | +-- randomatic@1.1.5
           [exec] | +-- read-pkg@1.1.0
           [exec] | +-- read-pkg-up@1.0.1
           [exec] | +-- readable-stream@1.1.14
           [exec] | | `-- inherits@2.0.3
           [exec] | +-- redent@1.0.0
           [exec] | +-- regenerate@1.3.1
           [exec] | +-- regenerator-runtime@0.9.5
           [exec] | +-- regex-cache@0.4.3
           [exec] | +-- regexpu-core@2.0.0
           [exec] | +-- regjsgen@0.2.0
           [exec] | +-- regjsparser@0.1.5
           [exec] | +-- repeat-element@1.1.2
           [exec] | +-- repeat-string@1.5.4
           [exec] | +-- repeating@1.1.3
           [exec] | +-- replace-ext@0.0.1
           [exec] | +-- replacestream@4.0.2
           [exec] | | +-- inherits@2.0.3
           [exec] | | +-- isarray@1.0.0
           [exec] | | +-- object-assign@4.1.0
           [exec] | | `-- readable-stream@2.1.5
           [exec] | +-- require-dir@0.3.1
           [exec] | +-- resolve@1.1.7
           [exec] | +-- resolve-url@0.2.1
           [exec] | +-- semver@5.3.0
           [exec] | +-- shebang-regex@1.0.0
           [exec] | +-- sigmund@1.0.1
           [exec] | +-- signal-exit@3.0.1
           [exec] | +-- slash@1.0.0
           [exec] | +-- source-map@0.5.6
           [exec] | +-- source-map-resolve@0.3.1
           [exec] | +-- source-map-support@0.4.3
           [exec] | +-- source-map-url@0.3.0
           [exec] | +-- soyparser@0.2.5
           [exec] | +-- sparkles@1.0.0
           [exec] | +-- spdx-correct@1.0.2
           [exec] | +-- spdx-expression-parse@1.0.4
           [exec] | +-- spdx-license-ids@1.2.2
           [exec] | +-- stream-combiner@0.2.2
           [exec] | +-- stream-consume@0.1.0
           [exec] | +-- stream-shift@1.0.0
           [exec] | +-- string-width@1.0.2
           [exec] | +-- string_decoder@0.10.31
           [exec] | +-- strip-ansi@3.0.1
           [exec] | +-- strip-bom@2.0.0
           [exec] | +-- strip-bom-stream@1.0.0
           [exec] | +-- strip-indent@1.0.1
           [exec] | +-- supports-color@2.0.0
           [exec] | +-- ternary-stream@2.0.0
           [exec] | +-- textextensions@1.0.2
           [exec] | +-- through@2.3.8
           [exec] | +-- through2@2.0.1
           [exec] | | +-- inherits@2.0.3
           [exec] | | +-- isarray@1.0.0
           [exec] | | `-- readable-stream@2.0.6
           [exec] | +-- through2-filter@2.0.0
           [exec] | +-- time-stamp@1.0.1
           [exec] | +-- to-absolute-glob@0.1.1
           [exec] | +-- to-fast-properties@1.0.2
           [exec] | +-- trim-newlines@1.0.0
           [exec] | +-- tunic@1.0.0
           [exec] | +-- unique-stream@2.2.1
           [exec] | +-- urix@0.1.0
           [exec] | +-- user-home@1.1.1
           [exec] | +-- util-deprecate@1.0.2
           [exec] | +-- vali-date@1.0.0
           [exec] | +-- validate-npm-package-license@3.0.1
           [exec] | +-- vinyl@0.5.3
           [exec] | +-- vinyl-fs@2.4.3
           [exec] | | +-- graceful-fs@4.1.9
           [exec] | | +-- inherits@2.0.3
           [exec] | | +-- isarray@1.0.0
           [exec] | | +-- object-assign@4.1.0
           [exec] | | +-- readable-stream@2.1.5
           [exec] | | `-- vinyl@1.2.0
           [exec] | +-- vinyl-sourcemaps-apply@0.2.1
           [exec] | +-- window-size@0.1.4
           [exec] | +-- wrap-ansi@2.0.0
           [exec] | +-- wrappy@1.0.2
           [exec] | +-- xtend@4.0.1
           [exec] | +-- y18n@3.2.1
           [exec] | `-- yargs@3.32.0
           [exec] +-- metal-component@2.6.2
           [exec] +-- metal-dom@2.6.0
           [exec] +-- metal-dropdown@2.0.0
           [exec] +-- metal-events@2.6.0
           [exec] +-- metal-incremental-dom@2.6.2
           [exec] +-- metal-position@2.0.0
           [exec] +-- metal-soy@2.6.3
           [exec] +-- metal-soy-bundle@2.2.0
           [exec] +-- metal-state@2.6.0
           [exec] +-- micromatch@2.3.11
           [exec] npm WARN frontend-taglib@2.2.6 No description
           [exec] npm WARN frontend-taglib@2.2.6 No repository field.
           [exec] +-- minimatch@3.0.3
           [exec] +-- minimist@1.2.0
           [exec] +-- mkdirp@0.5.1
           [exec] | `-- minimist@0.0.8
           [exec] +-- multipipe@0.1.2
           [exec] +-- natives@1.1.0
           [exec] npm WARN frontend-taglib@2.2.6 No license field.
           [exec] +-- node-status-codes@1.0.0
           [exec] +-- nopt@3.0.6
           [exec] +-- normalize-path@2.0.1
           [exec] +-- number-is-nan@1.0.1
           [exec] +-- object-assign@3.0.0
           [exec] +-- object.omit@2.0.1
           [exec] +-- once@1.4.0
           [exec] +-- orchestrator@0.3.8
           [exec] +-- ordered-read-streams@0.1.0
           [exec] +-- os-homedir@1.0.2
           [exec] +-- os-tmpdir@1.0.2
           [exec] +-- osenv@0.1.4
           [exec] +-- package-json@2.4.0
           [exec] | `-- semver@5.3.0
           [exec] +-- packrattle@4.1.0
           [exec] +-- parse-filepath@1.0.1
           [exec] +-- parse-glob@3.0.4
           [exec] +-- parse-json@2.2.0
           [exec] +-- parse-passwd@1.0.0
           [exec] +-- path-is-absolute@1.0.1
           [exec] +-- path-root@0.1.1
           [exec] +-- path-root-regex@0.1.2
           [exec] +-- pinkie@2.0.4
           [exec] +-- pinkie-promise@2.0.1
           [exec] +-- prepend-http@1.0.4
           [exec] +-- preserve@0.2.0
           [exec] +-- pretty-hrtime@1.0.3
           [exec] +-- private@0.1.7
           [exec] +-- process-nextick-args@1.0.7
           [exec] +-- proto-list@1.2.4
           [exec] +-- pseudomap@1.0.2
           [exec] +-- randomatic@1.1.6
           [exec] +-- rc@1.1.6
           [exec] +-- read-all-stream@3.1.0
           [exec] | +-- isarray@1.0.0
           [exec] | `-- readable-stream@2.2.2
           [exec] +-- readable-stream@1.1.14
           [exec] +-- recast@0.10.43
           [exec] | `-- esprima-fb@15001.1001.0-dev-harmony-fb
           [exec] +-- rechoir@0.6.2
           [exec] +-- regex-cache@0.4.3
           [exec] +-- registry-auth-token@3.1.0
           [exec] +-- registry-url@3.1.0
           [exec] +-- repeat-element@1.1.2
           [exec] +-- repeat-string@1.6.1
           [exec] +-- repeating@2.0.1
           [exec] +-- replace-ext@0.0.1
           [exec] +-- resolve@1.2.0
           [exec] +-- resolve-dir@0.1.1
           [exec] +-- rimraf@2.5.4
           [exec] +-- semver@4.3.6
           [exec] +-- semver-diff@2.1.0
           [exec] | `-- semver@5.3.0
           [exec] +-- sequencify@0.0.7
           [exec] +-- sigmund@1.0.1
           [exec] +-- slide@1.1.6
           [exec] +-- source-map@0.5.6
           [exec] +-- sparkles@1.0.0
           [exec] +-- stream-consume@0.1.0
           [exec] +-- string-width@1.0.2
           [exec] +-- string_decoder@0.10.31
           [exec] +-- strip-ansi@3.0.1
           [exec] +-- strip-bom@1.0.0
           [exec] +-- strip-json-comments@1.0.4
           [exec] +-- supports-color@2.0.0
           [exec] +-- through2@2.0.3
           [exec] | +-- isarray@1.0.0
           [exec] | `-- readable-stream@2.2.2
           [exec] +-- tildify@1.2.0
           [exec] +-- time-stamp@1.0.1
           [exec] +-- timed-out@3.1.3
           [exec] +-- unc-path-regex@0.1.2
           [exec] +-- underscore@1.8.3
           [exec] +-- underscore.string@2.3.3
           [exec] +-- unique-stream@1.0.0
           [exec] +-- unzip-response@1.0.2
           [exec] +-- upath@0.1.7
           [exec] | `-- lodash@3.10.1
           [exec] +-- update-notifier@0.6.3
           [exec] +-- url-parse-lax@1.0.0
           [exec] +-- user-home@1.1.1
           [exec] +-- util-deprecate@1.0.2
           [exec] +-- uuid@2.0.3
           [exec] +-- v8flags@2.0.11
           [exec] +-- vinyl@0.5.3
           [exec] +-- vinyl-fs@0.3.14
           [exec] | +-- clone@0.2.0
           [exec] | +-- graceful-fs@3.0.11
           [exec] | +-- readable-stream@1.0.34
           [exec] | +-- through2@0.6.5
           [exec] | `-- vinyl@0.4.6
           [exec] +-- walk@2.3.9
           [exec] +-- walkdir@0.0.10
           [exec] +-- which@1.2.12
           [exec] +-- widest-line@1.0.0
           [exec] +-- wrappy@1.0.2
           [exec] +-- write-file-atomic@1.3.1
           [exec] +-- xdg-basedir@2.0.0
           [exec] `-- xtend@4.0.1
           [exec]
           [exec]
           [exec] > node-sass@4.5.3 install L:\EE\70p\modules\apps\foundation\frontend-js\frontend-js-web\node_modules\gulp-metal\node_modules\node-sass
           [exec] > node scripts/install.js
           [exec]
           [exec] Downloading binary from https://github.com/sass/node-sass/releases/download/v4.5.3/win32-x64-48_binding.node
           [exec] Download complete
           [exec] Binary saved to L:\EE\70p\modules\apps\foundation\frontend-js\frontend-js-web\node_modules\gulp-metal\node_modules\node-sass\vendor\win32-x64-48\binding.node
           [exec] Caching binary to L:\EE\70p\modules\apps\foundation\frontend-js\frontend-js-web\build\node\.cache\node-sass\4.5.3\win32-x64-48_binding.node
           [exec]
           [exec] > spawn-sync@1.0.15 postinstall L:\EE\70p\modules\apps\foundation\frontend-js\frontend-js-web\node_modules\gulp-metal\node_modules\spawn-sync
           [exec] > node postinstall
           [exec]
           [exec]
           [exec] > sauce-connect-launcher@0.13.0 postinstall L:\EE\70p\modules\apps\foundation\frontend-js\frontend-js-web\node_modules\gulp-metal\node_modules\sauce-connect-launcher
           [exec] > node scripts/install.js
           [exec]
           [exec]
           [exec] > node-sass@4.5.3 postinstall L:\EE\70p\modules\apps\foundation\frontend-js\frontend-js-web\node_modules\gulp-metal\node_modules\node-sass
           [exec] > node scripts/build.js
           [exec]
           [exec] Binary found at L:\EE\70p\modules\apps\foundation\frontend-js\frontend-js-web\node_modules\gulp-metal\node_modules\node-sass\vendor\win32-x64-48\binding.node
           [exec] Testing binary
           [exec] Binary is fine
           [exec] frontend-js-web@1.0.56 L:\EE\70p\modules\apps\foundation\frontend-js\frontend-js-web
           [exec] +-- abbrev@1.0.9
           [exec] +-- accepts@1.3.3
           [exec] +-- acorn@5.0.3
           [exec] +-- acorn-jsx@3.0.1
           [exec] | `-- acorn@3.3.0
           [exec] +-- after@0.8.2
           [exec] +-- ajv@4.11.8
           [exec] +-- ajv-keywords@1.5.1
           [exec] +-- align-text@0.1.4
           [exec] +-- amdefine@1.0.1
           [exec] +-- ansi-escapes@1.4.0
           [exec] +-- ansi-regex@2.1.1
           [exec] +-- ansi-styles@2.2.1
           [exec] +-- anymatch@1.3.0
           [exec] +-- archy@1.0.0
           [exec] +-- argparse@1.0.9
           [exec] +-- arr-diff@2.0.0
           [exec] +-- arr-flatten@1.0.3
           [exec] +-- array-differ@1.0.0
           [exec] +-- array-each@1.0.1
           [exec] +-- array-find-index@1.0.2
           [exec] +-- array-slice@1.0.0
           [exec] +-- array-union@1.0.2
           [exec] +-- array-uniq@1.0.3
           [exec] +-- array-unique@0.2.1
           [exec] +-- arraybuffer.slice@0.0.6
           [exec] +-- arrify@1.0.1
           [exec] +-- assertion-error@1.0.0
           [exec] +-- ast-types@0.9.11
           [exec] +-- async@1.5.2
           [exec] +-- async-each@1.0.1
           [exec] +-- autoprefixer@6.7.7
           [exec] +-- babel-code-frame@6.22.0
           [exec] +-- babel-core@6.25.0
           [exec] | +-- lodash@4.17.4
           [exec] | `-- minimatch@3.0.4
           [exec] +-- babel-generator@6.25.0
           [exec] | +-- jsesc@1.3.0
           [exec] | `-- lodash@4.17.4
           [exec] +-- babel-helper-call-delegate@6.24.1
           [exec] +-- babel-helper-define-map@6.24.1
           [exec] | `-- lodash@4.17.4
           [exec] +-- babel-helper-function-name@6.24.1
           [exec] +-- babel-helper-get-function-arity@6.24.1
           [exec] +-- babel-helper-hoist-variables@6.24.1
           [exec] +-- babel-helper-optimise-call-expression@6.24.1
           [exec] +-- babel-helper-regex@6.24.1
           [exec] | `-- lodash@4.17.4
           [exec] +-- babel-helper-replace-supers@6.24.1
           [exec] +-- babel-helpers@6.24.1
           [exec] +-- babel-messages@6.23.0
           [exec] +-- babel-plugin-check-es2015-constants@6.22.0
           [exec] +-- babel-plugin-transform-es2015-arrow-functions@6.22.0
           [exec] +-- babel-plugin-transform-es2015-block-scoped-functions@6.22.0
           [exec] +-- babel-plugin-transform-es2015-block-scoping@6.24.1
           [exec] | `-- lodash@4.17.4
           [exec] +-- babel-plugin-transform-es2015-classes@6.24.1
           [exec] +-- babel-plugin-transform-es2015-computed-properties@6.24.1
           [exec] +-- babel-plugin-transform-es2015-destructuring@6.23.0
           [exec] +-- babel-plugin-transform-es2015-duplicate-keys@6.24.1
           [exec] +-- babel-plugin-transform-es2015-for-of@6.23.0
           [exec] +-- babel-plugin-transform-es2015-function-name@6.24.1
           [exec] +-- babel-plugin-transform-es2015-literals@6.22.0
           [exec] +-- babel-plugin-transform-es2015-modules-amd@6.24.1
           [exec] +-- babel-plugin-transform-es2015-modules-commonjs@6.24.1
           [exec] +-- babel-plugin-transform-es2015-modules-systemjs@6.24.1
           [exec] +-- babel-plugin-transform-es2015-modules-umd@6.24.1
           [exec] +-- babel-plugin-transform-es2015-object-super@6.24.1
           [exec] +-- babel-plugin-transform-es2015-parameters@6.24.1
           [exec] +-- babel-plugin-transform-es2015-shorthand-properties@6.24.1
           [exec] +-- babel-plugin-transform-es2015-spread@6.22.0
           [exec] +-- babel-plugin-transform-es2015-sticky-regex@6.24.1
           [exec] +-- babel-plugin-transform-es2015-template-literals@6.22.0
           [exec] +-- babel-plugin-transform-es2015-typeof-symbol@6.23.0
           [exec] +-- babel-plugin-transform-es2015-unicode-regex@6.24.1
           [exec] +-- babel-plugin-transform-node-env-inline@0.1.1
           [exec] +-- babel-plugin-transform-regenerator@6.24.1
           [exec] +-- babel-plugin-transform-strict-mode@6.24.1
           [exec] +-- babel-preset-es2015@6.24.1
           [exec] +-- babel-preset-metal@3.1.0
           [exec] +-- babel-register@6.24.1
           [exec] | `-- lodash@4.17.4
           [exec] +-- babel-runtime@6.23.0
           [exec] +-- babel-template@6.25.0
           [exec] | `-- lodash@4.17.4
           [exec] +-- babel-traverse@6.25.0
           [exec] | `-- lodash@4.17.4
           [exec] +-- babel-types@6.25.0
           [exec] | `-- lodash@4.17.4
           [exec] +-- babylon@6.17.4
           [exec] +-- backo2@1.0.2
           [exec] +-- balanced-match@1.0.0
           [exec] +-- base64-arraybuffer@0.1.5
           [exec] +-- base64id@1.0.0
           [exec] +-- bcrypt-pbkdf@1.0.1
           [exec] +-- beeper@1.1.1
           [exec] +-- better-assert@1.0.2
           [exec] +-- binary-extensions@1.8.0
           [exec] +-- blob@0.0.4
           [exec] +-- bluebird@3.5.0
           [exec] +-- body-parser@1.17.2
           [exec] | `-- debug@2.6.7
           [exec] +-- boxen@0.3.1
           [exec] | `-- object-assign@4.1.1
           [exec] +-- brace-expansion@1.1.8
           [exec] +-- braces@1.8.5
           [exec] +-- browserslist@1.7.7
           [exec] +-- builtin-modules@1.1.1
           [exec] +-- bytes@2.4.0
           [exec] +-- caller-path@0.1.0
           [exec] +-- callsite@1.0.0
           [exec] +-- callsites@0.2.0
           [exec] +-- camelcase@1.2.1
           [exec] +-- camelcase-keys@2.1.0
           [exec] | `-- camelcase@2.1.1
           [exec] +-- caniuse-db@1.0.30000696
           [exec] +-- capture-stack-trace@1.0.0
           [exec] +-- center-align@0.1.3
           [exec] +-- chai@2.3.0
           [exec] +-- chalk@1.1.3
           [exec] +-- chokidar@1.7.0
           [exec] +-- circular-json@0.3.1
           [exec] +-- cli-cursor@1.0.2
           [exec] +-- cli-width@2.1.0
           [exec] +-- cliui@2.1.0
           [exec] | `-- wordwrap@0.0.2
           [exec] +-- clone@1.0.2
           [exec] +-- clone-stats@0.0.1
           [exec] +-- co@4.6.0
           [exec] +-- code-point-at@1.1.0
           [exec] +-- colors@1.1.2
           [exec] +-- combine-lists@1.0.1
           [exec] | `-- lodash@4.17.4
           [exec] +-- commander@2.10.0
           [exec] +-- component-bind@1.0.0
           [exec] +-- component-emitter@1.1.2
           [exec] +-- component-inherit@0.0.3
           [exec] +-- concat-map@0.0.1
           [exec] +-- concat-stream@1.6.0
           [exec] | +-- isarray@1.0.0
           [exec] | +-- readable-stream@2.3.2
           [exec] | `-- string_decoder@1.0.3
           [exec] +-- config-chain@1.1.11
           [exec] +-- configstore@2.1.0
           [exec] | +-- graceful-fs@4.1.11
           [exec] | `-- object-assign@4.1.1
           [exec] +-- connect@3.6.2
           [exec] | `-- debug@2.6.7
           [exec] +-- content-type@1.0.2
           [exec] +-- convert-source-map@1.5.0
           [exec] +-- cookie@0.3.1
           [exec] +-- core-js@2.4.1
           [exec] +-- core-util-is@1.0.2
           [exec] +-- create-error-class@3.0.2
           [exec] +-- currently-unhandled@0.4.1
           [exec] +-- custom-event@1.0.1
           [exec] +-- d@1.0.0
           [exec] +-- dateformat@2.0.0
           [exec] +-- debug@2.6.8
           [exec] +-- decamelize@1.2.0
           [exec] +-- deep-eql@0.1.3
           [exec] +-- deep-extend@0.4.2
           [exec] +-- deep-is@0.1.3
           [exec] +-- defaults@1.0.3
           [exec] +-- del@2.2.2
           [exec] | `-- object-assign@4.1.1
           [exec] +-- depd@1.1.0
           [exec] +-- deprecated@0.0.1
           [exec] +-- detect-file@0.1.0
           [exec] +-- detect-indent@4.0.0
           [exec] +-- di@0.0.1
           [exec] +-- diff@1.4.0
           [exec] +-- doctrine@2.0.0
           [exec] | `-- isarray@1.0.0
           [exec] +-- dom-serialize@2.2.1
           [exec] +-- dot-prop@3.0.0
           [exec] +-- duplexer2@0.0.2
           [exec] +-- ecc-jsbn@0.1.1
           [exec] +-- editorconfig@0.13.2
           [exec] | `-- lru-cache@3.2.0
           [exec] +-- ee-first@1.1.1
           [exec] +-- electron-to-chromium@1.3.15
           [exec] +-- encodeurl@1.0.1
           [exec] +-- end-of-stream@0.1.5
           [exec] +-- engine.io@1.8.3
           [exec] | +-- debug@2.3.3
           [exec] | `-- ms@0.7.2
           [exec] +-- engine.io-client@1.8.3
           [exec] | +-- component-emitter@1.2.1
           [exec] | +-- debug@2.3.3
           [exec] | `-- ms@0.7.2
           [exec] +-- engine.io-parser@1.3.2
           [exec] +-- ent@2.2.0
           [exec] +-- error-ex@1.3.1
           [exec] +-- es5-ext@0.10.23
           [exec] +-- es6-iterator@2.0.1
           [exec] +-- es6-map@0.1.5
           [exec] +-- es6-plato@1.0.14
           [exec] | +-- glob@7.1.2
           [exec] | +-- lodash@4.17.4
           [exec] | `-- minimatch@3.0.4
           [exec] +-- es6-promise@4.1.1
           [exec] +-- es6-set@0.1.5
           [exec] +-- es6-symbol@3.1.1
           [exec] +-- es6-weak-map@2.0.2
           [exec] +-- escape-html@1.0.3
           [exec] +-- escape-string-regexp@1.0.5
           [exec] +-- escodegen@1.8.1
           [exec] | +-- esprima@2.7.3
           [exec] | +-- estraverse@1.9.3
           [exec] | `-- source-map@0.2.0
           [exec] +-- escomplex-plugin-metrics-module@0.0.13
           [exec] +-- escomplex-plugin-metrics-project@0.0.13
           [exec] +-- escomplex-plugin-syntax-babylon@0.0.13
           [exec] +-- escomplex-plugin-syntax-estree@0.0.13
           [exec] +-- escope@3.6.0
           [exec] +-- eslint@3.19.0
           [exec] | +-- glob@7.1.2
           [exec] | +-- lodash@4.17.4
           [exec] | +-- minimatch@3.0.4
           [exec] | +-- strip-bom@3.0.0
           [exec] | `-- user-home@2.0.0
           [exec] +-- espree@3.4.3
           [exec] +-- esprima@3.1.3
           [exec] +-- esquery@1.0.0
           [exec] +-- esrecurse@4.2.0
           [exec] | `-- object-assign@4.1.1
           [exec] +-- estraverse@4.2.0
           [exec] +-- esutils@2.0.2
           [exec] +-- event-emitter@0.3.5
           [exec] +-- eventemitter3@1.2.0
           [exec] +-- exit-hook@1.1.1
           [exec] +-- expand-braces@0.1.2
           [exec] | +-- array-slice@0.2.3
           [exec] | +-- braces@0.1.5
           [exec] | +-- expand-range@0.1.1
           [exec] | +-- is-number@0.1.1
           [exec] | `-- repeat-string@0.2.2
           [exec] +-- expand-brackets@0.1.5
           [exec] +-- expand-range@1.8.2
           [exec] +-- expand-tilde@1.2.2
           [exec] +-- extend@3.0.1
           [exec] +-- extglob@0.3.2
           [exec] +-- fancy-log@1.3.0
           [exec] +-- fast-levenshtein@2.0.6
           [exec] +-- figures@1.7.0
           [exec] | `-- object-assign@4.1.1
           [exec] +-- file-entry-cache@2.0.0
           [exec] | `-- object-assign@4.1.1
           [exec] +-- filename-regex@2.0.1
           [exec] +-- fill-range@2.2.3
           [exec] +-- filled-array@1.1.0
           [exec] +-- finalhandler@1.0.3
           [exec] | `-- debug@2.6.7
           [exec] +-- find-index@0.1.1
           [exec] +-- find-up@1.1.2
           [exec] +-- findup-sync@0.4.3
           [exec] +-- fined@1.1.0
           [exec] | `-- expand-tilde@2.0.2
           [exec] +-- first-chunk-stream@1.0.0
           [exec] +-- flagged-respawn@0.3.2
           [exec] +-- flat-cache@1.2.2
           [exec] | `-- graceful-fs@4.1.11
           [exec] +-- for-in@1.0.2
           [exec] +-- for-own@0.1.5
           [exec] +-- foreachasync@3.0.0
           [exec] +-- formatio@1.1.1
           [exec] +-- fs-access@1.0.1
           [exec] +-- fs-exists-sync@0.1.0
           [exec] +-- fs-extra@2.1.2
           [exec] | `-- graceful-fs@4.1.11
           [exec] +-- fs.realpath@1.0.0
           [exec] +-- gaze@0.5.2
           [exec] +-- generate-function@2.0.0
           [exec] +-- generate-object-property@1.2.0
           [exec] +-- get-stdin@4.0.1
           [exec] +-- glob@4.5.3
           [exec] +-- glob-base@0.3.0
           [exec] +-- glob-parent@2.0.0
           [exec] +-- glob-stream@3.1.18
           [exec] | +-- readable-stream@1.0.34
           [exec] | `-- through2@0.6.5
           [exec] +-- glob-watcher@0.0.6
           [exec] +-- glob2base@0.0.12
           [exec] +-- global-modules@0.2.3
           [exec] +-- global-prefix@0.1.5
           [exec] +-- globals@9.18.0
           [exec] +-- globby@5.0.0
           [exec] | +-- glob@7.1.2
           [exec] | +-- minimatch@3.0.4
           [exec] | `-- object-assign@4.1.1
           [exec] +-- globule@0.1.0
           [exec] | +-- glob@3.1.21
           [exec] | +-- graceful-fs@1.2.3
           [exec] | +-- inherits@1.0.2
           [exec] | `-- minimatch@0.2.14
           [exec] +-- glogg@1.0.0
           [exec] +-- got@5.7.1
           [exec] | +-- duplexer2@0.1.4
           [exec] | +-- isarray@1.0.0
           [exec] | +-- object-assign@4.1.1
           [exec] | +-- readable-stream@2.3.2
           [exec] | `-- string_decoder@1.0.3
           [exec] +-- graceful-fs@3.0.11
           [exec] +-- graceful-readlink@1.0.1
           [exec] +-- growl@1.9.2
           [exec] +-- gulp@3.9.1
           [exec] +-- gulp-autoprefixer@3.1.1
           [exec] +-- gulp-metal@2.2.1
           [exec] | +-- abbrev@1.1.0
           [exec] | +-- accepts@1.3.3
           [exec] | +-- acorn@5.0.3
           [exec] | +-- acorn-jsx@3.0.1
           [exec] | | `-- acorn@3.3.0
           [exec] | +-- adm-zip@0.4.7
           [exec] | +-- after@0.8.2
           [exec] | +-- agent-base@2.1.1
           [exec] | | `-- semver@5.0.3
           [exec] | +-- ajv@4.11.8
           [exec] | +-- ajv-keywords@1.5.1
           [exec] | +-- align-text@0.1.4
           [exec] | +-- amdefine@1.0.1
           [exec] | +-- ansi-escapes@1.4.0
           [exec] | +-- ansi-regex@2.1.1
           [exec] | +-- ansi-styles@2.2.1
           [exec] | +-- anymatch@1.3.0
           [exec] | +-- aproba@1.1.2
           [exec] | +-- archiver@0.14.4
           [exec] | | +-- async@0.9.2
           [exec] | | +-- glob@4.3.5
           [exec] | | +-- isarray@0.0.1
           [exec] | | +-- lodash@3.2.0
           [exec] | | +-- minimatch@2.0.10
           [exec] | | +-- readable-stream@1.0.34
           [exec] | | `-- string_decoder@0.10.31
           [exec] | +-- are-we-there-yet@1.1.4
           [exec] | +-- argparse@1.0.9
           [exec] | +-- arr-diff@2.0.0
           [exec] | +-- arr-flatten@1.0.3
           [exec] | +-- array-differ@1.0.0
           [exec] | +-- array-find-index@1.0.2
           [exec] | +-- array-slice@0.2.3
           [exec] | +-- array-union@1.0.2
           [exec] | +-- array-uniq@1.0.3
           [exec] | +-- array-unique@0.2.1
           [exec] | +-- arraybuffer.slice@0.0.6
           [exec] | +-- arrify@1.0.1
           [exec] | +-- asn1@0.2.3
           [exec] | +-- assert-plus@0.2.0
           [exec] | +-- assertion-error@1.0.0
           [exec] | +-- async@0.2.10
           [exec] | +-- async-each@1.0.1
           [exec] | +-- async-foreach@0.1.3
           [exec] | +-- asynckit@0.4.0
           [exec] | +-- aws-sign2@0.6.0
           [exec] | +-- aws4@1.6.0
           [exec] | +-- babel-code-frame@6.22.0
           [exec] | +-- babel-core@6.25.0
           [exec] | +-- babel-generator@6.25.0
           [exec] | | `-- jsesc@1.3.0
           [exec] | +-- babel-globals@2.0.1
           [exec] | | `-- babel-deps@2.1.0
           [exec] | +-- babel-helper-call-delegate@6.24.1
           [exec] | +-- babel-helper-define-map@6.24.1
           [exec] | +-- babel-helper-function-name@6.24.1
           [exec] | +-- babel-helper-get-function-arity@6.24.1
           [exec] | +-- babel-helper-hoist-variables@6.24.1
           [exec] | +-- babel-helper-optimise-call-expression@6.24.1
           [exec] | +-- babel-helper-regex@6.24.1
           [exec] | +-- babel-helper-replace-supers@6.24.1
           [exec] | +-- babel-helpers@6.24.1
           [exec] | +-- babel-messages@6.23.0
           [exec] | +-- babel-plugin-check-es2015-constants@6.22.0
           [exec] | +-- babel-plugin-external-helpers-2@6.3.13
           [exec] | | +-- babel-runtime@5.8.38
           [exec] | | `-- core-js@1.2.7
           [exec] | +-- babel-plugin-globals@2.0.1
           [exec] | +-- babel-plugin-transform-es2015-arrow-functions@6.22.0
           [exec] | +-- babel-plugin-transform-es2015-block-scoped-functions@6.22.0
           [exec] | +-- babel-plugin-transform-es2015-block-scoping@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-classes@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-computed-properties@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-destructuring@6.23.0
           [exec] | +-- babel-plugin-transform-es2015-duplicate-keys@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-for-of@6.23.0
           [exec] | +-- babel-plugin-transform-es2015-function-name@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-literals@6.22.0
           [exec] | +-- babel-plugin-transform-es2015-modules-amd@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-modules-commonjs@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-modules-systemjs@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-modules-umd@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-object-super@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-parameters@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-shorthand-properties@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-spread@6.22.0
           [exec] | +-- babel-plugin-transform-es2015-sticky-regex@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-template-literals@6.22.0
           [exec] | +-- babel-plugin-transform-es2015-typeof-symbol@6.23.0
           [exec] | +-- babel-plugin-transform-es2015-unicode-regex@6.24.1
           [exec] | +-- babel-plugin-transform-node-env-inline@0.1.1
           [exec] | +-- babel-plugin-transform-regenerator@6.24.1
           [exec] | +-- babel-plugin-transform-strict-mode@6.24.1
           [exec] | +-- babel-preset-es2015@6.24.1
           [exec] | +-- babel-preset-metal@3.1.0
           [exec] | +-- babel-preset-metal-resolve-source@1.0.2
           [exec] | +-- babel-register@6.24.1
           [exec] | +-- babel-runtime@6.23.0
           [exec] | +-- babel-template@6.25.0
           [exec] | +-- babel-traverse@6.25.0
           [exec] | +-- babel-types@6.25.0
           [exec] | +-- babylon@6.17.3
           [exec] | +-- backo2@1.0.2
           [exec] | +-- balanced-match@1.0.0
           [exec] | +-- base64-arraybuffer@0.1.5
           [exec] | +-- base64id@1.0.0
           [exec] | +-- beeper@1.1.1
           [exec] | +-- better-assert@1.0.2
           [exec] | +-- binary-extensions@1.8.0
           [exec] | +-- binaryextensions@1.0.1
           [exec] | +-- bl@0.9.5
           [exec] | | +-- isarray@0.0.1
           [exec] | | +-- readable-stream@1.0.34
           [exec] | | `-- string_decoder@0.10.31
           [exec] | +-- blob@0.0.4
           [exec] | +-- block-stream@0.0.9
           [exec] | +-- bluebird@3.4.7
           [exec] | +-- body-parser@1.17.2
           [exec] | | `-- debug@2.6.7
           [exec] | +-- boom@2.10.1
           [exec] | +-- bower@1.8.0
           [exec] | +-- brace-expansion@1.1.8
           [exec] | +-- braces@1.8.5
           [exec] | +-- buffer-crc32@0.2.13
           [exec] | +-- bufferstreams@1.1.1
           [exec] | +-- builtin-modules@1.1.1
           [exec] | +-- bytes@2.4.0
           [exec] | +-- caller-path@0.1.0
           [exec] | +-- callsite@1.0.0
           [exec] | +-- callsites@0.2.0
           [exec] | +-- camelcase@2.1.1
           [exec] | +-- camelcase-keys@2.1.0
           [exec] | +-- caseless@0.12.0
           [exec] | +-- catharsis@0.8.8
           [exec] | +-- center-align@0.1.3
           [exec] | +-- chai@2.3.0
           [exec] | +-- chalk@1.1.3
           [exec] | +-- chokidar@1.7.0
           [exec] | +-- circular-json@0.3.1
           [exec] | +-- cli@1.0.1
           [exec] | +-- cli-cursor@1.0.2
           [exec] | +-- cli-width@2.1.0
           [exec] | +-- cliui@3.2.0
           [exec] | +-- clone@1.0.2
           [exec] | +-- clone-buffer@1.0.0
           [exec] | +-- clone-stats@0.0.1
           [exec] | +-- cloneable-readable@1.0.0
           [exec] | | `-- through2@2.0.3
           [exec] | +-- co@4.6.0
           [exec] | +-- code-point-at@1.1.0
           [exec] | +-- colors@1.1.2
           [exec] | +-- combine-lists@1.0.1
           [exec] | +-- combined-stream@1.0.5
           [exec] | +-- commander@2.9.0
           [exec] | +-- component-bind@1.0.0
           [exec] | +-- component-emitter@1.1.2
           [exec] | +-- component-inherit@0.0.3
           [exec] | +-- compress-commons@0.2.9
           [exec] | | +-- isarray@0.0.1
           [exec] | | +-- readable-stream@1.0.34
           [exec] | | `-- string_decoder@0.10.31
           [exec] | +-- concat-map@0.0.1
           [exec] | +-- concat-stream@1.6.0
           [exec] | +-- concat-with-sourcemaps@1.0.4
           [exec] | +-- connect@3.6.2
           [exec] | | `-- debug@2.6.7
           [exec] | +-- console-browserify@1.1.0
           [exec] | +-- console-control-strings@1.1.0
           [exec] | +-- content-type@1.0.2
           [exec] | +-- convert-source-map@1.5.0
           [exec] | +-- cookie@0.3.1
           [exec] | +-- core-js@2.4.1
           [exec] | +-- core-util-is@1.0.2
           [exec] | +-- crc32-stream@0.3.4
           [exec] | | +-- isarray@0.0.1
           [exec] | | +-- readable-stream@1.0.34
           [exec] | | `-- string_decoder@0.10.31
           [exec] | +-- cross-spawn@3.0.1
           [exec] | | `-- lru-cache@4.1.1
           [exec] | +-- cryptiles@2.0.5
           [exec] | +-- ctype@0.5.3
           [exec] | +-- currently-unhandled@0.4.1
           [exec] | +-- custom-event@1.0.1
           [exec] | +-- d@1.0.0
           [exec] | +-- dashdash@1.14.1
           [exec] | | `-- assert-plus@1.0.0
           [exec] | +-- date-now@0.1.4
           [exec] | +-- dateformat@2.0.0
           [exec] | +-- deap@1.0.0
           [exec] | +-- debug@2.6.8
           [exec] | +-- decamelize@1.2.0
           [exec] | +-- deep-eql@0.1.3
           [exec] | +-- deep-is@0.1.3
           [exec] | +-- del@2.2.2
           [exec] | +-- delayed-stream@1.0.0
           [exec] | +-- delegates@1.0.0
           [exec] | +-- depd@1.1.0
           [exec] | +-- detect-indent@4.0.0
           [exec] | +-- di@0.0.1
           [exec] | +-- diff@1.4.0
           [exec] | +-- disparity@2.0.0
           [exec] | +-- doctrine@2.0.0
           [exec] | +-- dom-serialize@2.2.1
           [exec] | +-- dom-serializer@0.1.0
           [exec] | | +-- domelementtype@1.1.3
           [exec] | | `-- entities@1.1.1
           [exec] | +-- domelementtype@1.3.0
           [exec] | +-- domhandler@2.3.0
           [exec] | +-- domutils@1.5.1
           [exec] | +-- duplexer@0.1.1
           [exec] | +-- duplexer2@0.0.2
           [exec] | | +-- isarray@0.0.1
           [exec] | | +-- readable-stream@1.1.14
           [exec] | | `-- string_decoder@0.10.31
           [exec] | +-- duplexify@3.5.0
           [exec] | | +-- end-of-stream@1.0.0
           [exec] | | `-- once@1.3.3
           [exec] | +-- ee-first@1.1.1
           [exec] | +-- encodeurl@1.0.1
           [exec] | +-- engine.io@1.8.3
           [exec] | | +-- debug@2.3.3
           [exec] | | `-- ms@0.7.2
           [exec] | +-- engine.io-client@1.8.3
           [exec] | | +-- component-emitter@1.2.1
           [exec] | | +-- debug@2.3.3
           [exec] | | `-- ms@0.7.2
           [exec] | +-- engine.io-parser@1.3.2
           [exec] | +-- ent@2.2.0
           [exec] | +-- entities@1.0.0
           [exec] | +-- error-ex@1.3.1
           [exec] | +-- es5-ext@0.10.23
           [exec] | +-- es6-iterator@2.0.1
           [exec] | +-- es6-map@0.1.5
           [exec] | +-- es6-set@0.1.5
           [exec] | +-- es6-symbol@3.1.1
           [exec] | +-- es6-weak-map@2.0.2
           [exec] | +-- escape-html@1.0.3
           [exec] | +-- escape-string-regexp@1.0.5
           [exec] | +-- escodegen@1.8.1
           [exec] | | +-- esprima@2.7.3
           [exec] | | +-- estraverse@1.9.3
           [exec] | | `-- source-map@0.2.0
           [exec] | +-- escope@3.6.0
           [exec] | +-- esformatter@0.8.2
           [exec] | | +-- debug@0.7.4
           [exec] | | +-- espree@2.2.5
           [exec] | | +-- glob@5.0.15
           [exec] | | +-- minimist@1.2.0
           [exec] | | +-- strip-json-comments@0.1.3
           [exec] | | `-- supports-color@1.3.1
           [exec] | +-- eslint@3.19.0
           [exec] | +-- espree@3.4.3
           [exec] | +-- esprima@3.1.3
           [exec] | +-- esquery@1.0.0
           [exec] | +-- esrecurse@4.1.0
           [exec] | | `-- estraverse@4.1.1
           [exec] | +-- estraverse@4.2.0
           [exec] | +-- esutils@2.0.2
           [exec] | +-- event-emitter@0.3.5
           [exec] | +-- eventemitter3@1.2.0
           [exec] | +-- exit@0.1.2
           [exec] | +-- exit-hook@1.1.1
           [exec] | +-- expand-braces@0.1.2
           [exec] | | +-- braces@0.1.5
           [exec] | | +-- expand-range@0.1.1
           [exec] | | +-- is-number@0.1.1
           [exec] | | `-- repeat-string@0.2.2
           [exec] | +-- expand-brackets@0.1.5
           [exec] | +-- expand-range@1.8.2
           [exec] | +-- extend@3.0.1
           [exec] | +-- extend-shallow@2.0.1
           [exec] | +-- extglob@0.3.2
           [exec] | +-- extsprintf@1.0.2
           [exec] | +-- fancy-log@1.3.0
           [exec] | +-- fast-levenshtein@2.0.6
           [exec] | +-- figures@1.7.0
           [exec] | +-- file-entry-cache@2.0.0
           [exec] | +-- filename-regex@2.0.1
           [exec] | +-- fill-range@2.2.3
           [exec] | +-- finalhandler@1.0.3
           [exec] | | `-- debug@2.6.7
           [exec] | +-- find-up@1.1.2
           [exec] | +-- first-chunk-stream@1.0.0
           [exec] | +-- flat-cache@1.2.2
           [exec] | +-- for-in@1.0.2
           [exec] | +-- for-own@0.1.5
           [exec] | +-- forever-agent@0.6.1
           [exec] | +-- fork-stream@0.0.4
           [exec] | +-- form-data@2.1.4
           [exec] | +-- formatio@1.1.1
           [exec] | +-- fs-access@1.0.1
           [exec] | +-- fs.realpath@1.0.0
           [exec] | +-- fstream@1.0.11
           [exec] | +-- gauge@2.7.4
           [exec] | +-- generate-function@2.0.0
           [exec] | +-- generate-object-property@1.2.0
           [exec] | +-- get-caller-file@1.0.2
           [exec] | +-- get-stdin@4.0.1
           [exec] | +-- getpass@0.1.7
           [exec] | | `-- assert-plus@1.0.0
           [exec] | +-- glob@7.1.2
           [exec] | +-- glob-base@0.3.0
           [exec] | +-- glob-expand@0.1.0
           [exec] | | +-- glob@4.4.2
           [exec] | | +-- lodash@1.2.1
           [exec] | | `-- minimatch@2.0.10
           [exec] | +-- glob-parent@2.0.0
           [exec] | +-- globals@9.18.0
           [exec] | +-- globby@5.0.0
           [exec] | +-- glogg@1.0.0
           [exec] | +-- graceful-fs@4.1.11
           [exec] | +-- graceful-readlink@1.0.1
           [exec] | +-- growl@1.9.2
           [exec] | +-- gulp-babel-deps@2.0.1
           [exec] | +-- gulp-babel-globals@2.0.0
           [exec] | +-- gulp-concat@2.6.1
           [exec] | | +-- clone-stats@1.0.0
           [exec] | | +-- replace-ext@1.0.0
           [exec] | | `-- vinyl@2.0.2
           [exec] | +-- gulp-esformatter@5.0.0
           [exec] | +-- gulp-eslint@3.0.1
           [exec] | +-- gulp-if@2.0.2
           [exec] | +-- gulp-ignore@2.0.2
           [exec] | +-- gulp-jshint@2.0.4
           [exec] | +-- gulp-match@1.0.3
           [exec] | +-- gulp-mocha@2.2.0
           [exec] | | `-- mocha@2.5.3
           [exec] | |   +-- commander@2.3.0
           [exec] | |   +-- debug@2.2.0
           [exec] | |   +-- escape-string-regexp@1.0.2
           [exec] | |   +-- glob@3.2.11
           [exec] | |   +-- minimatch@0.3.0
           [exec] | |   +-- ms@0.7.1
           [exec] | |   `-- supports-color@1.2.0
           [exec] | +-- gulp-rename@1.2.2
           [exec] | +-- gulp-replace@0.5.4
           [exec] | +-- gulp-sass@3.1.0
           [exec] | +-- gulp-sourcemaps@1.6.0
           [exec] | | +-- strip-bom@2.0.0
           [exec] | | `-- vinyl@1.2.0
           [exec] | +-- gulp-uglify@1.5.4
           [exec] | +-- gulp-util@3.0.8
           [exec] | | +-- minimist@1.2.0
           [exec] | | `-- object-assign@3.0.0
           [exec] | +-- gulp-wrapper@1.0.0
           [exec] | | +-- isarray@0.0.1
           [exec] | | +-- readable-stream@1.0.34
           [exec] | | +-- string_decoder@0.10.31
           [exec] | | `-- through2@0.6.5
           [exec] | +-- gulplog@1.0.0
           [exec] | +-- handlebars@4.0.10
           [exec] | | +-- async@1.5.2
           [exec] | | `-- source-map@0.4.4
           [exec] | +-- har-schema@1.0.5
           [exec] | +-- har-validator@4.2.1
           [exec] | +-- has-ansi@2.0.0
           [exec] | +-- has-binary@0.1.7
           [exec] | | `-- isarray@0.0.1
           [exec] | +-- has-color@0.1.7
           [exec] | +-- has-cors@1.1.0
           [exec] | +-- has-flag@1.0.0
           [exec] | +-- has-gulplog@0.1.0
           [exec] | +-- has-unicode@2.0.1
           [exec] | +-- hawk@3.1.3
           [exec] | +-- hoek@2.16.3
           [exec] | +-- home-or-tmp@2.0.0
           [exec] | +-- hosted-git-info@2.4.2
           [exec] | +-- htmlparser2@3.8.3
           [exec] | | +-- isarray@0.0.1
           [exec] | | +-- readable-stream@1.1.14
           [exec] | | `-- string_decoder@0.10.31
           [exec] | +-- http-errors@1.6.1
           [exec] | +-- http-proxy@1.16.2
           [exec] | +-- http-signature@1.1.1
           [exec] | +-- https-proxy-agent@1.0.0
           [exec] | +-- iconv-lite@0.4.15
           [exec] | +-- iectrl@0.1.2
           [exec] | | +-- colors@0.6.2
           [exec] | | +-- commander@1.2.0
           [exec] | | `-- debug@0.7.4
           [exec] | +-- ignore@3.3.3
           [exec] | +-- imurmurhash@0.1.4
           [exec] | +-- in-publish@2.0.0
           [exec] | +-- indent-string@2.1.0
           [exec] | +-- indexof@0.0.1
           [exec] | +-- inflight@1.0.6
           [exec] | +-- inherits@2.0.3
           [exec] | +-- inquirer@0.12.0
           [exec] | +-- interpret@1.0.3
           [exec] | +-- invariant@2.2.2
           [exec] | +-- invert-kv@1.0.0
           [exec] | +-- irregular-plurals@1.2.0
           [exec] | +-- is-arrayish@0.2.1
           [exec] | +-- is-binary-path@1.0.1
           [exec] | +-- is-buffer@1.1.5
           [exec] | +-- is-builtin-module@1.0.0
           [exec] | +-- is-dotfile@1.0.3
           [exec] | +-- is-equal-shallow@0.1.3
           [exec] | +-- is-extendable@0.1.1
           [exec] | +-- is-extglob@1.0.0
           [exec] | +-- is-finite@1.0.2
           [exec] | +-- is-fullwidth-code-point@1.0.0
           [exec] | +-- is-glob@2.0.1
           [exec] | +-- is-my-json-valid@2.16.0
           [exec] | +-- is-number@2.1.0
           [exec] | +-- is-path-cwd@1.0.0
           [exec] | +-- is-path-in-cwd@1.0.0
           [exec] | +-- is-path-inside@1.0.0
           [exec] | +-- is-posix-bracket@0.1.1
           [exec] | +-- is-primitive@2.0.0
           [exec] | +-- is-property@1.0.2
           [exec] | +-- is-resolvable@1.0.0
           [exec] | +-- is-stream@1.1.0
           [exec] | +-- is-typedarray@1.0.0
           [exec] | +-- is-utf8@0.2.1
           [exec] | +-- is-valid-glob@0.3.0
           [exec] | +-- isarray@1.0.0
           [exec] | +-- isbinaryfile@3.0.2
           [exec] | +-- isexe@2.0.0
           [exec] | +-- isobject@2.1.0
           [exec] | +-- isparta@4.0.0
           [exec] | | `-- esprima@2.7.3
           [exec] | +-- isstream@0.1.2
           [exec] | +-- istanbul@0.4.5
           [exec] | | +-- abbrev@1.0.9
           [exec] | | +-- async@1.5.2
           [exec] | | +-- esprima@2.7.3
           [exec] | | +-- glob@5.0.15
           [exec] | | +-- resolve@1.1.7
           [exec] | | `-- supports-color@3.2.3
           [exec] | +-- istextorbinary@1.0.2
           [exec] | +-- jade@0.26.3
           [exec] | | +-- commander@0.6.1
           [exec] | | `-- mkdirp@0.3.0
           [exec] | +-- js-base64@2.1.9
           [exec] | +-- js-tokens@3.0.1
           [exec] | +-- js-yaml@3.8.4
           [exec] | +-- js2xmlparser@1.0.0
           [exec] | +-- jsdoc@3.4.3
           [exec] | | +-- acorn@3.3.0
           [exec] | | `-- espree@3.1.7
           [exec] | +-- jsesc@0.5.0
           [exec] | +-- jshint@2.9.4
           [exec] | | +-- lodash@3.7.0
           [exec] | | +-- shelljs@0.3.0
           [exec] | | `-- strip-json-comments@1.0.4
           [exec] | +-- jshint-stylish@2.2.1
           [exec] | +-- json-schema@0.2.3
           [exec] | +-- json-stable-stringify@1.0.1
           [exec] | +-- json-stringify-safe@5.0.1
           [exec] | +-- json3@3.3.2
           [exec] | +-- json5@0.5.1
           [exec] | +-- jsonify@0.0.0
           [exec] | +-- jsonpointer@4.0.1
           [exec] | +-- jsprim@1.4.0
           [exec] | | `-- assert-plus@1.0.0
           [exec] | +-- karma@1.7.0
           [exec] | | `-- lodash@3.10.1
           [exec] | +-- karma-babel-preprocessor@6.0.1
           [exec] | +-- karma-chai@0.1.0
           [exec] | +-- karma-chrome-launcher@0.2.3
           [exec] | +-- karma-commonjs@1.0.0
           [exec] | +-- karma-coverage@0.5.5
           [exec] | | `-- dateformat@1.0.12
           [exec] | +-- karma-firefox-launcher@0.1.7
           [exec] | +-- karma-ievms@0.1.0  (git+https://github.com/niksy/karma-ievms.git#edd23d7fc6539225f8ba31abcc5efe2a53807058)
           [exec] | +-- karma-mocha@0.2.2
           [exec] | +-- karma-safari-launcher@0.1.1
           [exec] | +-- karma-sauce-launcher@0.3.1
           [exec] | | `-- q@1.5.0
           [exec] | +-- karma-sinon@1.0.5
           [exec] | +-- karma-source-map-support@1.2.0
           [exec] | +-- keypress@0.1.0
           [exec] | +-- kind-of@3.2.2
           [exec] | +-- klaw@1.3.1
           [exec] | +-- lazy-cache@1.0.4
           [exec] | +-- lazystream@0.1.0
           [exec] | | +-- isarray@0.0.1
           [exec] | | +-- readable-stream@1.0.34
           [exec] | | `-- string_decoder@0.10.31
           [exec] | +-- lcid@1.0.0
           [exec] | +-- levn@0.3.0
           [exec] | +-- load-json-file@1.1.0
           [exec] | | `-- strip-bom@2.0.0
           [exec] | +-- lodash@4.17.4
           [exec] | +-- lodash._basecopy@3.0.1
           [exec] | +-- lodash._basetostring@3.0.1
           [exec] | +-- lodash._basevalues@3.0.0
           [exec] | +-- lodash._getnative@3.9.1
           [exec] | +-- lodash._isiterateecall@3.0.9
           [exec] | +-- lodash._reescape@3.0.0
           [exec] | +-- lodash._reevaluate@3.0.0
           [exec] | +-- lodash._reinterpolate@3.0.0
           [exec] | +-- lodash._root@3.0.1
           [exec] | +-- lodash.assign@4.2.0
           [exec] | +-- lodash.clonedeep@4.5.0
           [exec] | +-- lodash.escape@3.2.0
           [exec] | +-- lodash.isarguments@3.1.0
           [exec] | +-- lodash.isarray@3.0.4
           [exec] | +-- lodash.isequal@4.5.0
           [exec] | +-- lodash.isobject@3.0.2
           [exec] | +-- lodash.keys@3.1.2
           [exec] | +-- lodash.merge@4.6.0
           [exec] | +-- lodash.mergewith@4.6.0
           [exec] | +-- lodash.restparam@3.6.1
           [exec] | +-- lodash.template@3.6.2
           [exec] | +-- lodash.templatesettings@3.1.1
           [exec] | +-- log-symbols@1.0.2
           [exec] | +-- log4js@0.6.38
           [exec] | | +-- isarray@0.0.1
           [exec] | | +-- readable-stream@1.0.34
           [exec] | | `-- string_decoder@0.10.31
           [exec] | +-- lolex@1.3.2
           [exec] | +-- longest@1.0.1
           [exec] | +-- loose-envify@1.3.1
           [exec] | +-- loud-rejection@1.6.0
           [exec] | +-- lru-cache@2.7.3
           [exec] | +-- map-obj@1.0.1
           [exec] | +-- marked@0.3.6
           [exec] | +-- media-typer@0.3.0
           [exec] | +-- meow@3.7.0
           [exec] | | `-- minimist@1.2.0
           [exec] | +-- merge@1.2.0
           [exec] | +-- merge-stream@1.0.1
           [exec] | +-- metal-jquery-adapter@1.0.0
           [exec] | +-- metal-karma-config@2.3.1
           [exec] | | `-- sinon@1.17.7
           [exec] | +-- metal-tools-build-amd@3.0.3
           [exec] | | +-- glob@5.0.15
           [exec] | | +-- glob-parent@3.1.0
           [exec] | | +-- glob-stream@5.3.5
           [exec] | | | +-- readable-stream@1.0.34
           [exec] | | | `-- through2@0.6.5
           [exec] | | +-- is-extglob@2.1.1
           [exec] | | +-- is-glob@3.1.0
           [exec] | | +-- isarray@0.0.1
           [exec] | | +-- lazystream@1.0.0
           [exec] | | +-- ordered-read-streams@0.3.0
           [exec] | | +-- string_decoder@0.10.31
           [exec] | | +-- strip-bom@2.0.0
           [exec] | | +-- unique-stream@2.2.1
           [exec] | | +-- vinyl@1.2.0
           [exec] | | `-- vinyl-fs@2.4.4
           [exec] | +-- metal-tools-build-globals@2.0.2
           [exec] | | +-- glob@5.0.15
           [exec] | | +-- glob-parent@3.1.0
           [exec] | | +-- glob-stream@5.3.5
           [exec] | | | +-- readable-stream@1.0.34
           [exec] | | | `-- through2@0.6.5
           [exec] | | +-- is-extglob@2.1.1
           [exec] | | +-- is-glob@3.1.0
           [exec] | | +-- isarray@0.0.1
           [exec] | | +-- lazystream@1.0.0
           [exec] | | +-- ordered-read-streams@0.3.0
           [exec] | | +-- string_decoder@0.10.31
           [exec] | | +-- strip-bom@2.0.0
           [exec] | | +-- unique-stream@2.2.1
           [exec] | | +-- vinyl@1.2.0
           [exec] | | `-- vinyl-fs@2.4.4
           [exec] | +-- metal-tools-build-jquery@2.0.2
           [exec] | | +-- glob@5.0.15
           [exec] | | +-- glob-parent@3.1.0
           [exec] | | +-- glob-stream@5.3.5
           [exec] | | | +-- readable-stream@1.0.34
           [exec] | | | `-- through2@0.6.5
           [exec] | | +-- is-extglob@2.1.1
           [exec] | | +-- is-glob@3.1.0
           [exec] | | +-- isarray@0.0.1
           [exec] | | +-- lazystream@1.0.0
           [exec] | | +-- ordered-read-streams@0.3.0
           [exec] | | +-- string_decoder@0.10.31
           [exec] | | +-- strip-bom@2.0.0
           [exec] | | +-- unique-stream@2.2.1
           [exec] | | +-- vinyl@1.2.0
           [exec] | | `-- vinyl-fs@2.4.4
           [exec] | +-- metal-tools-soy@4.1.2
           [exec] | | +-- glob@5.0.15
           [exec] | | +-- glob-parent@3.1.0
           [exec] | | +-- glob-stream@5.3.5
           [exec] | | | +-- readable-stream@1.0.34
           [exec] | | | `-- through2@0.6.5
           [exec] | | +-- is-extglob@2.1.1
           [exec] | | +-- is-glob@3.1.0
           [exec] | | +-- isarray@0.0.1
           [exec] | | +-- lazystream@1.0.0
           [exec] | | +-- ordered-read-streams@0.3.0
           [exec] | | +-- string_decoder@0.10.31
           [exec] | | +-- strip-bom@2.0.0
           [exec] | | +-- unique-stream@2.2.1
           [exec] | | +-- vinyl@1.2.0
           [exec] | | `-- vinyl-fs@2.4.4
           [exec] | +-- micromatch@2.3.11
           [exec] | +-- mime@1.3.6
           [exec] | +-- mime-db@1.27.0
           [exec] | +-- mime-types@2.1.15
           [exec] | +-- minimatch@3.0.4
           [exec] | +-- minimist@0.0.8
           [exec] | +-- mkdirp@0.5.1
           [exec] | +-- moment@2.0.0
           [exec] | +-- ms@2.0.0
           [exec] | +-- multipipe@0.1.2
           [exec] | +-- mute-stream@0.0.5
           [exec] | +-- nan@2.6.2
           [exec] | +-- natural-compare@1.4.0
           [exec] | +-- negotiator@0.6.1
           [exec] | +-- node-gyp@3.6.2
           [exec] | | `-- semver@5.3.0
           [exec] | +-- node-int64@0.3.3
           [exec] | +-- node-sass@4.5.3
           [exec] | | +-- gaze@1.1.2
           [exec] | | `-- globule@1.2.0
           [exec] | +-- nomnomnomnom@2.0.1
           [exec] | | +-- ansi-styles@1.0.0
           [exec] | | +-- chalk@0.4.0
           [exec] | | +-- strip-ansi@0.1.1
           [exec] | | `-- underscore@1.6.0
           [exec] | +-- nopt@3.0.6
           [exec] | +-- normalize-package-data@2.3.8
           [exec] | +-- normalize-path@2.1.1
           [exec] | +-- npm-path@1.1.0
           [exec] | +-- npm-run@2.0.0
           [exec] | | `-- minimist@1.2.0
           [exec] | +-- npm-which@2.0.0
           [exec] | +-- npmlog@4.1.0
           [exec] | +-- null-check@1.0.0
           [exec] | +-- number-is-nan@1.0.1
           [exec] | +-- oauth-sign@0.8.2
           [exec] | +-- object-assign@4.1.1
           [exec] | +-- object-component@0.0.3
           [exec] | +-- object.omit@2.0.1
           [exec] | +-- on-finished@2.3.0
           [exec] | +-- once@1.4.0
           [exec] | +-- onetime@1.1.0
           [exec] | +-- open@0.0.5
           [exec] | +-- optimist@0.6.1
           [exec] | | `-- wordwrap@0.0.3
           [exec] | +-- optionator@0.8.2
           [exec] | +-- options@0.0.6
           [exec] | +-- os-homedir@1.0.2
           [exec] | +-- os-locale@1.4.0
           [exec] | +-- os-shim@0.1.3
           [exec] | +-- os-tmpdir@1.0.2
           [exec] | +-- osenv@0.1.4
           [exec] | +-- parse-glob@3.0.4
           [exec] | +-- parse-json@2.2.0
           [exec] | +-- parsejson@0.0.3
           [exec] | +-- parseqs@0.0.5
           [exec] | +-- parseuri@0.0.5
           [exec] | +-- parseurl@1.3.1
           [exec] | +-- parsimmon@1.4.0
           [exec] | +-- path-dirname@1.0.2
           [exec] | +-- path-exists@2.1.0
           [exec] | +-- path-is-absolute@1.0.1
           [exec] | +-- path-is-inside@1.0.2
           [exec] | +-- path-parse@1.0.5
           [exec] | +-- path-type@1.1.0
           [exec] | +-- performance-now@0.2.0
           [exec] | +-- pify@2.3.0
           [exec] | +-- pinkie@2.0.4
           [exec] | +-- pinkie-promise@2.0.1
           [exec] | +-- plur@2.1.2
           [exec] | +-- pluralize@1.2.1
           [exec] | +-- prelude-ls@1.1.2
           [exec] | +-- preserve@0.2.0
           [exec] | +-- private@0.1.7
           [exec] | +-- process-nextick-args@1.0.7
           [exec] | +-- progress@1.1.8
           [exec] | +-- protochain@1.0.5
           [exec] | +-- pseudomap@1.0.2
           [exec] | +-- punycode@1.4.1
           [exec] | +-- q@0.9.7
           [exec] | +-- qjobs@1.1.5
           [exec] | +-- qs@6.4.0
           [exec] | +-- randomatic@1.1.7
           [exec] | | +-- is-number@3.0.0
           [exec] | | | `-- kind-of@3.2.2
           [exec] | | `-- kind-of@4.0.0
           [exec] | +-- range-parser@1.2.0
           [exec] | +-- raw-body@2.2.0
           [exec] | +-- rcfinder@0.1.9
           [exec] | +-- rcloader@0.2.2
           [exec] | +-- read-pkg@1.1.0
           [exec] | +-- read-pkg-up@1.0.1
           [exec] | +-- readable-stream@2.2.11
           [exec] | +-- readdirp@2.1.0
           [exec] | +-- readline2@1.0.1
           [exec] | +-- rechoir@0.6.2
           [exec] | +-- redent@1.0.0
           [exec] | +-- regenerate@1.3.2
           [exec] | +-- regenerator-runtime@0.10.5
           [exec] | +-- regenerator-transform@0.9.11
           [exec] | +-- regex-cache@0.4.3
           [exec] | +-- regexpu-core@2.0.0
           [exec] | +-- regjsgen@0.2.0
           [exec] | +-- regjsparser@0.1.5
           [exec] | +-- remove-trailing-separator@1.0.2
           [exec] | +-- repeat-element@1.1.2
           [exec] | +-- repeat-string@1.6.1
           [exec] | +-- repeating@2.0.1
           [exec] | +-- replace-ext@0.0.1
           [exec] | +-- replacestream@4.0.2
           [exec] | +-- request@2.81.0
           [exec] | +-- require-directory@2.1.1
           [exec] | +-- require-main-filename@1.0.1
           [exec] | +-- require-uncached@1.0.3
           [exec] | +-- requires-port@1.0.0
           [exec] | +-- requizzle@0.2.1
           [exec] | | `-- underscore@1.6.0
           [exec] | +-- resolve@1.3.3
           [exec] | +-- resolve-from@1.0.1
           [exec] | +-- restore-cursor@1.0.1
           [exec] | +-- right-align@0.1.3
           [exec] | +-- rimraf@2.6.1
           [exec] | +-- rocambole@0.7.0
           [exec] | | `-- esprima@2.7.3
           [exec] | +-- rocambole-indent@2.0.4
           [exec] | | `-- mout@0.11.1
           [exec] | +-- rocambole-linebreak@1.0.2
           [exec] | +-- rocambole-node@1.0.0
           [exec] | +-- rocambole-token@1.2.1
           [exec] | +-- rocambole-whitespace@1.0.0
           [exec] | +-- run-async@0.1.0
           [exec] | +-- run-sequence@1.2.2
           [exec] | +-- rx-lite@3.1.2
           [exec] | +-- safe-buffer@5.0.1
           [exec] | +-- samsam@1.1.2
           [exec] | +-- sass-graph@2.2.4
           [exec] | +-- sauce-connect-launcher@0.13.0
           [exec] | | +-- async@1.4.0
           [exec] | | +-- glob@5.0.15
           [exec] | | +-- lodash@3.10.1
           [exec] | | `-- rimraf@2.4.3
           [exec] | +-- saucelabs@1.4.0
           [exec] | +-- scss-tokenizer@0.2.3
           [exec] | | `-- source-map@0.4.4
           [exec] | +-- semver@4.3.6
           [exec] | +-- serializerr@1.0.3
           [exec] | +-- set-blocking@2.0.0
           [exec] | +-- set-immediate-shim@1.0.1
           [exec] | +-- setprototypeof@1.0.3
           [exec] | +-- shelljs@0.7.8
           [exec] | +-- sigmund@1.0.1
           [exec] | +-- signal-exit@3.0.2
           [exec] | +-- slash@1.0.0
           [exec] | +-- slice-ansi@0.0.4
           [exec] | +-- sntp@1.0.9
           [exec] | +-- socket.io@1.7.3
           [exec] | | +-- debug@2.3.3
           [exec] | | +-- ms@0.7.2
           [exec] | | `-- object-assign@4.1.0
           [exec] | +-- socket.io-adapter@0.5.0
           [exec] | | +-- debug@2.3.3
           [exec] | | `-- ms@0.7.2
           [exec] | +-- socket.io-client@1.7.3
           [exec] | | +-- component-emitter@1.2.1
           [exec] | | +-- debug@2.3.3
           [exec] | | `-- ms@0.7.2
           [exec] | +-- socket.io-parser@2.3.1
           [exec] | | +-- debug@2.2.0
           [exec] | | +-- isarray@0.0.1
           [exec] | | `-- ms@0.7.1
           [exec] | +-- source-map@0.5.6
           [exec] | +-- source-map-support@0.4.15
           [exec] | +-- soyparser@1.0.2
           [exec] | +-- sparkles@1.0.0
           [exec] | +-- spawn-sync@1.0.15
           [exec] | +-- spdx-correct@1.0.2
           [exec] | +-- spdx-expression-parse@1.0.4
           [exec] | +-- spdx-license-ids@1.2.2
           [exec] | +-- sprintf-js@1.0.3
           [exec] | +-- sshpk@1.13.1
           [exec] | | `-- assert-plus@1.0.0
           [exec] | +-- statuses@1.3.1
           [exec] | +-- stdout-stream@1.4.0
           [exec] | +-- stream-combiner@0.2.2
           [exec] | +-- stream-consume@0.1.0
           [exec] | +-- stream-shift@1.0.0
           [exec] | +-- string-length@1.0.1
           [exec] | +-- string-width@1.0.2
           [exec] | +-- string_decoder@1.0.2
           [exec] | +-- stringstream@0.0.5
           [exec] | +-- strip-ansi@3.0.1
           [exec] | +-- strip-bom@3.0.0
           [exec] | +-- strip-bom-stream@1.0.0
           [exec] | | `-- strip-bom@2.0.0
           [exec] | +-- strip-indent@1.0.1
           [exec] | +-- strip-json-comments@2.0.1
           [exec] | +-- supports-color@2.0.0
           [exec] | +-- sync-exec@0.5.0
           [exec] | +-- table@3.8.3
           [exec] | | +-- is-fullwidth-code-point@2.0.0
           [exec] | | `-- string-width@2.0.0
           [exec] | +-- taffydb@2.6.2
           [exec] | +-- tar@2.2.1
           [exec] | +-- tar-stream@1.1.5
           [exec] | | +-- end-of-stream@1.4.0
           [exec] | | +-- isarray@0.0.1
           [exec] | | +-- readable-stream@1.0.34
           [exec] | | `-- string_decoder@0.10.31
           [exec] | +-- temp@0.8.3
           [exec] | | `-- rimraf@2.2.8
           [exec] | +-- ternary-stream@2.0.1
           [exec] | +-- text-table@0.2.0
           [exec] | +-- textextensions@1.0.2
           [exec] | +-- through@2.3.8
           [exec] | +-- through2-filter@2.0.0
           [exec] | +-- time-stamp@1.1.0
           [exec] | +-- tmp@0.0.31
           [exec] | +-- to-absolute-glob@0.1.1
           [exec] | +-- to-array@0.1.4
           [exec] | +-- to-fast-properties@1.0.3
           [exec] | +-- to-iso-string@0.0.2
           [exec] | +-- tough-cookie@2.3.2
           [exec] | +-- trim-newlines@1.0.0
           [exec] | +-- trim-right@1.0.1
           [exec] | +-- tryit@1.0.3
           [exec] | +-- tunnel-agent@0.6.0
           [exec] | +-- type-check@0.3.2
           [exec] | +-- type-detect@0.1.1
           [exec] | +-- type-is@1.6.15
           [exec] | +-- typedarray@0.0.6
           [exec] | +-- uglify-js@2.6.4
           [exec] | | +-- camelcase@1.2.1
           [exec] | | +-- cliui@2.1.0
           [exec] | | +-- wordwrap@0.0.2
           [exec] | | `-- yargs@3.10.0
           [exec] | +-- uglify-save-license@0.4.1
           [exec] | +-- uglify-to-browserify@1.0.2
           [exec] | +-- ultron@1.0.2
           [exec] | +-- underscore@1.8.3
           [exec] | +-- underscore-contrib@0.3.0
           [exec] | | `-- underscore@1.6.0
           [exec] | +-- underscore.string@3.0.3
           [exec] | +-- unpipe@1.0.0
           [exec] | +-- user-home@2.0.0
           [exec] | +-- useragent@2.1.13
           [exec] | | `-- lru-cache@2.2.4
           [exec] | +-- util@0.10.3
           [exec] | | `-- inherits@2.0.1
           [exec] | +-- util-deprecate@1.0.2
           [exec] | +-- utils-merge@1.0.0
           [exec] | +-- uuid@3.0.1
           [exec] | +-- vali-date@1.0.0
           [exec] | +-- validate-npm-package-license@3.0.1
           [exec] | +-- vargs@0.1.0
           [exec] | +-- verror@1.3.6
           [exec] | +-- vinyl@0.5.3
           [exec] | +-- vinyl-sourcemaps-apply@0.2.1
           [exec] | +-- void-elements@2.0.1
           [exec] | +-- wd@0.3.12
           [exec] | | +-- asn1@0.1.11
           [exec] | | +-- assert-plus@0.1.5
           [exec] | | +-- async@1.0.0
           [exec] | | +-- aws-sign2@0.5.0
           [exec] | | +-- bluebird@2.11.0
           [exec] | | +-- caseless@0.9.0
           [exec] | | +-- combined-stream@0.0.7
           [exec] | | +-- delayed-stream@0.0.5
           [exec] | | +-- form-data@0.2.0
           [exec] | | | `-- async@0.9.2
           [exec] | | +-- har-validator@1.8.0
           [exec] | | +-- hawk@2.3.1
           [exec] | | +-- http-signature@0.10.1
           [exec] | | +-- lodash@3.9.3
           [exec] | | +-- mime-db@1.12.0
           [exec] | | +-- mime-types@2.0.14
           [exec] | | +-- oauth-sign@0.6.0
           [exec] | | +-- q@1.4.1
           [exec] | | +-- qs@2.4.2
           [exec] | | +-- request@2.55.0
           [exec] | | | `-- node-uuid@1.4.8
           [exec] | | `-- tunnel-agent@0.4.3
           [exec] | +-- which@1.2.14
           [exec] | +-- which-module@1.0.0
           [exec] | +-- wide-align@1.1.2
           [exec] | +-- window-size@0.1.0
           [exec] | +-- wordwrap@1.0.0
           [exec] | +-- wrap-ansi@2.1.0
           [exec] | +-- wrappy@1.0.2
           [exec] | +-- write@0.2.1
           [exec] | +-- ws@1.1.2
           [exec] | +-- wtf-8@1.0.0
           [exec] | +-- xmlhttprequest-ssl@1.5.3
           [exec] | +-- xtend@4.0.1
           [exec] | +-- y18n@3.2.1
           [exec] | +-- yallist@2.1.2
           [exec] | +-- yargs@7.1.0
           [exec] | | `-- camelcase@3.0.0
           [exec] | +-- yargs-parser@5.0.0
           [exec] | | `-- camelcase@3.0.0
           [exec] | +-- yeast@0.1.2
           [exec] | `-- zip-stream@0.5.2
           [exec] |   +-- isarray@0.0.1
           [exec] |   +-- lodash@3.2.0
           [exec] |   +-- readable-stream@1.0.34
           [exec] |   `-- string_decoder@0.10.31
           [exec] +-- gulp-util@3.0.8
           [exec] +-- gulplog@1.0.0
           [exec] +-- handlebars@4.0.10
           [exec] | `-- source-map@0.4.4
           [exec] +-- has-ansi@2.0.0
           [exec] +-- has-binary@0.1.7
           [exec] +-- has-color@0.1.7
           [exec] +-- has-cors@1.1.0
           [exec] +-- has-flag@1.0.0
           [exec] +-- has-gulplog@0.1.0
           [exec] +-- home-or-tmp@2.0.0
           [exec] +-- homedir-polyfill@1.0.1
           [exec] +-- hosted-git-info@2.5.0
           [exec] +-- http-errors@1.6.1
           [exec] +-- http-proxy@1.16.2
           [exec] +-- iconv-lite@0.4.15
           [exec] +-- ignore@3.3.3
           [exec] +-- imurmurhash@0.1.4
           [exec] +-- indent-string@2.1.0
           [exec] +-- indexof@0.0.1
           [exec] +-- inflight@1.0.6
           [exec] +-- inherits@2.0.3
           [exec] +-- ini@1.3.4
           [exec] +-- inquirer@0.12.0
           [exec] | `-- lodash@4.17.4
           [exec] +-- interpret@1.0.3
           [exec] +-- invariant@2.2.2
           [exec] +-- is-absolute@0.2.6
           [exec] +-- is-arrayish@0.2.1
           [exec] +-- is-binary-path@1.0.1
           [exec] +-- is-buffer@1.1.5
           [exec] +-- is-builtin-module@1.0.0
           [exec] +-- is-dotfile@1.0.3
           [exec] +-- is-equal-shallow@0.1.3
           [exec] +-- is-extendable@0.1.1
           [exec] +-- is-extglob@1.0.0
           [exec] +-- is-finite@1.0.2
           [exec] +-- is-fullwidth-code-point@1.0.0
           [exec] +-- is-glob@2.0.1
           [exec] +-- is-my-json-valid@2.16.0
           [exec] +-- is-npm@1.0.0
           [exec] +-- is-number@2.1.0
           [exec] +-- is-obj@1.0.1
           [exec] +-- is-path-cwd@1.0.0
           [exec] +-- is-path-in-cwd@1.0.0
           [exec] +-- is-path-inside@1.0.0
           [exec] +-- is-plain-object@2.0.3
           [exec] | `-- isobject@3.0.0
           [exec] +-- is-posix-bracket@0.1.1
           [exec] +-- is-primitive@2.0.0
           [exec] +-- is-property@1.0.2
           [exec] +-- is-redirect@1.0.0
           [exec] +-- is-relative@0.2.1
           [exec] +-- is-resolvable@1.0.0
           [exec] +-- is-retry-allowed@1.1.0
           [exec] +-- is-stream@1.1.0
           [exec] +-- is-unc-path@0.1.2
           [exec] +-- is-utf8@0.2.1
           [exec] +-- is-windows@0.2.0
           [exec] +-- isarray@0.0.1
           [exec] +-- isbinaryfile@3.0.2
           [exec] +-- isexe@2.0.0
           [exec] +-- isobject@2.1.0
           [exec] | `-- isarray@1.0.0
           [exec] +-- isparta@4.0.0
           [exec] | +-- esprima@2.7.3
           [exec] | `-- object-assign@4.1.1
           [exec] +-- istanbul@0.4.5
           [exec] | +-- esprima@2.7.3
           [exec] | +-- glob@5.0.15
           [exec] | +-- resolve@1.1.7
           [exec] | `-- supports-color@3.2.3
           [exec] +-- jade@0.26.3
           [exec] | +-- commander@0.6.1
           [exec] | `-- mkdirp@0.3.0
           [exec] +-- js-base64@2.1.9
           [exec] +-- js-beautify@1.6.14
           [exec] +-- js-tokens@3.0.2
           [exec] +-- js-yaml@3.8.4
           [exec] +-- jsbn@0.1.1
           [exec] +-- jsesc@0.5.0
           [exec] +-- json-stable-stringify@1.0.1
           [exec] +-- json3@3.3.2
           [exec] +-- json5@0.5.1
           [exec] +-- jsonfile@2.4.0
           [exec] | `-- graceful-fs@4.1.11
           [exec] +-- jsonify@0.0.0
           [exec] +-- jsonpointer@4.0.1
           [exec] +-- jsstana@0.1.6
           [exec] | +-- esprima@2.7.3
           [exec] | `-- underscore@1.8.3
           [exec] +-- karma@1.7.0
           [exec] | +-- glob@7.1.2
           [exec] | +-- graceful-fs@4.1.11
           [exec] | +-- lodash@3.10.1
           [exec] | `-- minimatch@3.0.4
           [exec] +-- karma-babel-preprocessor@6.0.1
           [exec] +-- karma-chai@0.1.0
           [exec] +-- karma-chrome-launcher@0.2.3
           [exec] +-- karma-commonjs@0.0.13
           [exec] +-- karma-coverage@0.5.5
           [exec] | +-- dateformat@1.0.12
           [exec] | `-- minimatch@3.0.4
           [exec] +-- karma-firefox-launcher@0.1.7
           [exec] +-- karma-html2js-preprocessor@1.1.0
           [exec] +-- karma-junit-reporter@0.2.2
           [exec] +-- karma-mocha@0.2.2
           [exec] +-- karma-sinon@1.0.5
           [exec] +-- karma-source-map-support@1.0.0
           [exec] | +-- source-map@0.1.32
           [exec] | `-- source-map-support@0.2.10
           [exec] +-- kind-of@3.2.2
           [exec] +-- klaw@1.3.1
           [exec] | `-- graceful-fs@4.1.11
           [exec] +-- latest-version@2.0.0
           [exec] +-- lazy-cache@1.0.4
           [exec] +-- levenshtein@1.0.5
           [exec] +-- levn@0.3.0
           [exec] +-- liferay-amd-loader@2.1.0
           [exec] +-- liferay-karma-config@0.0.4
           [exec] +-- liferay-module-config-generator@1.3.0
           [exec] | +-- fs-extra@0.26.7
           [exec] | +-- graceful-fs@4.1.11
           [exec] | `-- minimatch@3.0.4
           [exec] +-- liftoff@2.3.0
           [exec] +-- load-json-file@1.1.0
           [exec] | +-- graceful-fs@4.1.11
           [exec] | `-- strip-bom@2.0.0
           [exec] +-- lodash@1.0.2
           [exec] +-- lodash._basecopy@3.0.1
           [exec] +-- lodash._basetostring@3.0.1
           [exec] +-- lodash._basevalues@3.0.0
           [exec] +-- lodash._getnative@3.9.1
           [exec] +-- lodash._isiterateecall@3.0.9
           [exec] +-- lodash._reescape@3.0.0
           [exec] +-- lodash._reevaluate@3.0.0
           [exec] +-- lodash._reinterpolate@3.0.0
           [exec] +-- lodash._root@3.0.1
           [exec] +-- lodash.escape@3.2.0
           [exec] +-- lodash.isarguments@3.1.0
           [exec] +-- lodash.isarray@3.0.4
           [exec] +-- lodash.isplainobject@4.0.6
           [exec] +-- lodash.isstring@4.0.1
           [exec] +-- lodash.keys@3.1.2
           [exec] +-- lodash.mapvalues@4.6.0
           [exec] +-- lodash.restparam@3.6.1
           [exec] +-- lodash.template@3.6.2
           [exec] +-- lodash.templatesettings@3.1.1
           [exec] +-- log4js@0.6.38
           [exec] | `-- readable-stream@1.0.34
           [exec] +-- lolex@1.3.2
           [exec] +-- longest@1.0.1
           [exec] +-- loose-envify@1.3.1
           [exec] +-- loud-rejection@1.6.0
           [exec] +-- lowercase-keys@1.0.0
           [exec] +-- lru-cache@2.7.3
           [exec] +-- map-cache@0.2.2
           [exec] +-- map-obj@1.0.1
           [exec] +-- media-typer@0.3.0
           [exec] +-- meow@3.7.0
           [exec] | `-- object-assign@4.1.1
           [exec] +-- metal@2.13.2
           [exec] +-- metal-cli@4.3.3
           [exec] | +-- ansi-regex@2.1.1
           [exec] | +-- ansi-styles@2.2.1
           [exec] | +-- anymatch@1.3.0
           [exec] | +-- arr-diff@2.0.0
           [exec] | +-- arr-flatten@1.0.3
           [exec] | +-- array-differ@1.0.0
           [exec] | +-- array-each@1.0.1
           [exec] | +-- array-slice@1.0.0
           [exec] | +-- array-uniq@1.0.3
           [exec] | +-- array-unique@0.2.1
           [exec] | +-- arrify@1.0.1
           [exec] | +-- async-done@1.2.2
           [exec] | +-- async-each@1.0.1
           [exec] | +-- babel-code-frame@6.22.0
           [exec] | +-- babel-core@6.25.0
           [exec] | +-- babel-deps@2.1.0
           [exec] | +-- babel-generator@6.25.0
           [exec] | | `-- jsesc@1.3.0
           [exec] | +-- babel-globals@2.0.1
           [exec] | +-- babel-helper-call-delegate@6.24.1
           [exec] | +-- babel-helper-define-map@6.24.1
           [exec] | +-- babel-helper-function-name@6.24.1
           [exec] | +-- babel-helper-get-function-arity@6.24.1
           [exec] | +-- babel-helper-hoist-variables@6.24.1
           [exec] | +-- babel-helper-optimise-call-expression@6.24.1
           [exec] | +-- babel-helper-regex@6.24.1
           [exec] | +-- babel-helper-replace-supers@6.24.1
           [exec] | +-- babel-helpers@6.24.1
           [exec] | +-- babel-messages@6.23.0
           [exec] | +-- babel-plugin-check-es2015-constants@6.22.0
           [exec] | +-- babel-plugin-external-helpers-2@6.3.13
           [exec] | | +-- babel-runtime@5.8.38
           [exec] | | `-- core-js@1.2.7
           [exec] | +-- babel-plugin-globals@2.0.1
           [exec] | +-- babel-plugin-transform-es2015-arrow-functions@6.22.0
           [exec] | +-- babel-plugin-transform-es2015-block-scoped-functions@6.22.0
           [exec] | +-- babel-plugin-transform-es2015-block-scoping@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-classes@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-computed-properties@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-destructuring@6.23.0
           [exec] | +-- babel-plugin-transform-es2015-duplicate-keys@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-for-of@6.23.0
           [exec] | +-- babel-plugin-transform-es2015-function-name@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-literals@6.22.0
           [exec] | +-- babel-plugin-transform-es2015-modules-amd@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-modules-commonjs@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-modules-systemjs@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-modules-umd@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-object-super@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-parameters@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-shorthand-properties@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-spread@6.22.0
           [exec] | +-- babel-plugin-transform-es2015-sticky-regex@6.24.1
           [exec] | +-- babel-plugin-transform-es2015-template-literals@6.22.0
           [exec] | +-- babel-plugin-transform-es2015-typeof-symbol@6.23.0
           [exec] | +-- babel-plugin-transform-es2015-unicode-regex@6.24.1
           [exec] | +-- babel-plugin-transform-node-env-inline@0.1.1
           [exec] | +-- babel-plugin-transform-regenerator@6.24.1
           [exec] | +-- babel-plugin-transform-strict-mode@6.24.1
           [exec] | +-- babel-preset-es2015@6.24.1
           [exec] | +-- babel-preset-metal-resolve-source@1.0.2
           [exec] | +-- babel-register@6.24.1
           [exec] | +-- babel-runtime@6.23.0
           [exec] | +-- babel-template@6.25.0
           [exec] | +-- babel-traverse@6.25.0
           [exec] | +-- babel-types@6.25.0
           [exec] | +-- babylon@6.17.4
           [exec] | +-- balanced-match@1.0.0
           [exec] | +-- beeper@1.1.1
           [exec] | +-- binary-extensions@1.8.0
           [exec] | +-- binaryextensions@1.0.1
           [exec] | +-- bower@1.8.0
           [exec] | +-- brace-expansion@1.1.8
           [exec] | +-- braces@1.8.5
           [exec] | +-- builtin-modules@1.1.1
           [exec] | +-- camelcase@4.1.0
           [exec] | +-- chalk@1.1.3
           [exec] | +-- chokidar@1.7.0
           [exec] | +-- cliui@3.2.0
           [exec] | | `-- string-width@1.0.2
           [exec] | +-- clone@1.0.2
           [exec] | +-- clone-stats@0.0.1
           [exec] | +-- code-point-at@1.1.0
           [exec] | +-- concat-map@0.0.1
           [exec] | +-- concat-with-sourcemaps@1.0.4
           [exec] | +-- convert-source-map@1.5.0
           [exec] | +-- core-js@2.4.1
           [exec] | +-- core-util-is@1.0.2
           [exec] | +-- cross-spawn@4.0.2
           [exec] | +-- dateformat@2.0.0
           [exec] | +-- debug@2.6.8
           [exec] | +-- decamelize@1.2.0
           [exec] | +-- detect-indent@4.0.0
           [exec] | +-- duplexer@0.1.1
           [exec] | +-- duplexer2@0.0.2
           [exec] | | +-- isarray@0.0.1
           [exec] | | +-- readable-stream@1.1.14
           [exec] | | `-- string_decoder@0.10.31
           [exec] | +-- duplexify@3.5.0
           [exec] | | +-- end-of-stream@1.0.0
           [exec] | | `-- once@1.3.3
           [exec] | +-- end-of-stream@1.4.0
           [exec] | +-- error-ex@1.3.1
           [exec] | +-- escape-string-regexp@1.0.5
           [exec] | +-- esutils@2.0.2
           [exec] | +-- execa@0.5.1
           [exec] | +-- expand-brackets@0.1.5
           [exec] | +-- expand-range@1.8.2
           [exec] | +-- extend@3.0.1
           [exec] | +-- extend-shallow@2.0.1
           [exec] | +-- extglob@0.3.2
           [exec] | +-- fancy-log@1.3.0
           [exec] | +-- filename-regex@2.0.1
           [exec] | +-- fill-range@2.2.3
           [exec] | +-- find-up@2.1.0
           [exec] | +-- first-chunk-stream@1.0.0
           [exec] | +-- for-in@1.0.2
           [exec] | +-- for-own@0.1.5
           [exec] | +-- fork-stream@0.0.4
           [exec] | +-- get-caller-file@1.0.2
           [exec] | +-- get-stream@2.3.1
           [exec] | | `-- object-assign@4.1.1
           [exec] | +-- glob@5.0.15
           [exec] | +-- glob-base@0.3.0
           [exec] | +-- glob-expand@0.1.0
           [exec] | | +-- glob@4.4.2
           [exec] | | +-- lodash@1.2.1
           [exec] | | `-- minimatch@2.0.10
           [exec] | +-- glob-parent@2.0.0
           [exec] | +-- glob-stream@5.3.5
           [exec] | | +-- glob-parent@3.1.0
           [exec] | | +-- is-extglob@2.1.1
           [exec] | | +-- is-glob@3.1.0
           [exec] | | +-- isarray@0.0.1
           [exec] | | +-- readable-stream@1.0.34
           [exec] | | +-- string_decoder@0.10.31
           [exec] | | `-- through2@0.6.5
           [exec] | +-- glob-watcher@3.2.0
           [exec] | +-- globals@9.18.0
           [exec] | +-- glogg@1.0.0
           [exec] | +-- graceful-fs@4.1.11
           [exec] | +-- gulp-babel-deps@2.0.1
           [exec] | +-- gulp-babel-globals@2.0.0
           [exec] | +-- gulp-if@2.0.2
           [exec] | +-- gulp-ignore@2.0.2
           [exec] | +-- gulp-match@1.0.3
           [exec] | +-- gulp-replace@0.5.4
           [exec] | +-- gulp-sourcemaps@1.6.0
           [exec] | | `-- vinyl@1.2.0
           [exec] | +-- gulp-util@3.0.8
           [exec] | | `-- minimist@1.2.0
           [exec] | +-- gulp-wrapper@1.0.0
           [exec] | | +-- isarray@0.0.1
           [exec] | | +-- readable-stream@1.0.34
           [exec] | | +-- string_decoder@0.10.31
           [exec] | | `-- through2@0.6.5
           [exec] | +-- gulplog@1.0.0
           [exec] | +-- has-ansi@2.0.0
           [exec] | +-- has-gulplog@0.1.0
           [exec] | +-- home-or-tmp@2.0.0
           [exec] | +-- hosted-git-info@2.5.0
           [exec] | +-- inflight@1.0.6
           [exec] | +-- inherits@2.0.3
           [exec] | +-- invariant@2.2.2
           [exec] | +-- invert-kv@1.0.0
           [exec] | +-- is-arrayish@0.2.1
           [exec] | +-- is-binary-path@1.0.1
           [exec] | +-- is-buffer@1.1.5
           [exec] | +-- is-builtin-module@1.0.0
           [exec] | +-- is-dotfile@1.0.3
           [exec] | +-- is-equal-shallow@0.1.3
           [exec] | +-- is-extendable@0.1.1
           [exec] | +-- is-extglob@1.0.0
           [exec] | +-- is-finite@1.0.2
           [exec] | +-- is-fullwidth-code-point@1.0.0
           [exec] | +-- is-glob@2.0.1
           [exec] | +-- is-number@2.1.0
           [exec] | +-- is-posix-bracket@0.1.1
           [exec] | +-- is-primitive@2.0.0
           [exec] | +-- is-stream@1.1.0
           [exec] | +-- is-utf8@0.2.1
           [exec] | +-- is-valid-glob@0.3.0
           [exec] | +-- isarray@1.0.0
           [exec] | +-- isexe@2.0.0
           [exec] | +-- isobject@2.1.0
           [exec] | +-- istextorbinary@1.0.2
           [exec] | +-- js-tokens@3.0.1
           [exec] | +-- jsesc@0.5.0
           [exec] | +-- json-stable-stringify@1.0.1
           [exec] | +-- json5@0.5.1
           [exec] | +-- jsonify@0.0.0
           [exec] | +-- kind-of@3.2.2
           [exec] | +-- lazystream@1.0.0
           [exec] | +-- lcid@1.0.0
           [exec] | +-- load-json-file@2.0.0
           [exec] | | `-- strip-bom@3.0.0
           [exec] | +-- locate-path@2.0.0
           [exec] | +-- lodash@4.17.4
           [exec] | +-- lodash._basecopy@3.0.1
           [exec] | +-- lodash._basetostring@3.0.1
           [exec] | +-- lodash._basevalues@3.0.0
           [exec] | +-- lodash._getnative@3.9.1
           [exec] | +-- lodash._isiterateecall@3.0.9
           [exec] | +-- lodash._reescape@3.0.0
           [exec] | +-- lodash._reevaluate@3.0.0
           [exec] | +-- lodash._reinterpolate@3.0.0
           [exec] | +-- lodash._root@3.0.1
           [exec] | +-- lodash.debounce@4.0.8
           [exec] | +-- lodash.escape@3.2.0
           [exec] | +-- lodash.isarguments@3.1.0
           [exec] | +-- lodash.isarray@3.0.4
           [exec] | +-- lodash.isequal@4.5.0
           [exec] | +-- lodash.keys@3.1.2
           [exec] | +-- lodash.restparam@3.6.1
           [exec] | +-- lodash.template@3.6.2
           [exec] | +-- lodash.templatesettings@3.1.1
           [exec] | +-- loose-envify@1.3.1
           [exec] | +-- lru-cache@4.1.1
           [exec] | +-- mem@1.1.0
           [exec] | +-- merge@1.2.0
           [exec] | +-- merge-stream@1.0.1
           [exec] | +-- metal-jquery-adapter@1.0.0
           [exec] | +-- metal-tools-build-amd@3.0.4
           [exec] | +-- metal-tools-build-globals@2.0.2
           [exec] | +-- metal-tools-build-jquery@2.0.2
           [exec] | +-- metal-tools-soy@4.2.5
           [exec] | | `-- yargs@8.0.2
           [exec] | +-- micromatch@2.3.11
           [exec] | +-- mimic-fn@1.1.0
           [exec] | +-- minimatch@3.0.4
           [exec] | +-- minimist@0.0.8
           [exec] | +-- mkdirp@0.5.1
           [exec] | +-- ms@2.0.0
           [exec] | +-- multipipe@0.1.2
           [exec] | +-- nan@2.6.2
           [exec] | +-- next-tick@1.0.0
           [exec] | +-- normalize-package-data@2.4.0
           [exec] | +-- normalize-path@2.1.1
           [exec] | +-- npm-run-path@2.0.2
           [exec] | +-- number-is-nan@1.0.1
           [exec] | +-- object-assign@3.0.0
           [exec] | +-- object.defaults@1.1.0
           [exec] | | +-- for-own@1.0.0
           [exec] | | `-- isobject@3.0.0
           [exec] | +-- object.omit@2.0.1
           [exec] | +-- once@1.4.0
           [exec] | +-- ordered-read-streams@0.3.0
           [exec] | +-- os-homedir@1.0.2
           [exec] | +-- os-locale@2.0.0
           [exec] | +-- os-tmpdir@1.0.2
           [exec] | +-- p-finally@1.0.0
           [exec] | +-- p-limit@1.1.0
           [exec] | +-- p-locate@2.0.0
           [exec] | +-- parse-glob@3.0.4
           [exec] | +-- parse-json@2.2.0
           [exec] | +-- parsimmon@1.6.0
           [exec] | +-- path-dirname@1.0.2
           [exec] | +-- path-exists@3.0.0
           [exec] | +-- path-is-absolute@1.0.1
           [exec] | +-- path-key@2.0.1
           [exec] | +-- path-parse@1.0.5
           [exec] | +-- path-type@2.0.0
           [exec] | +-- pify@2.3.0
           [exec] | +-- pinkie@2.0.4
           [exec] | +-- pinkie-promise@2.0.1
           [exec] | +-- preserve@0.2.0
           [exec] | +-- private@0.1.7
           [exec] | +-- process-nextick-args@1.0.7
           [exec] | +-- pseudomap@1.0.2
           [exec] | +-- randomatic@1.1.7
           [exec] | | +-- is-number@3.0.0
           [exec] | | | `-- kind-of@3.2.2
           [exec] | | `-- kind-of@4.0.0
           [exec] | +-- read-pkg@2.0.0
           [exec] | +-- read-pkg-up@2.0.0
           [exec] | +-- readable-stream@2.3.2
           [exec] | +-- readdirp@2.1.0
           [exec] | +-- regenerate@1.3.2
           [exec] | +-- regenerator-runtime@0.10.5
           [exec] | +-- regenerator-transform@0.9.11
           [exec] | +-- regex-cache@0.4.3
           [exec] | +-- regexpu-core@2.0.0
           [exec] | +-- regjsgen@0.2.0
           [exec] | +-- regjsparser@0.1.5
           [exec] | +-- remove-trailing-separator@1.0.2
           [exec] | +-- repeat-element@1.1.2
           [exec] | +-- repeat-string@1.6.1
           [exec] | +-- repeating@2.0.1
           [exec] | +-- replace-ext@0.0.1
           [exec] | +-- replacestream@4.0.2
           [exec] | | `-- object-assign@4.1.1
           [exec] | +-- require-dir@0.3.2
           [exec] | +-- require-directory@2.1.1
           [exec] | +-- require-main-filename@1.0.1
           [exec] | +-- resolve@1.3.3
           [exec] | +-- safe-buffer@5.1.1
           [exec] | +-- semver@5.3.0
           [exec] | +-- set-blocking@2.0.0
           [exec] | +-- set-immediate-shim@1.0.1
           [exec] | +-- signal-exit@3.0.2
           [exec] | +-- slash@1.0.0
           [exec] | +-- source-map@0.5.6
           [exec] | +-- source-map-support@0.4.15
           [exec] | +-- soyparser@1.0.2
           [exec] | +-- sparkles@1.0.0
           [exec] | +-- spdx-correct@1.0.2
           [exec] | +-- spdx-expression-parse@1.0.4
           [exec] | +-- spdx-license-ids@1.2.2
           [exec] | +-- stream-combiner@0.2.2
           [exec] | +-- stream-consume@0.1.0
           [exec] | +-- stream-exhaust@1.0.1
           [exec] | +-- stream-shift@1.0.0
           [exec] | +-- string-width@2.1.0
           [exec] | | +-- ansi-regex@3.0.0
           [exec] | | +-- is-fullwidth-code-point@2.0.0
           [exec] | | `-- strip-ansi@4.0.0
           [exec] | +-- string_decoder@1.0.3
           [exec] | +-- strip-ansi@3.0.1
           [exec] | +-- strip-bom@2.0.0
           [exec] | +-- strip-bom-stream@1.0.0
           [exec] | +-- strip-eof@1.0.0
           [exec] | +-- supports-color@2.0.0
           [exec] | +-- ternary-stream@2.0.1
           [exec] | +-- textextensions@1.0.2
           [exec] | +-- through@2.3.8
           [exec] | +-- through2@2.0.3
           [exec] | +-- through2-filter@2.0.0
           [exec] | +-- time-stamp@1.1.0
           [exec] | +-- to-absolute-glob@0.1.1
           [exec] | +-- to-fast-properties@1.0.3
           [exec] | +-- trim-right@1.0.1
           [exec] | +-- unique-stream@2.2.1
           [exec] | +-- util-deprecate@1.0.2
           [exec] | +-- vali-date@1.0.0
           [exec] | +-- validate-npm-package-license@3.0.1
           [exec] | +-- vinyl@0.5.3
           [exec] | +-- vinyl-fs@2.4.4
           [exec] | | +-- object-assign@4.1.1
           [exec] | | `-- vinyl@1.2.0
           [exec] | +-- vinyl-sourcemaps-apply@0.2.1
           [exec] | +-- which@1.2.14
           [exec] | +-- which-module@2.0.0
           [exec] | +-- window-size@0.1.4
           [exec] | +-- wrap-ansi@2.1.0
           [exec] | | `-- string-width@1.0.2
           [exec] | +-- wrappy@1.0.2
           [exec] | +-- xtend@4.0.1
           [exec] | +-- y18n@3.2.1
           [exec] | +-- yallist@2.1.2
           [exec] | +-- yargs@3.32.0
           [exec] | | +-- camelcase@2.1.1
           [exec] | | +-- os-locale@1.4.0
           [exec] | | `-- string-width@1.0.2
           [exec] | `-- yargs-parser@7.0.0
           [exec] +-- metal-component@2.13.2
           [exec] +-- metal-dom@2.13.2
           [exec] +-- metal-events@2.13.2
           [exec] +-- metal-karma-config@2.3.1
           [exec] | +-- karma-commonjs@1.0.0
           [exec] | +-- karma-source-map-support@1.2.0
           [exec] | `-- sinon@1.17.7
           [exec] +-- metal-state@2.13.2
           [exec] +-- micromatch@2.3.11
           [exec] +-- mime@1.3.6
           [exec] +-- mime-db@1.27.0
           [exec] +-- mime-types@2.1.15
           [exec] +-- minimatch@2.0.10
           [exec] +-- minimist@1.2.0
           [exec] +-- mkdirp@0.5.1
           [exec] | `-- minimist@0.0.8
           [exec] +-- mocha@2.5.3
           [exec] | +-- commander@2.3.0
           [exec] | +-- debug@2.2.0
           [exec] | +-- escape-string-regexp@1.0.2
           [exec] | +-- glob@3.2.11
           [exec] | +-- minimatch@0.3.0
           [exec] | +-- ms@0.7.1
           [exec] | `-- supports-color@1.2.0
           [exec] +-- ms@2.0.0
           [exec] +-- multipipe@0.1.2
           [exec] +-- mute-stream@0.0.5
           [exec] +-- nan@2.6.2
           [exec] +-- natives@1.1.0
           [exec] +-- natural-compare@1.4.0
           [exec] +-- negotiator@0.6.1
           [exec] +-- node-status-codes@1.0.0
           [exec] +-- nomnomnomnom@2.0.1
           [exec] | +-- ansi-styles@1.0.0
           [exec] | +-- chalk@0.4.0
           [exec] | `-- strip-ansi@0.1.1
           [exec] +-- nopt@3.0.6
           [exec] +-- normalize-package-data@2.4.0
           [exec] +-- normalize-path@2.1.1
           [exec] +-- normalize-range@0.1.2
           [exec] +-- null-check@1.0.0
           [exec] +-- num2fraction@1.2.2
           [exec] +-- number-is-nan@1.0.1
           [exec] +-- object-assign@3.0.0
           [exec] +-- object-component@0.0.3
           [exec] +-- object.defaults@1.1.0
           [exec] | +-- for-own@1.0.0
           [exec] | `-- isobject@3.0.0
           [exec] +-- object.omit@2.0.1
           [exec] +-- object.pick@1.2.0
           [exec] +-- on-finished@2.3.0
           [exec] +-- once@1.3.3
           [exec] +-- onetime@1.1.0
           [exec] +-- optimist@0.6.1
           [exec] | +-- minimist@0.0.10
           [exec] | `-- wordwrap@0.0.3
           [exec] +-- optionator@0.8.2
           [exec] +-- options@0.0.6
           [exec] +-- orchestrator@0.3.8
           [exec] +-- ordered-read-streams@0.1.0
           [exec] +-- os-homedir@1.0.2
           [exec] +-- os-tmpdir@1.0.2
           [exec] +-- osenv@0.1.4
           [exec] +-- package-json@2.4.0
           [exec] | `-- semver@5.3.0
           [exec] +-- packrattle@4.1.0
           [exec] +-- parse-filepath@1.0.1
           [exec] +-- parse-glob@3.0.4
           [exec] +-- parse-json@2.2.0
           [exec] +-- parse-passwd@1.0.0
           [exec] +-- parsejson@0.0.3
           [exec] +-- parseqs@0.0.5
           [exec] +-- parseuri@0.0.5
           [exec] +-- parseurl@1.3.1
           [exec] +-- path-exists@2.1.0
           [exec] +-- path-is-absolute@1.0.1
           [exec] +-- path-is-inside@1.0.2
           [exec] +-- path-parse@1.0.5
           [exec] +-- path-root@0.1.1
           [exec] +-- path-root-regex@0.1.2
           [exec] +-- path-type@1.1.0
           [exec] | `-- graceful-fs@4.1.11
           [exec] +-- pify@2.3.0
           [exec] +-- pinkie@2.0.4
           [exec] +-- pinkie-promise@2.0.1
           [exec] +-- pluralize@1.2.1
           [exec] +-- posix-getopt@1.2.0
           [exec] +-- postcss@5.2.17
           [exec] | `-- supports-color@3.2.3
           [exec] +-- postcss-value-parser@3.3.0
           [exec] +-- prelude-ls@1.1.2
           [exec] +-- prepend-http@1.0.4
           [exec] +-- preserve@0.2.0
           [exec] +-- prettier@1.5.2
           [exec] +-- pretty-hrtime@1.0.3
           [exec] +-- private@0.1.7
           [exec] +-- process-nextick-args@1.0.7
           [exec] +-- progress@1.1.8
           [exec] +-- proto-list@1.2.4
           [exec] +-- pseudomap@1.0.2
           [exec] +-- qjobs@1.1.5
           [exec] +-- qs@6.4.0
           [exec] +-- randomatic@1.1.7
           [exec] | +-- is-number@3.0.0
           [exec] | | `-- kind-of@3.2.2
           [exec] | `-- kind-of@4.0.0
           [exec] +-- range-parser@1.2.0
           [exec] +-- raw-body@2.2.0
           [exec] +-- rc@1.2.1
           [exec] +-- read-all-stream@3.1.0
           [exec] | +-- isarray@1.0.0
           [exec] | +-- readable-stream@2.3.2
           [exec] | `-- string_decoder@1.0.3
           [exec] +-- read-pkg@1.1.0
           [exec] +-- read-pkg-up@1.0.1
           [exec] +-- readable-stream@1.1.14
           [exec] +-- readdirp@2.1.0
           [exec] | +-- graceful-fs@4.1.11
           [exec] | +-- isarray@1.0.0
           [exec] | +-- minimatch@3.0.4
           [exec] npm WARN optional Skipping failed optional dependency /gulp-metal/chokidar/fsevents:
           [exec] | +-- readable-stream@2.3.2
           [exec] | `-- string_decoder@1.0.3
           [exec] +-- readline2@1.0.1
           [exec] +-- recast@0.12.6
           [exec] | `-- esprima@4.0.0
           [exec] +-- rechoir@0.6.2
           [exec] npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.1.2
           [exec] npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
           [exec] +-- redent@1.0.0
           [exec] +-- regenerate@1.3.2
           [exec] +-- regenerator-runtime@0.10.5
           [exec] +-- regenerator-transform@0.9.11
           [exec] +-- regex-cache@0.4.3
           [exec] npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.1.2
           [exec] +-- regexpu-core@2.0.0
           [exec] +-- registry-auth-token@3.3.1
           [exec] +-- registry-url@3.1.0
           [exec] +-- regjsgen@0.2.0
           [exec] +-- regjsparser@0.1.5
           [exec] npm WARN optional Skipping failed optional dependency /metal-cli/chokidar/fsevents:
           [exec] +-- remove-trailing-separator@1.0.2
           [exec] +-- repeat-element@1.1.2
           [exec] +-- repeat-string@1.6.1
           [exec] +-- repeating@2.0.1
           [exec] +-- replace-ext@0.0.1
           [exec] npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.1.2
           [exec] npm WARN frontend-js-web@1.0.56 No description
           [exec] npm WARN frontend-js-web@1.0.56 No repository field.
           [exec] +-- require-uncached@1.0.3
           [exec] +-- requires-port@1.0.0
           [exec] +-- resolve@1.3.3
           [exec] +-- resolve-dir@0.1.1
           [exec] +-- resolve-from@1.0.1
           [exec] +-- restore-cursor@1.0.1
           [exec] npm WARN frontend-js-web@1.0.56 No license field.
           [exec] +-- right-align@0.1.3
           [exec] +-- rimraf@2.6.1
           [exec] | +-- glob@7.1.2
           [exec] | `-- minimatch@3.0.4
           [exec] +-- run-async@0.1.0
           [exec] +-- rx-lite@3.1.2
           [exec] +-- safe-buffer@5.1.1
           [exec] +-- samsam@1.1.2
           [exec] +-- semver@4.3.6
           [exec] +-- semver-diff@2.1.0
           [exec] | `-- semver@5.3.0
           [exec] +-- sequencify@0.0.7
           [exec] +-- set-immediate-shim@1.0.1
           [exec] +-- setprototypeof@1.0.3
           [exec] +-- shelljs@0.7.8
           [exec] | +-- glob@7.1.2
           [exec] | `-- minimatch@3.0.4
           [exec] +-- sigmund@1.0.1
           [exec] +-- signal-exit@3.0.2
           [exec] +-- sinon@1.17.2
           [exec] +-- slash@1.0.0
           [exec] +-- slice-ansi@0.0.4
           [exec] +-- slide@1.1.6
           [exec] +-- socket.io@1.7.3
           [exec] | +-- debug@2.3.3
           [exec] | +-- ms@0.7.2
           [exec] | `-- object-assign@4.1.0
           [exec] +-- socket.io-adapter@0.5.0
           [exec] | +-- debug@2.3.3
           [exec] | `-- ms@0.7.2
           [exec] +-- socket.io-client@1.7.3
           [exec] | +-- component-emitter@1.2.1
           [exec] | +-- debug@2.3.3
           [exec] | `-- ms@0.7.2
           [exec] +-- socket.io-parser@2.3.1
           [exec] | +-- debug@2.2.0
           [exec] | `-- ms@0.7.1
           [exec] +-- source-map@0.5.6
           [exec] +-- source-map-support@0.4.15
           [exec] +-- sparkles@1.0.0
           [exec] +-- spdx-correct@1.0.2
           [exec] +-- spdx-expression-parse@1.0.4
           [exec] +-- spdx-license-ids@1.2.2
           [exec] +-- sprintf-js@1.0.3
           [exec] +-- statuses@1.3.1
           [exec] +-- stream-consume@0.1.0
           [exec] +-- string-width@1.0.2
           [exec] +-- string_decoder@0.10.31
           [exec] +-- strip-ansi@3.0.1
           [exec] +-- strip-bom@1.0.0
           [exec] +-- strip-indent@1.0.1
           [exec] +-- strip-json-comments@2.0.1
           [exec] +-- supports-color@2.0.0
           [exec] +-- svg4everybody@2.1.8
           [exec] +-- table@3.8.3
           [exec] | +-- ansi-regex@3.0.0
           [exec] | +-- is-fullwidth-code-point@2.0.0
           [exec] | +-- lodash@4.17.4
           [exec] | +-- string-width@2.1.0
           [exec] | `-- strip-ansi@4.0.0
           [exec] +-- text-table@0.2.0
           [exec] +-- through@2.3.8
           [exec] +-- through2@2.0.3
           [exec] | +-- isarray@1.0.0
           [exec] | +-- readable-stream@2.3.2
           [exec] | `-- string_decoder@1.0.3
           [exec] +-- tildify@1.2.0
           [exec] +-- time-stamp@1.1.0
           [exec] +-- timed-out@3.1.3
           [exec] +-- tmp@0.0.31
           [exec] +-- to-array@0.1.4
           [exec] +-- to-fast-properties@1.0.3
           [exec] +-- to-iso-string@0.0.2
           [exec] +-- trim-newlines@1.0.0
           [exec] +-- trim-right@1.0.1
           [exec] +-- tryit@1.0.3
           [exec] +-- tweetnacl@0.14.5
           [exec] +-- type-check@0.3.2
           [exec] +-- type-detect@0.1.1
           [exec] +-- type-is@1.6.15
           [exec] +-- typedarray@0.0.6
           [exec] +-- typhonjs-ast-walker@0.1.1
           [exec] +-- typhonjs-escomplex@0.0.12
           [exec] +-- typhonjs-escomplex-commons@0.0.16
           [exec] +-- typhonjs-escomplex-module@0.0.12
           [exec] +-- typhonjs-escomplex-project@0.0.12
           [exec] +-- typhonjs-plugin-manager@0.0.3
           [exec] +-- uglify-js@2.8.29
           [exec] +-- uglify-to-browserify@1.0.2
           [exec] +-- ultron@1.0.2
           [exec] +-- unc-path-regex@0.1.2
           [exec] +-- underscore@1.6.0
           [exec] +-- underscore.string@2.3.3
           [exec] +-- unique-stream@1.0.0
           [exec] +-- unpipe@1.0.0
           [exec] +-- unzip-response@1.0.2
           [exec] +-- upath@0.1.7
           [exec] | `-- lodash@3.10.1
           [exec] +-- update-notifier@0.6.3
           [exec] +-- url-parse-lax@1.0.0
           [exec] +-- user-home@1.1.1
           [exec] +-- useragent@2.1.13
           [exec] | `-- lru-cache@2.2.4
           [exec] +-- util@0.10.3
           [exec] | `-- inherits@2.0.1
           [exec] +-- util-deprecate@1.0.2
           [exec] +-- utils-merge@1.0.0
           [exec] +-- uuid@2.0.3
           [exec] +-- v8flags@2.1.1
           [exec] +-- validate-npm-package-license@3.0.1
           [exec] +-- vinyl@0.5.3
           [exec] +-- vinyl-fs@0.3.14
           [exec] | +-- clone@0.2.0
           [exec] | +-- readable-stream@1.0.34
           [exec] | +-- through2@0.6.5
           [exec] | `-- vinyl@0.4.6
           [exec] +-- vinyl-sourcemaps-apply@0.2.1
           [exec] +-- void-elements@2.0.1
           [exec] +-- walk@2.3.9
           [exec] +-- walkdir@0.0.10
           [exec] +-- which@1.2.14
           [exec] +-- widest-line@1.0.0
           [exec] +-- window-size@0.1.0
           [exec] +-- wordwrap@1.0.0
           [exec] +-- wrappy@1.0.2
           [exec] +-- write@0.2.1
           [exec] +-- write-file-atomic@1.3.4
           [exec] | `-- graceful-fs@4.1.11
           [exec] +-- ws@1.1.2
           [exec] +-- wtf-8@1.0.0
           [exec] +-- xdg-basedir@2.0.0
           [exec] +-- xmlbuilder@0.4.2
           [exec] +-- xmlhttprequest-ssl@1.5.3
           [exec] +-- xtend@4.0.1
           [exec] +-- yargs@3.10.0
           [exec] `-- yeast@0.1.2
           [exec]
           [exec]
           [exec] FAILURE: Build failed with an exception.
           [exec]
           [exec] * What went wrong:
           [exec] Execution failed for task ':apps:foundation:frontend-image-editor:frontend-image-editor-capability-saturation:configJSModules'.
           [exec] > java.io.IOException: Process '[cmd, /c, ""L:\EE\70p\modules\apps\foundation\frontend-image-editor\frontend-image-editor-capability-saturation\build\node\bin\node" "L:/EE/70p/modules/apps/foundation/frontend-image-editor/frontend-image-editor-capability-saturation/node_modules/liferay-module-config-generator/bin/index.js" "--config" "" "--extension" "" "--format" "/_/g,-" "--ignorePath" "true" "--moduleConfig" "L:/EE/70p/modules/apps/foundation/frontend-image-editor/frontend-image-editor-capability-saturation/package.json" "--namespace" "Liferay.Loader" "--output" "L:/EE/70p/modules/apps/foundation/frontend-image-editor/frontend-image-editor-capability-saturation/classes/META-INF/config.json" "--moduleRoot" "L:/EE/70p/modules/apps/foundation/frontend-image-editor/frontend-image-editor-capability-saturation/build/tmp/configJSModules/files" "L:/EE/70p/modules/apps/foundation/frontend-image-editor/frontend-image-editor-capability-saturation/build/tmp/configJSModules""]' finished with non-zero exit value 1
           [exec]
           [exec] * Try:
           [exec] Run with --info or --debug option to get more log output.
           [exec]
           [exec] * Exception is:
           [exec] org.gradle.api.tasks.TaskExecutionException: Execution failed for task ':apps:foundation:frontend-image-editor:frontend-image-editor-capability-saturation:configJSModules'.
           [exec]     at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.executeActions(ExecuteActionsTaskExecuter.java:84)
           [exec]     at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.execute(ExecuteActionsTaskExecuter.java:55)
           [exec]     at org.gradle.api.internal.tasks.execution.SkipUpToDateTaskExecuter.execute(SkipUpToDateTaskExecuter.java:62)
           [exec]     at org.gradle.api.internal.tasks.execution.ValidatingTaskExecuter.execute(ValidatingTaskExecuter.java:58)
           [exec]     at org.gradle.api.internal.tasks.execution.SkipEmptySourceFilesTaskExecuter.execute(SkipEmptySourceFilesTaskExecuter.java:88)
           [exec]     at org.gradle.api.internal.tasks.execution.ResolveTaskArtifactStateTaskExecuter.execute(ResolveTaskArtifactStateTaskExecuter.java:46)
           [exec]     at org.gradle.api.internal.tasks.execution.SkipTaskWithNoActionsExecuter.execute(SkipTaskWithNoActionsExecuter.java:51)
           [exec]     at org.gradle.api.internal.tasks.execution.SkipOnlyIfTaskExecuter.execute(SkipOnlyIfTaskExecuter.java:54)
           [exec]     at org.gradle.api.internal.tasks.execution.ExecuteAtMostOnceTaskExecuter.execute(ExecuteAtMostOnceTaskExecuter.java:43)
           [exec]     at org.gradle.api.internal.tasks.execution.CatchExceptionTaskExecuter.execute(CatchExceptionTaskExecuter.java:34)
           [exec]     at org.gradle.execution.taskgraph.DefaultTaskGraphExecuter$EventFiringTaskWorker$1.execute(DefaultTaskGraphExecuter.java:236)
           [exec]     at org.gradle.execution.taskgraph.DefaultTaskGraphExecuter$EventFiringTaskWorker$1.execute(DefaultTaskGraphExecuter.java:228)
           [exec]     at org.gradle.internal.Transformers$4.transform(Transformers.java:169)
           [exec]     at org.gradle.internal.progress.DefaultBuildOperationExecutor.run(DefaultBuildOperationExecutor.java:106)
           [exec]     at org.gradle.internal.progress.DefaultBuildOperationExecutor.run(DefaultBuildOperationExecutor.java:61)
           [exec]     at org.gradle.execution.taskgraph.DefaultTaskGraphExecuter$EventFiringTaskWorker.execute(DefaultTaskGraphExecuter.java:228)
           [exec]     at org.gradle.execution.taskgraph.DefaultTaskGraphExecuter$EventFiringTaskWorker.execute(DefaultTaskGraphExecuter.java:215)
           [exec]     at org.gradle.execution.taskgraph.AbstractTaskPlanExecutor$TaskExecutorWorker.processTask(AbstractTaskPlanExecutor.java:77)
           [exec]     at org.gradle.execution.taskgraph.AbstractTaskPlanExecutor$TaskExecutorWorker.run(AbstractTaskPlanExecutor.java:58)
           [exec]     at org.gradle.internal.concurrent.ExecutorPolicy$CatchAndRecordFailures.onExecute(ExecutorPolicy.java:54)
           [exec]     at org.gradle.internal.concurrent.StoppableExecutorImpl$1.run(StoppableExecutorImpl.java:40)
           [exec] Caused by: org.gradle.api.UncheckedIOException: java.io.IOException: Process '[cmd, /c, ""L:\EE\70p\modules\apps\foundation\frontend-image-editor\frontend-image-editor-capability-saturation\build\node\bin\node" "L:/EE/70p/modules/apps/foundation/frontend-image-editor/frontend-image-editor-capability-saturation/node_modules/liferay-module-config-generator/bin/index.js" "--config" "" "--extension" "" "--format" "/_/g,-" "--ignorePath" "true" "--moduleConfig" "L:/EE/70p/modules/apps/foundation/frontend-image-editor/frontend-image-editor-capability-saturation/package.json" "--namespace" "Liferay.Loader" "--output" "L:/EE/70p/modules/apps/foundation/frontend-image-editor/frontend-image-editor-capability-saturation/classes/META-INF/config.json" "--moduleRoot" "L:/EE/70p/modules/apps/foundation/frontend-image-editor/frontend-image-editor-capability-saturation/build/tmp/configJSModules/files" "L:/EE/70p/modules/apps/foundation/frontend-image-editor/frontend-image-editor-capability-saturation/build/tmp/configJSModules""]' finished with non-zero exit value 1
           [exec]     at org.gradle.internal.UncheckedException.throwAsUncheckedException(UncheckedException.java:43)
           [exec]     at org.gradle.internal.reflect.JavaMethod.invoke(JavaMethod.java:76)
           [exec]     at org.gradle.api.internal.project.taskfactory.DefaultTaskClassInfoStore$StandardTaskAction.doExecute(DefaultTaskClassInfoStore.java:141)
           [exec]     at org.gradle.api.internal.project.taskfactory.DefaultTaskClassInfoStore$StandardTaskAction.execute(DefaultTaskClassInfoStore.java:134)
           [exec]     at org.gradle.api.internal.project.taskfactory.DefaultTaskClassInfoStore$StandardTaskAction.execute(DefaultTaskClassInfoStore.java:123)
           [exec]     at org.gradle.api.internal.AbstractTask$TaskActionWrapper.execute(AbstractTask.java:632)
           [exec]     at org.gradle.api.internal.AbstractTask$TaskActionWrapper.execute(AbstractTask.java:615)
           [exec]     at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.executeAction(ExecuteActionsTaskExecuter.java:95)
           [exec]     at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.executeActions(ExecuteActionsTaskExecuter.java:76)
           [exec]     ... 20 more
           [exec] Caused by: java.io.IOException: Process '[cmd, /c, ""L:\EE\70p\modules\apps\foundation\frontend-image-editor\frontend-image-editor-capability-saturation\build\node\bin\node" "L:/EE/70p/modules/apps/foundation/frontend-image-editor/frontend-image-editor-capability-saturation/node_modules/liferay-module-config-generator/bin/index.js" "--config" "" "--extension" "" "--format" "/_/g,-" "--ignorePath" "true" "--moduleConfig" "L:/EE/70p/modules/apps/foundation/frontend-image-editor/frontend-image-editor-capability-saturation/package.json" "--namespace" "Liferay.Loader" "--output" "L:/EE/70p/modules/apps/foundation/frontend-image-editor/frontend-image-editor-capability-saturation/classes/META-INF/config.json" "--moduleRoot" "L:/EE/70p/modules/apps/foundation/frontend-image-editor/frontend-image-editor-capability-saturation/build/tmp/configJSModules/files" "L:/EE/70p/modules/apps/foundation/frontend-image-editor/frontend-image-editor-capability-saturation/build/tmp/configJSModules""]' finished with non-zero exit value 1
           [exec]     at com.liferay.gradle.plugins.node.internal.NodeExecutor._executeProcessBuilder(NodeExecutor.java:164)
           [exec]     at com.liferay.gradle.plugins.node.internal.NodeExecutor.execute(NodeExecutor.java:71)
           [exec]     at com.liferay.gradle.plugins.node.tasks.ExecuteNodeTask.executeNode(ExecuteNodeTask.java:64)
           [exec]     at com.liferay.gradle.plugins.node.tasks.ExecuteNodeScriptTask.executeNode(ExecuteNodeScriptTask.java:40)
           [exec]     at com.liferay.gradle.plugins.js.module.config.generator.ConfigJSModulesTask.executeNode(ConfigJSModulesTask.java:103)
           [exec]     at org.gradle.internal.reflect.JavaMethod.invoke(JavaMethod.java:73)
           [exec]     ... 27 more
           [exec]
           [exec]
           [exec] BUILD FAILED
           [exec]
           [exec] Total time: 52 mins 30.508 secs
           [exec]
      
      BUILD FAILED
      L:\EE\70p\build.xml:30: The following error occurred while executing this line:
      L:\EE\70p\build.xml:350: The following error occurred while executing this line:
      L:\EE\70p\build-common.xml:637: L:\EE\70p\build-common.xml:639: exec returned: 1
      
      Total time: 64 minutes 55 seconds
      

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                3 years, 4 weeks, 1 day ago

                Packages

                Version Package
                7.0.0 DXP FP31
                7.0.5 CE GA6
                7.0.X
                7.1.X
                Master