Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-75958

The web content setting "Version history by default enabled" doesn't work

    Details

      Description

      The web content setting "Version history by default enabled" doesn't work.

      This setting is located in System Setting > Web Experience > Web Content.

      Steps to reproduce

      1. Go to Control Panel > System Setting > Web Experience > Web Content
      2. Uncheck "Version history by default enabled" setting
      3. This setting is cached, so reboot Liferay
      4. After rebooting Liferay, open any site and go to Content > Web Content section
      5. Create one webcontent
      6. Execute Export/Import from kebab menu
      7. In section "Content", click "Change" link
      8. A pop-up is displayed with a "Version History" check
        • Wrong behavior: "Version History" box is checked
        • Expected behavior: "Version History" box is unchecked (same value than "Version history by default enabled" setting)

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  1 year, 51 weeks, 2 days ago

                  Packages

                  Version Package
                  7.0.0 DXP FP35
                  7.0.0 DXP SP7
                  7.0.5 CE GA6
                  7.0.X
                  7.1.X
                  Master