Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-76341

Journal Structure default values are only showed on default language in WCM.

    Details

      Description

       Default field values are not showed when try to add a new language (defined in the Structure)   in a Web Content.

      Steps to reproduce

      1. Start a portal
      2. Create a Structure with a Text field and default value for it.
      3. Add translation in other language to this Structure changing the default value of the Text field.
      4. Add an empty template for this Structure.
      5. Create a Web Content based on this Structure.
      6. Add new language for this Web Content (this new language must be the same than in step 3).

      Current behavior
      Default value for field in new language is wrong.
      Expected bahavior
      Default value for field in new language is the same than value in Structure.

       Attached file multi-language-default-value-not-showed.png shows how the default value is not like the configured one.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  1 year, 39 weeks, 4 days ago

                  Packages

                  Version Package
                  7.0.0 DXP FP40
                  7.0.0 DXP SP7
                  7.0.5 CE GA6
                  7.0.X
                  7.1.0 M1
                  7.1.X
                  Master