Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-76604

Site template email configuration not propagated to the new site

    Details

      Description

      Reproduce steps:

      1. Go to Control Panel -> Sites -> Site Templates -> + Add a site template named "WC Site Template1".
      2. Go to "WC Site Template1" -> Content -> Web Content -> Configuration(ellipsis).
      3. Update the following email configurations to different values.
        Web content Added Email
        Web content Moved from Folder Email
        Web content Moved to Folder Email
        Web content Review Email
        Web content updated Email
      4. Save it.
      5. Go to Control Panel -> Sites -> Sites -> + Add a site named "WC Site1" using the site template "WC Site Template1".
      6. Go to "WC Site1" -> Content -> Web Content -> Configuration(ellipsis)

      Actual Behavior:      field values like "Web content Added Email" reverted to the portal default values instead of the updated values.
      Expected Behavior: field values like "Web content Added Email" should reflect the updated values.

      Master: 5ef4d8b9e54c3a3a30872c4628f3e88eb0888252
      Branch: d20f581bfdbddf1322795dca0df891a583bab17cn

      Note: this issue can also be reproduced against Knowledge Base, Bookmarks portlet.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 36 weeks, 2 days ago

                Packages

                Version Package
                7.0.0 DXP FP37
                7.0.0 DXP SP7
                7.0.5 CE GA6
                7.0.X
                7.1.0 M1
                7.1.X
                Master