Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-78532

portal-workflow-kaleo-forms-web is using wrong version of ddm-api

    Details

      Description

      Error on startup on master-private branch

           [exec] 14:05:27,681 ERROR [fileinstall-/opt/dev/projects/github/liferay-portal/bundles/osgi/portal][org_apache_felix_fileinstall:112] Exiting the JVM 
           [exec] org.osgi.framework.BundleException: Could not resolve module: com.liferay.portal.workflow.kaleo.forms.web [215]
           [exec]   Unresolved requirement: Import-Package: com.liferay.dynamic.data.mapping.constants; version="[1.0.0,2.0.0)"
           [exec] 
           [exec] 	at org.eclipse.osgi.container.Module.start(Module.java:429)
           [exec] 	at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:402)
           [exec] 	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle(DirectoryWatcher.java:1258)
           [exec] 	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles(DirectoryWatcher.java:1230)
           [exec] 	at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:512)
           [exec] 	at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:361)
           [exec] 	at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:312)
      

        Attachments

          Activity

            People

            Assignee:
            jason.pince Jason Pince
            Reporter:
            matthew.tambara Matthew Tambara
            Participants of an Issue:
            Recent user:
            Enterprise Release HU
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              3 years, 3 weeks, 6 days ago

                Packages

                Version Package
                7.1.0 M2
                7.1.X
                7.2.X
                Master