Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-78640

Cannot reconnect to remote Elasticsearch after improper settings are added to the Elasticsearch configuration, even after corrections

    Details

      Description

      When improper settings are added to Additional Configurations, remote Elasticsearch can no longer be reached without restarting Liferay.

      Steps to Reproduce

      1. Start Liferay
      2. Setup Remote Elasticsearch
      3. Navigate to Elasticsearch6 Configuration
        1. Navigate to Control Panel -> Configuration -> System Settings
        2. Under Content Management
          • Select: Search
        3. Under System Scope
          • Select: Elasticsearch6
      4. Under Additional Configurations, add:
        {test}
        
      5. Click Save/Update
        • Notice errors in console/logs
      6. Under Additional Configurations, remove the entered configuration
      7. Click Save/Update
      8. Navigate to Control Panel -> Configuration -> Server Administration
        • Execute: Reindex all search indexes

      Expected Result
      No error is thrown in console/logs and the remote Elasticsearch works as expected

      Actual Result
      An error is thrown in console/logs and the remote Elasticsearch does not work

        Attachments

          Activity

            People

            Assignee:
            brian.chan Brian Chan
            Reporter:
            eric.yan Eric Yan
            Participants of an Issue:
            Recent user:
            Brian Wulbern
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              3 years, 20 weeks, 1 day ago

                Packages

                Version Package
                7.1.X
                Master