Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-79311

no error message appears when deploying 2 modules with the same Web-ContextPath

    Details

      Description

      Summary of Issue:
      When 2 modules that share the same Web-ContextPath are deployed on the same page, their JSP's aren't compiled and therefore they do not behave as expected. There is no error shown that implies the root of the issue is the shared Web-ContextPath.

      Steps to Reproduce:
      1. Create 2 MVCPortlets in liferay workspace:

      cli>> blade create -t mvc-portlet a
      cli>> blade create -t mvc-portlet b
      

      2. Edit the modules both bnd.bnd in each module have the following appended at the end of it:

      Web-ContextPath: /mistakenly-shared
      

      3. Deploy each module.

      cli>> blade gw deploy
      

      4. Add both portlet to a page in liferay.

      Alternative Steps to reproduce:
      1. Startup Liferay DXP
      2. Deploy both attached portlets
      3. Add them to a page and see behavior

      Expected Behavior: An error to be logged explaining why both portlets don't display the same text

      Actual Behavior: No error is shown, but the identical portlets do not display the default JSP made by blade (one or both are blank, dependent order of deployment or whether they are registered on startup). The default text is in the form: "Hello from <a/b> JSP!"

      Additional information: The client hit an issue where a module referenced a string from the respective package.json file that were the same when trying to determine the string used for Web-ContextPath. When trying to render the portlets, neither module was able to render their JSP and no errors were reported. They realized the <LR_HOME>/work folder did not hold the compiled JSP's for the module, (as did I in my testing). They have discovered that the Web-ContextPath referenced the same string from 2 separate package.json files.

      Master:  Reproduced. a portlet showed: "Hello from a JSP!". b portlet did not show any content. 63becb8353e57714bf179233e4b54ad73d6919b1
      Branch: Unable to render embedded object: File (/images/icons/emoticons/check.png) not found. Reproduced. a portlet showed: "Hello from a JSP!". b portlet did not show any content. cf9781f8e70f78a5aa4cadb378bb7d8501b57e17

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  1 year, 4 days ago