Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-80134

Validator.class, _emailAddressPattern method has a typing error

    Details

    • Type: Bug
    • Status: Verified
    • Resolution: Unresolved
    • Affects Version/s: Master
    • Fix Version/s: None
    • Component/s: User Management
    • Labels:
    • Environment:
      Eclipse Neon.3 + Liferay IDE 3.1.2 GA3(Windows 64-bit) bundle.
      Using Liferay 7
    • Fix Priority:
      2

      Description

      Hello there, 

      was just following the tutorial on the dev.liferay site. Some stepps in the tutorial i tryed out my projekt and noticed that on introducing an '@' char in my email adress(inside the web application i'm currently developing) i always get an error.
      So after some browsing and debuging i discovered, that in the Validator.class the emailAddressPattern method is flawed, it currently says: "[\\w!#$%&'*+/=?^_`\{|}~-](?:
      .[\\w!#$%&'*+/=?^_`\{|}~-]
      )*@" +

      "(?:[a-zA-Z0-9](?:-[a-zA-Z0-9])?
      .
      )+"

      yet it should say: "[\\w!#$%&'*+\/=?^_`\{|}~-](?:
      .[\\w!#$%&'*+\/=?^_`\{|}~-]
      )*@" +
      "(?:[a-zA-Z0-9](?:-[a-zA-Z0-9])?
      .
      )+"

      there are two \ missing.

      But i can't edit this patern, how do i do that?

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Days since last comment:
                1 year, 29 weeks ago

                Packages

                Version Package