Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-80952

Visual issue when autofill causes Select from List field to lose value

    Details

      Description

      Steps to Reproduce:

      1. Go to Content > Forms
      2. Go to Settings > Data Providers
      3. Add a new Data Provider
        • Name: "Liferay Countries"
        • URL: "http://localhost:8080/api/jsonws/country/get-countries"
        • User Name: "test@liferay.com"
        • Password: "test"
        • Outputs:
          • Label: "Name"
          • Path: "nameCurrentValue"
          • Type "List"
      4. Save
      5. Go to Content > Forms
      6. Add a new Form
      7. Add a Text field
      8. Add a Select from List field
      9. Set 3 options for the Select field (A,B,C)
      10. Go to Rules tab
      11. Add a new rule
        • If Text field Is Not Empty
        • Autofill from Liferay Countries
        • Into Select field
      12. Save rule
      13. Publish Form
      14. Go to Publication URL
      15. Select option "B" for the Select field
      16. Input value into Text field to trigger Autofill

      Expected Result:
      Select field is set to default option and visual display "Choose an Option"

      Actual Result:
      Select field is made blank and dropdown icon moves to the left side of the field, instead of the right side.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Days since last comment:
                5 weeks, 3 days ago

                Packages

                Version Package