PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-8132

validation error of webform field label length, file to save, destination adresses and subject of the mail

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 5.2.3, 6.1.0 CE RC1
    • Component/s: Web Form
    • Labels:
    • Environment:
      oracle
      firefox 3.5
      webform plugin version 5.2.7.1 , saving to DB
    • Branch Version/s:
      6.0.x
    • Backported to Branch:
      Committed
    • Story Points:
      2
    • Similar Issues:
      Show 5 results 

      Description

      When entering fieldlabels with more than 75 characters no error appears, portlet configuration is being saved.

      it causes this error:
      When someone enters data into webform and ist configured to save data to the DB, webform cant save the data. (expando column value is limited to 75 chars)

      the fieldlabel html input size IS set to 50 but it is not repected by the browser (due to js ?)

      Also, the file to save in the filled in forms is not correctly saved in the preferences neither opened to save the results.

      The destination adresses field does not get checked for null

      The subject gets checked every time even if the mail option is not selected

        Issue Links

          Activity

          Sergio Sanchez added a comment -

          It is related in the first point of the ticket

          Michael Han added a comment -

          Src Format Error

          Michael Saechang added a comment -

          Committed on 6.1.x plugins revision: 89669.

          Not committed to 5.2.x.

          QA please test on 6.1.x and then resolve if pass.

          Mark Jin added a comment -

          PASSED Manual Testing using the following steps:

          1. Deploy Web Form portlet.
          2. Add a page and add WF portlet.
          3. Go to Configuration.
          4. Create text field with more than 75 characters.
          5. Check Send as Enail and click Save button with null Email Addresses.

          Reproduced on:
          Tomcat 7.0.21 + Oracle 11g. 6.1.x Revision 89220. Plugin Revision 89220.
          Before the Fixed: For example. When entering fieldlabels with more than 75 characters does not throw validation error.

          Fixed on:
          Tomcat 7.0.21 + Oracle 11g. 6.1.x Revision 91680. Plugin Revision 91680.
          After the fixed: When extering fieldlabels with more than 75 characters, You will get "Please enter no more than 75 characters.".


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                3 years, 30 weeks, 4 days ago

                Development

                  Structure Helper Panel