Details

    • Type: Technical Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Completed
    • Affects Version/s: None
    • Fix Version/s: Master
    • Component/s: None
    • Labels:
      None

      Description

      By reverting to version 2.0 this ensure that anyone that build against that version is still compatible.

      Anyone who builds against Portlet 3 API will have 3 scenarios to choose from:

      • if they use liferay's gradle defaults they don't have to do anything, they will inherit the JavaPortlet contract and be compatible
      • if they use any other tool chain that provides bnd, they simply have to add `-contract: JavaPortlet` to their bnd instructions
      • if they have neither liferay gradle defaults or bnd, they should prevent the import package of the javax.portlet.* from having an import version.

        Attachments

          Activity

            People

            • Assignee:
              brian.chan Brian Chan
              Reporter:
              raymond.auge Raymond Auge
              Recent user:
              William Nealeigh
              Participants of an Issue:
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 19 weeks, 6 days ago

                Packages

                Version Package
                Master