Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-82475

Editing a Content Page with its Pencil Button from its View Section doesn't load Widget database entries correctly

    Details

      Description

      Description
      The current entries for widgets should be correctly loaded when navigating to a content page. However, when specifically going from a view to an edit mode, we do not correctly load the widget entries from the database. One possibility is that it is never called because we do not consider going from view -> edit mode a necessary condition to load from database

      Steps to Reproduce

      1. Create a fragment with navigation menu portlet and blogs portlet
      2. Make sure both portlets are populated with data
      3. Create a Content page and add the fragment to it
      4. View the content page
      5. Click the Edit Pencil button on top to edit the content page

      Expected Result
      Portlet Entries Load

      Actual Result
      Portlet Entries do not Load

      Reproduced on: Tomcat 9.0.6 + MariaDB 10.2
      Portal 7.1.x-private GIT ID: 11dae6df9f20724f1c22947211cdad0af7b20325

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              kyle.miho Kyle Miho
              Reporter:
              kyle.miho Kyle Miho
              Participants of an Issue:
              Recent user:
              Marta Elicegui
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                3 years, 31 weeks, 1 day ago

                  Packages

                  Version Package
                  7.1.X
                  Master