Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-82646

UI broken after saving Web Content with characters outside UTF-8

    Details

      Description

      Steps to reproduce:

      1. Go to Site menu>Content>Web Content
      2. Create new Web Content
      3. Enter Title with characters outside UTF-8 (e.g. ¢ £ % # & * @ § ☆ ★ ○ ● ◎ ◇ | ◆ □ ■ △ ▲ ▽ ▼ ※ 〒 → ← ↑ ↓ 〓 )
      4. Publish Web Content

      Actual result: Web Content is not saved, UI is Broken, no browser error is displayed, console throw error Invalid URL encoding.

      Expected: Web Content is not saved, Error Content is outside UTF-8 coding is displayed and UI is not broken.

      Tested & failed: Liferay 7.1 git id: 75339f85a4c499c8756c4764740b52f64401e9ca, Ubuntu 14.04, CentOS

      Priority: L2 + S3 = 3
       

        Attachments

        1. 7.0.PNG
          7.0.PNG
          73 kB
        2. UTF8BrokenUI.gif
          UTF8BrokenUI.gif
          383 kB

          Activity

            People

            Assignee:
            kyle.miho Kyle Miho
            Reporter:
            jakub.vavera Jakub Vavera
            Participants of an Issue:
            Recent user:
            Csaba Turcsan
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              2 years, 33 weeks, 4 days ago

                Packages

                Version Package
                7.1.X
                Master