Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-82854

Cannot add new web content image reference to article via My Workflow Tasks

    Details

      Description

      Steps to Reproduce:

      1. Configure Web Content to use Single Approver workflow
      2. Add a new structure with an image field
      3. Add a template to show the image
      4. Add a new article with the image structure
      5. Add Select and Upload an image
      6. Submit for Publication
      7. Go to My Workflow Tasks > Assigned to My Roles
      8. Assign to Me
      9. In the task detailed view, click the icon to edit the web content article
      10. Select a new image for the web content
      11. Save
      12. Edit the Title of the Web Content
      13. Click Save again

      Expected Result:
      Previous edit with image change was saved correctly.

      Actual Result:
      Error thrown, "Error: The content references a missing file entry."

      If the user approve the article after Step #11, the image will not display.

      This issue will not occur if the user adds a new image reference via the Web Content application.

        Attachments

          Activity

            People

            Assignee:
            joyce.wang Joyce Wang
            Reporter:
            victor.ware Victor Ware
            Participants of an Issue:
            Recent user:
            Joyce Wang
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 46 weeks, 4 days ago

                Packages

                Version Package
                7.1.X
                Master