Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-83050

Unable to upload image with symbol in title

    Details

      Description

      Description:

      When attempting to add an image with a symbol in the file name (ex. &) for a page logo, the "Current Image" will show, however, there is no image actually showing. Also, the Done button is grayed out and cannot be interacted with.

      Steps to Reproduce:

      1) Download and startup Liferay
      3) Startup Liferay
      4) Navigate to Public or Private pages
      5) Click the ellipsis menu and select Configure
      6) Scroll to the bottom of the page and click Logo
      7) Choose an image to upload with a special character (ex. ata&t.png)
      8) Attempt to select Done

      Expected Results: You can see a preview of the image and, when you click the Done button, you are returned to the Configure page with a logo preview at the bottom.
      Actual Results: The preview does not appear but "Current Image" text appears and the Done button is greyed out.

      Branch:  Reproduced. 6055514df1b45dc7ad0b78792b589253d7586da2
      Master:  Reproduced. 589fa1d1671cc99e612901519c3e3b234abab013

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 27 weeks, 6 days ago

                Packages

                Version Package
                7.0.0 DXP FP57
                7.0.0 DXP SP9
                7.0.X
                7.1.X
                Master