Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-83433

Liferay 7.1 - should read Elasticsearch 6.1 instead of 6 to avoid confusion

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Won't Fix
    • Affects Version/s: 7.1.0 CE GA1, Master
    • Fix Version/s: None
    • Component/s: Accessibility
    • Labels:
      None
    • Fix Priority:
      3

      Description

      According to our Compatibility Matrix, Liferay 7.1 only supports Elasticsearch 6.1. This is different enough from ES 6 that it may cause problems. Liferay 7.0 is the version that supports ES6.

      Steps to reproduce
      1. Go to Control Panel -> Configuration -> System Settings
      2. Under the Platform section, click on Search
      3. Click on the Elasticsearch 6 tab.
      This tab and the menu heading should read 6.1, rather than 6.
      This is very likely to cause confusion as to what version of Elasticsearch that Liferay 7.1 supports because all of our other documentation states the difference in supported versions. Even our Marketplace apps specify these differences:
      https://web.liferay.com/marketplace/-/mp/application/106004266
      https://web.liferay.com/marketplace/-/mp/application/106005350

      Task
      Change the tab and heading to read Elasticsearch 6.1.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 13 weeks, 2 days ago

                Packages

                Version Package