Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-83458

test-dependency-easy-portlet causes portal failling to start

    Details

    • Fix Priority:
      2

      Description

      Step to reproduce:

      1. Palce the test-dependency-able-portlet,test-dependency-baker-portlet,test-dependency-charlie-portlet,test-dependency-dog-portlet,test-dependency-easy-portlet into deploy.
      2. Startup the bundle.

      Expected Result:
      Portal can startup.

      Actaul Result:
      Portal holds long time and fails to start.

      [exec] 16:50:14,637 ERROR [fileinstall-/opt/dev/projects/github/liferay-portal-7.0.x-private/bundles/osgi/war][org_apache_felix_fileinstall:97] Error while starting bundle: webbundle:/opt/dev/projects/github/liferay-portal-7.0.x-private/bundles/osgi/war/test-dependency-easy-portlet.war?Bundle-SymbolicName=test-dependency-easy-portlet&Web-ContextPath=/test-dependency-easy-portlet&protocol=file 
           [exec] org.osgi.framework.BundleException: Could not resolve module: test-dependency-easy-portlet [692]
           [exec]   Unresolved requirement: Import-Package: com.swabunga.spell.engine; resolution:="optional"
           [exec]   Unresolved requirement: Import-Package: com.swabunga.spell.event; resolution:="optional"
           [exec]   Unresolved requirement: Import-Package: net.fortuna.ical4j.model; resolution:="optional"
           [exec]   Unresolved requirement: Import-Package: net.fortuna.ical4j.model.property; resolution:="optional"
           [exec]   Unresolved requirement: Import-Package: org.apache.axis.tools.ant.wsdl; resolution:="optional"
           [exec]   Unresolved requirement: Import-Package: org.apache.bsf; resolution:="optional"
           [exec]   Unresolved requirement: Import-Package: org.apache.poi.hssf.usermodel; resolution:="optional"
           [exec]   Unresolved requirement: Import-Package: org.apache.poi.ss.usermodel; resolution:="optional"
           [exec]   Unresolved requirement: Import-Package: org.apache.portals.bridges.common; resolution:="optional"
           [exec]   Unresolved requirement: Import-Package: org.apache.portals.bridges.struts; resolution:="optional"
           [exec]   Unresolved requirement: Require-Bundle: test-dependency-fox-portlet; bundle-version="7.0.10.1"
           [exec] 
           [exec] 	at org.eclipse.osgi.container.Module.start(Module.java:429)
           [exec] 	at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:402)
           [exec] 	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle(DirectoryWatcher.java:1258)
           [exec] 	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles(DirectoryWatcher.java:1230)
           [exec] 	at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:512)
           [exec] 	at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:361)
           [exec] 	at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:312)
           [exec] 16:50:14,639 ERROR [fileinstall-/opt/dev/projects/github/liferay-portal-7.0.x-private/bundles/osgi/war][org_apache_felix_fileinstall:112] Exiting the JVM 
           [exec] org.osgi.framework.BundleException: Could not resolve module: test-dependency-easy-portlet [692]
           [exec]   Unresolved requirement: Import-Package: com.swabunga.spell.engine; resolution:="optional"
           [exec]   Unresolved requirement: Import-Package: com.swabunga.spell.event; resolution:="optional"
           [exec]   Unresolved requirement: Import-Package: net.fortuna.ical4j.model; resolution:="optional"
           [exec]   Unresolved requirement: Import-Package: net.fortuna.ical4j.model.property; resolution:="optional"
           [exec]   Unresolved requirement: Import-Package: org.apache.axis.tools.ant.wsdl; resolution:="optional"
           [exec]   Unresolved requirement: Import-Package: org.apache.bsf; resolution:="optional"
           [exec]   Unresolved requirement: Import-Package: org.apache.poi.hssf.usermodel; resolution:="optional"
           [exec]   Unresolved requirement: Import-Package: org.apache.poi.ss.usermodel; resolution:="optional"
           [exec]   Unresolved requirement: Import-Package: org.apache.portals.bridges.common; resolution:="optional"
           [exec]   Unresolved requirement: Import-Package: org.apache.portals.bridges.struts; resolution:="optional"
           [exec]   Unresolved requirement: Require-Bundle: test-dependency-fox-portlet; bundle-version="7.0.10.1"
           [exec] 
           [exec] 	at org.eclipse.osgi.container.Module.start(Module.java:429)
           [exec] 	at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:402)
           [exec] 	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle(DirectoryWatcher.java:1258)
           [exec] 	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles(DirectoryWatcher.java:1230)
           [exec] 	at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:512)
           [exec] 	at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:361)
           [exec] 	at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:312)
         [delete] Deleting: /opt/dev/projects/github/liferay-portal-7.0.x-private/jps_output
           [echo] The following error occurred while executing this line:
           [echo] /opt/dev/projects/github/liferay-portal-7.0.x-private/build-test-batch.xml:332: The following error occurred while executing this line:
           [echo] /opt/dev/projects/github/liferay-portal-7.0.x-private/build-test-batch.xml:986: /opt/dev/projects/github/liferay-portal-7.0.x-private/build-test-batch.xml:990: The following error occurred while executing this line:
           [echo] /opt/dev/projects/github/liferay-portal-7.0.x-private/build-test-tomcat.xml:46: The following error occurred while executing this line:
           [echo] /opt/dev/projects/github/liferay-portal-7.0.x-private/build-test-tomcat.xml:54: The following error occurred while executing this line:
           [echo] /opt/dev/projects/github/liferay-portal-7.0.x-private/build-test.xml:9828: The following error occurred while executing this line:
           [echo] /opt/dev/projects/github/liferay-portal-7.0.x-private/build-test.xml:3389: The following error occurred while executing this line:
           [echo] /opt/dev/projects/github/liferay-portal-7.0.x-private/build-test.xml:3506: 
           [echo] exec returned: 1
           [echo] The following error occurred while executing this line:
           [echo] /opt/dev/projects/github/liferay-portal-7.0.x-private/build-test.xml:3991: The following error occurred while executing this line:
           [echo] /opt/dev/projects/github/liferay-portal-7.0.x-private/build-test.xml:4132: Unable to find startup message after 30 minutes.
           [echo] ${jstack.output}
            [get] Getting: http://test-1-16/job/test-portal-acceptance-pullrequest-batch(7.0.x-private)/AXIS_VARIABLE=0,label_exp=!master/13549//consoleText
            [get] To: /opt/dev/projects/github/liferay-portal-7.0.x-private/20180712171817746.txt
         [delete] Deleting: /opt/dev/projects/github/liferay-portal-7.0.x-private/20180712171817746.txt
         [delete] Deleting: /opt/dev/projects/github/liferay-portal-7.0.x-private/null179629313.properties
      

      Testray link:
      https://testray.liferay.com/reports/production/logs/test-1-20/1531410379338/test-portal-acceptance-pullrequest(7.0.x-private)/309/functional-tomcat80-mysql56-jdk8/215/0/jenkins-console.txt.gz

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Days since last comment:
                1 year, 18 weeks, 1 day ago

                Packages

                Version Package